Tuya TYWE1S flash help

Hello everyone,

I recently purchased a Zemismart Smart Curtain kit (exactly this one --> https://it.aliexpress.com/item/4001106838117.html?spm=a2g0o.detail.0.0.321e7401HWwrff&gps-id=pcDetailBottomMoreThisSeller&scm=1007.13339.169870.0&scm_id=1007.13339.169870.0&scm-url=1007.13339.169870.0&pvid=6a1cb4d6-d6c1-4e48-beac-1a197427f328&_t=gps-id:pcDetailBottomMoreThisSeller,scm-url:1007.13339.169870.0,pvid:6a1cb4d6-d6c1-4e48-beac-1a197427f328,tpp_buckets:668%230%23131923%2383_668%23888%233325%2318_668%232846%238116%232002_668%232717%237558%23148_668%231000022185%231000066059%230_668%233468%2315609%23274) which comes with an USB/Wi-Fi dongle.

The USB/Wif-Fi dongle is equipped with a TY-TYWE1S chip:

Which I would like to flash with Tasmota firmware using Tasmotizer and the USB to Serial converter in the picture below:

I noticed that the same USB/Wi-Fi dongle has been flashed as per this guide here --> https://tasmota.github.io/docs/TuyaMCU-Devices/

But I am stuck with the flashing process because I cannot understand what has been soldered to what and I need some help on this.

Specifically I am not able to understand this picture --> https://user-images.githubusercontent.com/43923557/64847157-7899df80-d662-11e9-8133-2c6201658ec2.jpg

He is using an USB to Serial converter which has more connections than mine (for example, D+ and D- are not present in mine, and he is using those to connect U1RX and U1TX).

I successfully flashed TYWE3S chip and Shelly One with the Tasmotizer + USB to Serial converter combo in the past and I am applying the same principles with this TYWE1S chip but without success.

This is the GPIO layout of the TWYE1S chip:

And I am connecting it this way:

Tuya Chip —> USB to Serial converter
IO0 to GND
3V3 to VCC (the USB to Serial converter is set to 3v, not 5v)

By doing this way, Tasmotizer is failing to acquire a connection with the device and I am unable to erase the Tuya firmware on it and replace it with Tasmota.

Can anyone help me out on this, please?

Thank you

1 Like


1 Like

Try U0RX, U0TX

1 Like

Hi yogi1, thank you for the suggestion and the TYWE1S GPIO scheme.

So, I soldered as per these pictures:

And shorted GPIO and GND this way:

(yes, my soldering skills suck)

Then, I connected everything to my USB to Serial converter like this:

3v3 to VCC
GND and IO0 to GND

Unfortunately I am unable to obtain an IP address from Tasmotizer so the flash procedure cannot start:

I am really stuck. What am I doing wrong?

No need Device IP on Tasmotiser. See the link read it carefully from top and go to " Tasmotizer!"


To put the ESP8266 into Programming Mode:
Disconnect serial-to-USB adapter and power
Bridge GPIO0 and GND (by pressing the on-board button or connection with a wire)
Connect the serial-to-USB adapter to your computer
After a few seconds disconnect GPIO0 from GND.
Then go " Tasmotizer!" in link.
Once flashed. Go to
Initial Configuration
Using Web UI
Configure Wi-Fi

1 Like

Once you configure wifi on Tasmota webpage. Your AP mode( no more live. Then you can find Your IP on your router or on “Fing” App.

1 Like

Hello everyone,

I just wanted to post an update on this: turns out I am an idiot.

I spent the last 4 days trying to figure out why I wasn’t able to flash this damn thing.

Yesterday, I grabbed a couple of old Shelly 1 and Sonoff S20 that I had laying around and tried to flash those. I wasn’t able. Baffling, since I flashed those exact items in the past with the same USB to Serial converter, same cables, same software running on the same PC.

I troubleshooted a bit with Tasmotizer and discovered I was failing because it couldn’t communicate on COM1 (I was getting an error message saying that I didn’t have permission on that ///COM1 port).

Turn out that my PC lacked the proper PCI Serial Port drivers (I updated it to Windows 10 20H2). I never needed to download anything in the past and I flashed everything correctly. I grabbed the correct PCI Serial port driver from the web, installed those and restarted Tasmotizer. Now I was able to flash the Zemismart Curtain USB dongle on COM3 port and I finally managed to configure the curtains following this helpful post here --> Curtain Automation

I am now able to control it in HA as if it was a dimmable light and it works just fine!

1 Like

Hi, I tried to follow this guide but it didnt work for me, so I am writing this for anyone else that may buy a Zemismart smart wifi curtain after this post.

The chip in the motor is a TYWE1S but it also had headers on it. So I plugged it into a breadboard and powered it that way and also grounded it. That way I only had to stick TX and RX wires to the chip. Just to clarify, you can use those headers to power the board and by extension, it also powers the chip.

I then powered up the chip by connecting my serial programmer to my PC. I then used one of the ground cables to connect to IOO and then used the other ground gable to connect to reset. All you need to do is just touch the points and hold them. I then let go of reset and clicked tasmotize but kept the wire touching IOO. After I saw the transfer start, I took the cable away from IOO.

Here are some pictures to help. If you look at the headers on the right hand side of the board, they will have letters next to them. I put the power cable from the programmer in the header labelled V and the ground cable from the programmer in the header labelled

Hope this helps someone.

1 Like

Thx @hadeshorn for sharing – worked like a charm on my BCM500DS-TYW
Have you figured out Tasmota Config for this device?

I have it set up for ESPHome, let me know if you need help with that.

@hadeshorn i am interrested in your help freeing my heater.
I want to flash esphome on my tywes1.

  • i conected as you only rx and tx,
  • bridge temporarly io0 to gnd
  • switch on my heater and open web.esphome.io from my chromium browser
  • select my ttyUSB4 device
  • release the bridge
  • then flash

but it always tell me “Failed to initialize. Try resetting your device or holding the BOOT button while selecting your serial port until it starts preparing the installation.”

could you help me ?

i just found that my ground had to be connected between my tywes1 and my usb/serial

ok now i flashed esphome
access and flash it with homeassistant thrue wifi.
but the board does nothing.
i observe that only the first 5 pins vcc, u1tx, u1rx, 3v3 and gnd are connected to my heater board.

this helped me to print debug from urx1 and utx1

to read datas and make a sensor with it i opened a new post How to extract value from uart text sensor

Hi guys. I have this broken TYWE1s stick. is offline and no longer emits blue light.

Is there a possibility to replace it with an esp?