Tuya ZigBee plug turning itself off


I have 2 of these. They paired and worked fine. After a while though they turn themselves off.

I am using Hassio on rpi3. I am also using ZHA.


I don’t see any devices with that brand ( OBSHI ) as being supported or working here, unless they’re under a different name.

Personally, I would stick with devices that are confirmed to work with your integration. Not all Tuya ZigBee devices play nice.

Maybe try for a refund/exchange perhaps ?

Good luck with it :crossed_fingers:

One thing you can try.

Select Configure on the ZHA integration and increase the time before your device becomes unavailable. Then, Update Configuration.

It helped with 2 of my sockets because originally it was a lot lower.


I will try that. They are TS011F devices if that helps. Where is that compatibility list?

I just checked and they are listed as supported.

Okay, that’s good.
Pair the devices again.

Try increasing the time and see if that helps. Other than that, it could be many, many things. Let us know how you go with it :+1:

I have paired them multiple times. I will try the timeout and report back. There are other threads about devices with this chip but spotty resolutions.

Increased the offline timeout and repaired the devices. They are still turning off.

Not good, I see your device as confirmed working with many integrations. What are using for the coordinator? Any errors in your logs perhaps?

@DarthTater, looks like possibly a Tuya firmware issue as reported here.

That is a great resource. I was looking bat how to enable logging from your last post but then I got distracted.

Is there a way to flash new firmware without the tuya gateway?

I think it’s only possible in Tuya app. I have requested they update mine (Elivco UK variant of TS011F_plug_1) from 1.0.10 to see if that fixes the random switch off issue, but they haven’t done so yet. I will keep chatting to them about the issue, in case it’s firmware rather than hardware issue.

Let me know how it goes. I have tried everything and they always turn off after a while.

I have the same issue with TS011F_plug_1 running on Z2M. Newer firmware revisions work just fine. Oddly enough, Z2M reports that device supports OTA updates, however none can be found for it. Will keep digging.

When you say newer firmware revisions work fine did you update firmware on the device or have a different plug that has a newer firmware revision?

I have multiple devices that came pre-flashed with different firmware revisions. See this: TuYa TS011F_plug_3 control via MQTT | Zigbee2MQTT - it says that after 1.0.5 the power reporting is broken and needs polling. The polling thing is irrelevant, however they describe how the differentiation between TSF011F_plug_1 (pre 1.0.5) and TSF011F_plug_3 (1.0.5 or higher) is done. That said, the plug_3 models all work fine for me, however the ones reported as plug_1 are randomly powering off.

1 Like

I think it might be the other way round. In the Tuya app, the problematic plugs are FW v1.0.10 (latest according to Tuya) and the working ones are FW v1.0.4. The 1.0.10 FW is seen as plug_1 in Z2M. As you say, plug_3 seems to work, for me too in Z2M. This might be a Z2M naming issue, but it’s actually Tuya FW 1.0.10 that fail, if you put them in Smart Life app to see the real FW ver.

I’m currently talking to Tuya about the issue. They are trying to bounce me back to the supplier, but it seems there is a wider chipset issue, not a vendor issue.

Do you know of a supplier that is selling the good ones? I don’t have a tuya hub so can’t check or update firmware.

No sorry I don’t. It’s likely they are increasingly on this newer FW… if it is indeed a FW isssue, not dodgy hardware.