Tuya ZigBee Smart Plug with Energy monitoring

I’m about to buy one of those plug :
TUYA TS011F : Tuya Smart Plug 16A EU TS011F Zigbee compatibility
NEO NAS WR01B : https://zigbee.blakadder.com/Neo_NAS-WR01B.html
Question :
With TS011F, I read you are able to get POWER (W), but do you get the energy (Kwh) ?
Which plug with power energy do you recommend ?
I have choice between :

  1. NAS WR01B (+/- 10€)
  2. TS011F (+/-10€)
  3. NAS ER01B (+/-17€) : I read some critic about whistling noise
    For me the most important is the instant power in kW and cumulative energy in kWh by day, week, month

Do not buy the TS011F
I have 14 of them and they al switch off at random (even if their is no hub/coordinator)
Sometimes they keep working good for days/weeks but you cant use them for devices that must always be powered on like a modem / router / fridge / freezer


Very quickly, almost instantly
I use a conbee stick with it and you can configure the refresh time in seconds with the build-in DDF Editor. I believe the default is 30 seconds but you can set it to 1 sec if you want.
Keep in mind that zigbee has a limited bandwidth and if you have many devices then setting it to 1 second will fail refresh values often.

I have 9 plugs TS011F and they did not turn off once. This was a bug that was patched.

Also I use zigbee2mqtt and you can set their refresh rate to 1s. I set them all without any troubles. Plugs are routers, they do not have any problems to pass data constantly through the network.

Did you update the firmware of your TS011F?

No I did not upgrade them.
It says version 74 in HA and some say version 1.0.10
I got _TZ3000_typdpbpg and _TZ3000_cehuw1lw

Also I have two bricked version 68 plugs I tried to upgrade (with wrong firmware I presume)

BTW I am not the only one having problems with those plugs see

I am using z2m and the TS011F does not show its firmware vesion there but it is shown in HA, which is capable to update it. I am using them everywhere, from Synology NAS, dishwasher, washing machine, refrigerator, DLP projector… it never turned off. It is zigbee version and I bought it in two batches from China.

So update them and give it a try. They are great. You can set a lot of configurations in z2m including 1sec refresh and I do not see any troubles here. Solved my problem 5eur instead of 30eur per piece.

With Zigbee2MQTT, are you able to have directly the energy in (k)wh in HA.
I mean, you don’t need to use a " Riemann" to calculate the energy based on power.
It is better to have the cumulative energy coming from the device so in case HA is shutdown or Network is down then the energy will be restored with exact value from the device.
With this : https://zigbee.blakadder.com/Tuya_TS011F.html
With this : https://zigbee.blakadder.com/Neo_NAS-WR01B.html
Can you confirm which device will provide energy and power separately ?
Thank to help me to choice the best device. i have +/- 10 to order.

Curently, I have MEROSS MSS310 (witch are not zigbee) and I don’t get energy (only power, but it is useless. Most important is energy).

Tuya_TS011F.html show Volt, Amp, Watt and kWh separately native
Also you can calculate Watt from Volt*AMP and calculate Amp from Watt/Volt like this;

1 Like

So I have given firmware update another try. Updatet all 14 plugs to version 192.

Hi all,

Am in the market for a Zigbee smart plug, and would like to ask existing users some questions.

  1. I am using SkyConnect stick in HA, and need to create power-on schedules for my espresso machine. Can schedule configuration be done the Tuya app through the SkyConnect stick? Will the Tuya iOS app work in the absence of a Tuya Zigbee gateway?

  2. Are the power schedules on-device, and if they work even without Internet access? The smart plug will be powered on 24/7.

  3. Is there any way to amend timer schedules via HA? My ultimate aim is to create an automation, such that the power schedules are adjusted against my calendar.

1 Like

Hello all,

I’m in the market for some more smart plugs, and since most of the ones that are being offered (that are also not that expensive), are some kind of Tuya derivative (like the Blitzwolf ones).
However, since there are some warnings about them turning off/on at random, I am doubing a bit whether or not to drop some cash into them.

Additionally, the comments here TuYa TS011F_plug_1 control via MQTT | Zigbee2MQTT are putting me off a bit.

What are your experiences? Has the off/on been solved? Am I worrying too much about it?


Hi All,

I have 9 of these plugs operational as well and I switched from z2m to zha recently. What I didn’t notice until now is that the plugs are repeatedly reporting energy. It’s driving my network a bit crazy. Is there a zigbee control command to set the measurement reporting status? I did find one in the documentation of z2m, but as I’m running zha now, I can’t seem to find this command anywhere in ZHA.


Hi Roy,

How did you update the firmware of the plugs?


So is the moral here that HA can’t pick up energy monitoring signals from zigbee devices without a bridge translating the sensor readings to mqtt messages?

Just bought 6 “Bseed” TS011F_plug_1 _TZ3000_o1jzcxou – Updated firmware to latest 192 I think it was - none of them show any values for power/voltage/etc “metering”. Using z2m. Any ideas?

Same problem here, just bought this model :


Doesn’t report any metering even if I bought the power metering model. I’m using ZHA and did the firmware update (0x000000c0) available since 2024.3 but it’s not better

If someone have an idea would be appreciated

It seems the firmware update makes new clusters available when appairing again, but power sensors still do not work. Child lock is working. I tried to add it to a new HA instance with Z2M, same result…

I sent an email to BSEED to try to get technical support, wait and see their answer


I’m experiencing the same issue. Did you get any reply from BSEED support?

Bseed support told me that I selected the version without power monitoring. I was pretty sure I selected the right one though so I’m suspicious. The order history confirmed that the model wrongly chosen was the one without power monitoring… Did I made a mistake or the order was modified afterwards ? I’m not 100% sure, but I’ll be extra careful next time and I’ll take screenshots !