Two integration issues

Hi guys,

I recently switched over to HA from Homebridge/HomeKit and everything has been working so well I can’t believe how much better it is setting everything up and how well it all works.

I have two integrations that I can’t seem to figure out though…

  1. VeSync - I add the integration but it does not pull in my device which is a Levoit Core 400S. From what I can tell support has been added for this device but for some reason it does not show up when I install the integration. It works through a Homebridge plugin using VeSync so I’m not really sure what’s going wrong. Nothing shows up in the logs either indicating an error.

  2. Xiaomi miio - I know there has been some recent development on this front to include all models of the Roborock vacuums but mine simply will not configure. I have a Roborock E4. I have the token and IP address but it will not let me add the device. It seems like HA cannot connect to the device with the given info or maybe this model is simply not supported still/at all?

Thank you guys for reading!

EDIT to add system info:

Version: core-2021.11.2
Installation Type: Home Assistant OS
Host Operating System: Home Assistant OS 6.6
Update Channel: stable
Supervisor Version: supervisor-2021.10.8

For the Xiaomi, are you using the new integration? Nowadays you enter your cloud username/password and server country rather than token and IP address. That works for me.

I have tried all of the available integrations including the one provided in HACS. I get stuck trying to use the login because it needs to send me a code to login and the UI doesn’t seem to have that functionality.

I do have the token and IP address of the vacuum but it doesn’t let me connect with that info.

I tried dropping the files from the core package into custom_components and adding my vacuum to the but HA complains that it can’t launch the integration because the config flow if I do that.

I am so confused about this vesync issue. If I install plugins (homebridge-levoit-air-purifier and homebridge-levoitcore-client) for vesync on homebridge they can both pull in my purifier without issue. I thought I could maybe just use homebridge and use it to connect the purifier to Home Assistant but it only shows the air quality and no fan controls.

It’s the same API so I’m at a loss. Anyone have ideas how I can troubleshoot this issue?

Did you ever get your E4 working? My S4 works great, but the E4 responds to commands (clean,stop, etc) but will not update sensors.

My E4 is now connected and shows Home/Away but does not respond to commands.

The issue was/is the way HA identified the model from the data returned by the Python library.

I’m working on updating this integration (on the shoulders of others). Currently it (hopefully) works for all humidifiers, but a similar fix will be needed for the fans so all models in the library work with HA. I don’t have a fan so to do it, I’d need a tester (or 2).

I have a test repo and created a new topic. VeSync development particularly for Levoit Humdifiers