Unable to Access HA

Hello everyone,

Thank you for taking the time to read this and giving me a hand, I just started and I’m bummed by what just happened. I’ll try to keep it clear and simple.

What I’m trying to do:
Access my HA via http://hassio.local:8123 (or any other address).

What I get:
I’ve tried on different machines and browsers but the result is either an error or infinite loading with usually the following error displayed:

I once got the HA logo and an error message that it was not able to access with a retry button (I apologize the message was displayed shortly I didn’t have time to take a screenshot).

What I’ve tried:

My Configuration:

  • Raspberry Pi 3 B+
  • Hass.io (installed following the “getting started” instructions
  • Aeotec Z-Stick Gen5
  • The installation worked fine and I did not change anything in my config file. I actually did not change anything, I got everything working and setup, did not touch anything, tried to reconnect a few weeks later and got this error.
  • I did not check the exact version of Hass.io but I did a fresh install on 10/16/19 and did not change anything since.

Does Windows have an mDNS resolver nowadays? I remember I needed to install Bonjour to be able to go to any mDNS address (e.g. the blahblah.local).

Try connecting to the IP address, e.g. 192.168.1.XXX:8123 instead. Check your router for the IP address or do an ifconfig on your Pi’s serial terminal to check what IP address it got.


Whoops, I better read your post properly next time. So even with the IP it doesn’t work? Can you connect over SSH to the pi and check the HA logs? Can you check that HA is up and running?

Thanks Skye for the answer!
So I really just started and do not know SSH or how to access it or enable it. If you have a post that details how to do that I’d be happy to give it a try :slight_smile:

You said you tried to access the samba share using \\hassio.local\config and it refused the connection. Did you try again using its IP address? Assuming it is then use \\\config

If that fails then whatever it is you did prior to this problem has effectively locked you out of the system. Did you install the SSH plugin? If you didn’t then you are definitely locked out and, as far as I know, the only solution is to re-install everything from scratch.

Thank you for taking the time. I just checked with the IP and I get the exact same error as when using \\hassio.local\config

Does HASSIO something like switching lights? Are you sure the system is running and did boot up? SD Card failure?

That’s not encouraging news.

Unless you installed the SSH Server add-on, I believe you are now locked out of the system.

So on the Pi itself, I can see the LED for the Ethernet port blinking as well as the LED for the power it is solid red. The Z stick is also blinking like the usual. I can also see it on my network so I suppose the hardware side should be fine.

Thanks for the link! If nothing works I will just try to do a fresh install again. Is there a tutorial on how to backup everything?
I struggled for a good bit to get everything neat and working so if I have to do that again it would be great to have a backup.
Is it also something common that can happen? I have a small setup for now so the reinstall is not that big of an issue, but if I start to really rely on HA this could be a serious one. Especially if I’m away.

I don’t use HASS.IO but I understand it has a feature called snapshots. You can create a snapshot and restore from one. In fact, the documentation recommends that you create a snapshot prior to updating Home Assistant. In the event there’s a problem with the new version, you can restore the snapshot and everything reverts to its previous state.

Be advised that the snapshots are (to the best of my knowledge) stored on the host computer (your RPi) unless configured to do otherwise (and, as a non-HASS.IO user, that’s stretching the limits of my knowledge of snapshots)

In the event Home Assistant fails to start, you’ll still be in the current situation (locked out) unless you can connect to the RPi via SSH. Therefore, you ought to install the SSH Server add-on (and learn how to use it) as insurance for the future. Upon connecting to the RPi via SSH, you can manage things using the command-line:


… and if I’m wrong on any point, I encourage HASS.IO users to correct me. I only have ‘book knowledge’ about it and not practical ‘hands-on’ expertise.

1 Like

Thanks for all the links! That makes sense and the snapshot looks like a great help to remedy that.
And I will absolutely install the SSH add-on from now on :smiley:
I’ll wait a little bit to see if someone else has an idea, if not I will mark your message as the solution.
I really appreciate the help!

1 Like

Log into your router and see what IP address has been assigned to your Pi. Enter the IP address listed along with :8123 and you will be able to log in there. Certain routers do not allow the hassio.local address.

Hi Kyle, thanks for the input but unfortunately this has been tried already and did not work.

You don’t say how far along you were with the installation before you got locked out. Try using both http://yourIP:8123 AND https://yourIP.8123.

So I have been jumping around looking at several posts about this issue…
You solved it for me!
I have only been able to access my HA via my DuckDNS… whenever I tried hassio.local:8123 or my_ip:8123 it didn’t happen…
Using https:// works with both my_ip or hassio.local:8123

1 Like

Great when you find the solution - very frustrating when everything seems to be working, but you can’t access the frontend…

I know this thread is quite old - but I am experiencing the same problem: Not able to open HA.

Not via duckdns, not via the local hostname and not even by entering the ip. My router and lan scanner report the pi as online, and its leds also look stable (constant red and some blinking on lan and sd). Im totally lost now…

When pluging the sd card into my mac - its not readable, i hoped to at least be able to backup my settings. Trying to mounting and saving it now with the help of osxfuse.

If anyone has any other ideas - please let me know.