Unable to access http://hassio.local:8123

I installed Hassbian but unable to reach http://hassio.local:8123 any suggestions?

I have raspberry pi 3 B+ with hassbian running, samba too but no hass.io. Any help is much appreciated.

Ran command sudo systemctl restart [email protected] but no luck.

did you try its IP address

1 Like

I did indeed but did not work.

can you ssh into it try a reboot form the command line.

if new install did you wait the 20min+ just checking

I don’t understand why I need to reboot from ssh if I am still in my wifi network. I waited that much time till it came up. It did for a while last Saturday but then it stopped working.

They aren’t running hassio, so there is no ‘20 min’ wait

Are you sure it would be hassio.local since, you know, you didn’t install hassio?

Why not just use the IP address?

When you use the ‘name’ of it, you are relying on your router to resolve the name to the IP, but in a lot of cases the router does not support the protocols needed.

Just use the IP address and port to browse to.

Following the hassbian installation docs you should use http://hassbian.local:8123 or the ip address of course

I tried also with the IP address. I understand that if I have RPi3 B+ I can only install Hassbian. With Hassbian the HA runs in a virtual environment from Hassbian image. The question is what is the command to invoke that environment? I’m sure I’m doing something wrong here. Trying to figure out what it is. I was expecting to have the virtual environment to come up in my chrome browser when I browsed to HTTP://myIP:8123

Which I did indeed. Up until last Saturday but then I “lost” it. Question: could it be that in attempting to connect to Google home assistant I entered some lines of code in my configuration.yaml that caused this issue?
I made sure the line: config: is in it too.

If the problem started after you changed your config you should check the log and post your config.

You should read the logs and see why it is failing…no amount of ‘restarting’ the service is going to bring up Home Assistant if the config has errors

What happens when you run from the command prompt?
sudo systemctl status [email protected] -l

Do you see a line the that refers to the configuration.yaml file re. an error?

When I restart HA I get:

Failed to restart home-assistant.service: Unit home-assistant.service not found.

Very strange. I can go to the /home/homeassistant directory and see no files. Not sure if it is supposed to be empty though.

I’m really curious if you even went through the directions.

https://www.home-assistant.io/docs/installation/hassbian/installation/

Have you ‘installed’ the service yet, per the instructions?

Well, the ‘config’ directory is a hidden directory, as notated by the . before it. ls -la should show you ALL files/directories inside that directory.

But if you haven’t actually followed the directions, there may not be anything there anyway.

Got good news but at the same time I got puzzled by it. It worked when I tried IE instead of Chrome. Someone please help me understand why. Any configuration setting somewhere? Anyhow, I just don’t see the tabs across with the Addon. Perhaps that virtual environment does not show the same layout like if I had hassio running from the docker?!

Because you are NOT running hassio, you will not see any hassio tab or any addons, or anything related to hassio, because you aren’t running hassio.

If you want hassio addons and the hassio tab, you HAVE to run hassio.

I suspected I wasn’t running it because of all the videos I watched so far, don’t look the same to what I have. Nonetheless, how can I invoke the virtual environment then? Just point me to find material so I can delve into it. A link to some site, YouTube.

Thank you in advance

Gino

Hi Gino (i’m italian too)…did you solve your problems?
I have Raspberry Pi 3 b+ and i cannot connect to HA per browser (i use safari).
I cannot find any solutions…in another topic another RP3b+ user had to buy 3 model (the old one) to use correctly HA…i would’t do the same if it’s possible.
Please…if u can…help me!!!

You read the directions right? Along with the warning?

The recently released Raspberry Pi 3 model B+ is not yet supported.

Are you trying to use hassio or hassbian?

If you have a 3b+ you have to use hassbian, or run raspbian and install home assistant in a python environment.

Either way, you would not access hassio.local, because you aren’t running hassio.

Same problem here.

Nw RP B+

Cannot start om my.IP:8123 or hassbian.local:8123

Not on Ipad with Crome nor PC Win7 with Crome of IE

I do see it with Fing and can ping it