Unable to clean shutdown / reboot on Intel NUC DN2820FYK

I have the same issue as mentioned in the post below with HASS OS running direct on my NUC :

I’ve tried another NUC / drive thinking there might be an issue with the drive, however it does exactly the same (same model NUC with snapshot loaded). No clean power off or reboot gets stuck at the same place needing a hard reset.
It has worked before, however I don’t reboot the host very often. Any ideas ?

I don’t use virtualization, but it would seem that you are shutting down the virtual OS and not the host.

Just guessing because I don’t use any virtual environments.

This is HASS OS running direct on the NUC, no virtualisation as such.

OK, I misread your post.
How are you shutting down the host?

I rarely need to reboot my NUC, let alone shutdown. But this is how I do it:

Morning Stephen, normally this way and I have tried via CLI with ha host reboot or shutdown to no avail.

Have you considered doing a BIOS reset? (Write down your current settings first).
Also, do you get any errors flashing by as the shutdown progresses?

There could be a daemon or service not properly shutting down that could interfere with the normal shutdown process.

I DO NOT know if this will work, but you could try shutting down from the command line and redirect the output to a text file. Actually, try
ha host reboot > /share/reboot_stuff.txt first.
ha host shutdown > /share/shutdown_stuff.txt

I don’t know if this will work, but I don’t think it will hurt either.
(I tested it with
ha hardware info > /share/hardwareinfo.txt
and since Home Assistant shares this folder, I could see the file from my PC).

If it doesn’t shutdown, try the power button again and see if the text file closed.

Thanks, I’ll give it all a go this weekend. I have 2 of the same NUCs with the same setup so at least I can test one to destruction !