Unable to configure Plex

My plex local server was discovered, so I finally got around to pressing the Configure button. It asked me for a token, so I followed the instructions here

and logged into plex and got my token on screen - it started claim-XXXX

I copied that to the dialog, set SSL to true and verify to false, as I do not have a valid SSL cert. I then get the message - Failed to register, try again’

I’ve tried all the combinations of true/false. What I see in home_assistant.log on the server is the following line appearing

2019-05-25 04:34:19 WARNING (SyncWorker_4) [plexapi] BadRequest (401) unauthorized; Unauthorized

401 Unauthorized

so, it it correctly calling my Plex instance, but the token appears to be wrong.

I set this up last week with the latest download of HASS.io, I can’t see the version anywhere.

Plex server is version running on a Netgear 314 NAS

After more googling, I found in chrome dev tools, an X-Plex-Token in a request I had made to my Plex server, so I added that and now it seemed to work. However, now my Plex icon in my overview has an orange ‘Error’ in the circle and ‘Entity Not Found’ .

Not sure where I need to go from here.


I have exact same issue any help would be lovely

Same Here. Unable to configure Plex Media
The pop up comes up asking for
1- Token
2 - SSL - true or false
3 - verify - true or false

Does not matter what I put in SSL and verify, the error is
Failed to Call service configurator/configure. invalid Boolean value none

This is in the log

BadRequest (401) unauthorized; <html><head><script>window.location = window.location.href.match(/(^.+\/)[^\/]*$/)[1] + 'web/index.html';</script><title>Unauthorized</title></head><body><h1>401 Unauthorized</h1></body></htm

Hope someone can help
@frenck maybe you could offer some thoughts please? cheers guys

This is the error log

Wed Jul 17 2019 12:08:18 GMT+1200 (New Zealand Standard Time)
invalid boolean value fase
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/websocket_api/commands.py", line 121, in handle_call_service
  File "/usr/src/homeassistant/homeassistant/core.py", line 1150, in async_call
    self._execute_service(handler, service_call))
  File "/usr/src/homeassistant/homeassistant/core.py", line 1172, in _execute_service
    await handler.func(service_call)
  File "/usr/src/homeassistant/homeassistant/components/configurator/__init__.py", line 221, in async_handle_service_call
    call.data.get(ATTR_FIELDS, {}))
  File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/homeassistant/homeassistant/components/plex/media_player.py", line 243, in plex_configuration_callback
  File "/usr/src/homeassistant/homeassistant/helpers/config_validation.py", line 95, in boolean
    raise vol.Invalid('invalid boolean value {}'.format(value))
voluptuous.error.Invalid: invalid boolean value fase

I’m having the same problem. Did anyone file a bug report?

Im also having the same problem

Same here

Failed to call service configurator/configure. invalid boolean value None

Same problem here

Another “me too”

Same problem!

Are you guys able to access plex via your web browser?

I’m having the same issue and yes can access plex via web browser.

You may need to follow these steps:

I’m having the same issue with the service call responding:

Failed to call service configurator/configure. invalid boolean value None

I’ve tried various combinations of true/false and on/off for SSL entries.

I can get to my plex server otherwise in my browser, and Homeassistant clearly knows about it because if gives me the option to configure it.

See my previous post it has tips to fix it.

this does not work for me. I have access to server and full control over Plex via web and my Synology. removing the authorised devices did not fix the Failed to call service configurator/configure. invalid boolean value None issue.

What do your plex logs show?

Doesn’t seem to be hitting Plex at all, the error that’s generated from HomeAssistant is as follows:

invalid boolean value None

2:36 PM helpers/config_validation.py (ERROR)

So you are not getting the BadRequest (401) unauthorized error like @brucys?

Try this command from your HomeAssistant device:
wget http://YOUR_PLEX_IP:32400/?X-Plex-Token=YOURTOKENVALUEHERE

See what that says.

I am getting same error. Below is what I get when run the command firstof9 asked to be ran:

–2019-07-27 15:48:03--
Connecting to… connected.
HTTP request sent, awaiting response… 200 OK
Length: 5669 (5.5K) [text/xml]
Saving to: ‘index.html?X-Plex-Token=MYTOKENREMOVED’

index.html?X-Plex-Token=MYTOKENREMOVED 100%[=================================================================>] 5.54K --.-KB/s in 0s

2019-07-27 15:48:03 (458 MB/s) - ‘index.html?X-Plex-Token=MYTOKENREMOVED’ saved [5669/5669]

can you nano or cat the file and see if it is outputting a 401 page or something else?