Unable to connect to Mariadb installed on Synology

Tags: #<Tag:0x00007fc40c59a4c0>

I am struggling to connect Mariadb installed on a Synology. MariabDB10 has been installed successfully. I am able to create a user via phpmyadmin. I can connect to the DB using the Synology CLI. But when I try to connect via HA (HA is install on a rpi on the same network as the Synology), I get this error.

Error 2002 (HY000): Can't connect to MySQL server on '192.168.1.50' (115)

On Synology: I have edited the my.cnf file to read either one

bind-address = 0.0.0.0 
or
bind-address = 192.168.1.50

On HA: I use this cmd to test connect to Mariadb

mysql -h 192.168.1.50 -P 3307 -u some_user -p

phpmyadmin: This is the user I have created for HA.
2021-07-22_9-42-38

try with

[mysqld]

bind-address=0.0.0.0

skip-networking=0
skip-bind-address

changed to this:

[mysqld]
bind-address=0.0.0.0
skip-networking=0
skip-bind-address
max_allowed_packet = 1073741824

Still error:
2021-07-22_13-18-34

Arg. Found the answer here. Synology had by default disabled port 3307 in the Mariadb app. Need to enable it.

You’re positive your MariaDB is using port 3307? Default is 3306.
If so, be careful to specify this port on the HA configuration as well…

You’re positive your MariaDB is using port 3307? Default is 3306.

From what I have read, MariaDB5 uses 3306 and MariaDB10 uses 3307 by default. When I enable the port under the MariaDB app, it has 3307 stated already.

This will be under recorder. Hope is right.

secret file:

MySQL_login: 'mysql+pymysql://username:[email protected]:3307/db_hassio?charset=utf8mb4'

Yeah, seems to be a synoloy thing…

just wondering why you used mysql+pymysql?

I don’t know why I chose this one and I have not tested to see if it connects.
Which one is correct one to use?

Seems I do not need the pymysql part. This below works for MariaDB.

MySQL_login: 'mysql://username:[email protected]:3307/db_hassio?charset=utf8mb4'