Unable to load schema from 'http://schemas.home-assistant.io/integration-automation': No content.YAML(768)

I use VS Code on my local machine and access my HA via SSH. Within VS Code I have installed “Home Assistant Config Helper” to have the ability to check code and insert entities.

Lately (I believe around HAOS 9.5) I have error messages in VS Code for config.yaml:
Unable to load schema from ‘http://schemas.home-assistant.io/integration-automation’: No content.YAML(768)
and automation.yaml:
Unable to load schema from ‘http://schemas.home-assistant.io/integration-automation’: No content.YAML(768)

Home Assistant itself does not have any problem nor does the VS Code add-on.
I do not know why the helper is referring to a http site (there is nothing there). I have already removed and reinstalled the HA Config Helper but no result. Any tips on further troubleshooting?


Same- I’ve been trying to sort out if I did something in my VSCode configs, so far everything is clean. Any suggestions from the community?

Home Assistant 2023.3.6
Supervisor 2023.04.0
Operating System 9.5
Frontend 20230309.1 - latest

Downgrade to Home Assistant Config Helper v1.35.0 helped for now.


I am getting the identical message in the edit window of the Home Assistant Community Add-on: Studio Code Server, version 5.5.7.

This is the startup log of the code-server
s6-rc: info: service fix-attrs: starting
s6-rc: info: service base-addon-timezone: starting
s6-rc: info: service base-addon-log-level: starting
s6-rc: info: service fix-attrs successfully started
[12:08:21] INFO: Configuring timezone (America/New_York)…
Log level is set to INFO
s6-rc: info: service base-addon-log-level successfully started
s6-rc: info: service base-addon-timezone successfully started
s6-rc: info: service legacy-cont-init: starting
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service init-user: starting
s6-rc: info: service init-mysql: starting
s6-rc: info: service init-mosquitto: starting
s6-rc: info: service init-code-server: starting
s6-rc: info: service init-mysql successfully started
s6-rc: info: service init-code-server successfully started
s6-rc: info: service init-user successfully started
s6-rc: info: service code-server: starting
s6-rc: info: service code-server successfully started
[12:08:23] INFO: Starting code-server…
s6-rc: info: service init-mosquitto successfully started
s6-rc: info: service legacy-services: starting
s6-rc: info: service legacy-services successfully started
[2023-04-21T16:08:26.383Z] info Wrote default config file to ~/.config/code-server/config.yaml
[2023-04-21T16:08:28.205Z] info code-server 4.11.0 85e083580dec27ef19827ff42d3c9257d56ea7e3
[2023-04-21T16:08:28.208Z] info Using user-data-dir /data/vscode
[2023-04-21T16:08:28.289Z] info Using config file ~/.config/code-server/config.yaml
[2023-04-21T16:08:28.289Z] info HTTP server listening on
[2023-04-21T16:08:28.290Z] info - Authentication is disabled
[2023-04-21T16:08:28.290Z] info - Not serving HTTPS
Then, when an edit window is started, the log shows this:
[12:08:33] Extension host agent started.
[12:08:34] [][9a00a88c][ManagementConnection] New connection established.
[12:08:35] [][465c5cb6][ExtensionHostConnection] New connection established.
File not found: /usr/local/lib/code-server/lib/vscode/extensions/keesschollaart.vscode-home-assistant-1.35.1/jinja-language-configuration.json

I do not use add-on Home Assistant Config Helper
Home Assistant 2023.4.6
Supervisor 2023.04.0
Operating System 10.0
Frontend 20230411.1 - latest

Can you please explain briefly how to do that in HA? I have only “disable” and "disable (workspace) options for this…

Under the button “Uinstall” there is an option to install an other version if you are running VSCode on your computer. For the VSCode addon one has to downgrade the addon.

Hm… there is no “uninstall” option for Home Assistant Config Helper extension under extensions in studio code server inside HA, that’s why i asked…
but, i managed to “go back” with downgrading whole Studio code server, though…

Hope this will be magically fixed by an update without user intervention… Unable to load schema from 'http://schemas.home-assistant.io/configuration' · Issue #615 · hassio-addons/addon-vscode · GitHub

Noticed same thing as well today

1 Like

Any one knows where to fin the Uinstall button?

As far as i found from my searches you can’t uninstall only that addon, so only option is to roll back whole studio code server to previous version.

That’s what I understand also.
How, then, does one install one-version-back? What mechanism allows for that?

Well, when you updated studio code HA probably made a backup (depends on your installation, though…). Check under system - backup if you have a backup and restore. If not….you’re stuck, i guess…

Well, it seems I am suffering from an acute case of operator headspace.

forgot all about those backup thingys :slight_smile:

Same error here, what is the actual reason for this, is there one guru who can solve this the proper way. Think it deserves attention of the developers.
And is there a problem when this is in your templates sensors? Or does it all function and can be edited only that ugly error is there? Or does it have repercussions?

So far, the editing has not been affected. The features that I use still seem to work. It’s rather annoying for sure.

Attempting to roll back to previous version (5.5.6) to see if it’s the new version or something else.

I think it says itself, it is looking for all entities script in http://schemas.home-assistant.io/configuration but when you do a search for this internet folder, there is none. So I guess that is what triggers this error, visual studio is looking at the wrong place, guess that should be fixable.

Just “downgraded” to 5.5.6 and the error message is not present.
So it would appear that the problem is related to the 5.5.7 release of the VS Code Server add-on

No idea how-to downgrade, and it seems to me the best solution is solving the reason why this occurs. Before you make a new version public. Guess the developers know what they changed and then know where the fault lies.

Can you describe how to downgrade, I tried following these instructions and it did not work – How to downgrade addons? - #20 by krystof.k