Unable to reach the home assistant cloud - Nabu Casa

Tags: #<Tag:0x00007fc40ba9d798> #<Tag:0x00007fc40ba9d680> #<Tag:0x00007fc40ba9d5b8>

Hello everyone,

I need help before getting crazy!
I’ve decided to subscribe to the cloud to remote access and support Home assistant team.
But after lot’s of tries, and a real dedicated Public IP (and not a shared “private” CG-NAT), I always get the message “Unable to reach the home asistant cloud”.
I’ve tried to access to https://cloud.nabucasa.com from 6 different devices in my network, and I always get a error 404 too. So it seems to come from my network itself (?).
My ISP give me a Dynamic dedicated Public IP. They’re only offering fixed IP for very big extra fees (hundreds per month!). The rooter is a Firtz! and Home assistant is installed with Virtual Box on a Nac.

I really want to find a solution.

Thank you

Hi,
wherer do you got this link from?
My HA points me to https://account.nabucasa.com respectively https://auth.nabucasa.com

Hi Joerg,
I‘ve seen it on other topics, saying that we can’t reach the home assistant cloud if we have the error 404 message with this link.

Ah okay, I see.
Well, I can’t reach this link either (also get a 404) but the Nabu Casa connection to my HA is up an running.

ps
can you reach the other links?

Found this on the Nabu Casa Site - I know you don’t run VM, but you might give it a try if you can’t reach it at all:

I’m able to access to my Nabu Casa account but not to activate the remote control.
I’m not home, I’m back in a few hours and will try.

Exactly, I’ve seen that too and tried already. But my router attribute a IPv6 anyway. I’ve to try again to desactivate IPv6 with another way.

Something else: My home assistant is connected through an access point. I’ll try directly with the router.

This might be the issue. Bridging rarely works over wifi.

Your Home Assistant box is a server. It should have a wired LAN connection for reliability.

2 Likes

Okay thanks, I try that in a few hours.

Could an Ethernet bridge be a problem too? Or have I to be directly connected with the main router?

Theoretically it should work with WIFI or bridged, etc.
But as Tom said : since you have access to the router, wired it. By this you (and we) can rule out other issues.
When I started with HA two years ago, I set it up with WIFI but soon switched to wired. No issues at all since then.
If it works on the router, you later can try it bridged and see if it runs stable.

look here

you dont need to change anything on your router

I’ve moved my HA NAC and a screen to wire it directly with the router.
But I always have the same issue.

So I’ve tried both : with wifi and directly plug in the router. But it’s still the same message : unable to reach the home assistant cloud :slightly_frowning_face:

As I said, HA is installed on a Windows NAC and run with VB. I’m thinking about: I’ve Norton installed on it. Its Firewall give the permission to VB to run. But could Norton create a problem?

I don’t need to change anything to my router. So why is it unable to reach the cloud with IPv4 for HA and a dynamic public IP?

Edit: I‘ve understand later that you think I can log in. But I can’t. I receive this message (Unable to reach the cloud) when I want to log in to the cloud in Home assistant, so I have no access to this page.

Having a dynamic ip is irrelevant.

PS you do have remote control turned on?

Okay. But public or CG-NAT was :wink:

I can’t turn on the remote control because I can’t reach the cloud.

What version of home assistant are you using?

I do not know what this means. I think you mean cg-nat and “public” are problems.

Nabu casa works through cg-nat.

I don’t know what "public " means in this context.

I’m using core-2021.3.4

For some rare ISP like mine, the fixed IP is called "public IP " and the CG-NAT is called "private IP ". It’s not important.

Nabu Casa say that there are connexion problems with CG-NAT (see the capture), that’s why I had to fix that first :wink:

That page is not talking about nabu casa remote access.