Unable to remotely connect to Home Assistant with the new iOS app (1.5)

Tags: #<Tag:0x00007f46436afa00>

I’m new to this, but I got remote access working with Hass.io by enabling the Duck DNS add-on (with Let’s Encrypt) and opening a port on my router. When I use the new URL (https://xxx.duckdns.org:8123), it works fine from my phone in Safari, but not with the native iOS app. I just get the error “Connection Error / The request timed out.”. I copied fullchain.pem over to my phone and added to Profile & Device Management, but that didn’t seem to make a difference.

Any tips on how I can securely and remotely access Home Assistant with the new iOS app? Thanks!

Which version of the app are you on?

In the url enter: https:xxx.duckdns.org:8123

Then click validate and save connection settings.

You should be taken to the HA homepage to login. Enter your creditiails, login and save the login (lower right corner)

@silvrr thanks for the help — when I hit validate I get the error “Shared.TokenManager.TokenError error 1”. I’m using version 1.5 of the Home Assistant for iOS app (directly from the App Store) and 0.85.1 of Home Assistant.

Note that I had it working with the iOS app before I enabled HTTPS and just used the local address of my Raspberry Pi (e.g. https://192.168.1.XXX:8123).

Can you reset the app? (down the bottom of the settings page)

Thanks @DavidFW1960. I tried that, but no luck. I also tried uninstalling and reinstalling the app, no luck.

I read in the forums that @petermj had a similar problem. Were you able to resolve it, Peter?

It’s documented that self-signed SSL certificates will not work due to Apple’s limitations, but my understanding is that Let’s Encrypt should work because it’s an actual Certificate Authority. I’d love to know if others were able to get this to work with Hass.io / Duck DNS / Let’s Encrypt.

I got it to work! I tried opening port 443 (and forwarding it to 8123), so I can drop the port # from my remote URL. After doing that it worked. Anybody know why? Is it less secure to use 443 for this?

I did not. But I haven’t tried it in a while. I should really try it again soon. When I do, I’ll update the Forum.

Of course! Most people would use this combination and it works.

Hello @rocky! I have the same issue on my iOS App. But I didn’t understand what you did with the port 443. Can you help me? Thanks!

I had this issue too (v1.5 App) a few weeks ago when I changed over to SSL. It was rather bizarre as all I needed to do was to change the config entry in the HA iOS App from http://blah to https://blah. Worked fine on my iOS iPAD, but when I did this on my iOS iPhone it failed to connect and complained about the shared token. I reset the config in the app, and manually entered the data back in and still no luck. What did work, and its rather bizarre too, was I went to Safari and did https://blah just to make sure that it could connect to HA (and it did). I copied the URL from Safari, and Pasted it into the iPhone HA App’s config entry and it worked…can’t explain it…it just somehow worked.

Unfortunately this isn’t working for me =(

Got same issue, was always working fine before 95.x but after upgrade and my config got corrupted, it is not working anymore.

via inside lan, no issue
via mobile phone on 4g working
via IOS app on 4g not working
reset of IOS app not working

finally after removing IOS app and reinstall it worked again. looks like some saved credential issues which is not cleared after IOS app reset…

1 Like

Same issue here after installing DuckDNS. Everything worked, but the app.

Deleting the app and re-installing helped.


This worked for me as well.
The url in safari was something like https://xxx.duckdns.org/auth/authorize/… followed by a huge string of url parameters. Pasted that to the iOS app and got to the login screen. When I go back to my settings in the iOS app it strangely just displays my normal duckdns address that was not working previously, but now I am in.

Following this works perfectly. After setting Remote access using Duck DNS (Good guide here: https://www.youtube.com/watch?v=VUTPAoB27iQ) and successfully connecting to the home page in Safari through https:sitename.duckdns.org:8123 it redirects to a longer authorization url and login page. Copying that URL (https:sitename.duckdns.org/authorize etc)…and pasting that long string worked. I tried other combinations and that failed. The OP seemed to make it also work by forwarding Port 443 (HTTPS) to 8123 which also worked in my case too.

Hi Guys,

I recently installed HA on a ubuntu VM running on a Hyper-v server. So far so good :wink:
I installed the HA app on my iPhone and managed to connect to the HA server when i was @ home (internal ip). I am now trying to make it so that i can connect to my HA server using the ios when i am not at home (external/remote access), and this is were the problems start.

I have domain name registred with an external (EU) registrar and i made a forward from there to my home (static) ip. On my local router i made a port forward from external port 8123 to internal port 8123 which points to the local ip from the HA server.
As soon as i open up a browser and i browse to http://ha.domainname.nl:8123/ i can get a connection to my Dashboard.
When i enter this into the app i get the error “Shared.TokenManager.TokenError error1.” like stated by other users.
I tried every solution that worked for other users but i kepe getting the same error. I tried opening the URL from my safari browser on my iPhone, and i get connected. I tried to copy the long URL (stated by Dobby) into the app but I keep getting the error. For some strange reason forwarding port 443 to my internal ip with port 8123 won’t work (as in, it wont let me connect trough web).

Anyone have any other suggestions?

Thanks in advance!

I managed to fix the problem.

what i needed to do was open http://ha.domainname.nl:8123/ in my safari browser on the iPhone, log in and paste the URL it gives you into the app.

the way i read the other solution was just visit http://ha.domainname.nl:8123/ in the safari browser on the phone an paste the URL it generates. Since this did not work i tried login in and copy past the URL it gave me then, and voila we have connection.

Hope this will help someone some day :slight_smile:

1 Like

I had the same problem and the solution that helped for me was very simple: just append a slash / at the end of the url.
From
https://MyKeyHere.ui.nabu.casa
To
https://mykeyhere.ui.nabu.casa/

Cheers

1 Like

I just ran into this issue as well, but I was able to resolve it. It case anyone else sees this:

I’m using duckdns as well as the Nginx Proxy Manager that is basically taking my traffic from https://hass.mydomain.duckdns.org and passing it to http://192.168.1.X:8123. It works totally fine in any browser and brings me to the hass login page, but adding into the app was not working and giving me the same error OP was getting.

To resolve:

  1. Delete the app and reinstall.
  2. copy your duckdns link- in my case it was: https://hass.mydomain.duckdns.org NO slash, no port as nginx already knows it’s forwarding :443 traffic to :8123. Your case may be different.
  3. Paste into the ‘URL’ input in the app in the configuration area, and press Done. Do nothing else here.
  4. You will be brought to the login page and everything works perfectly.

I hope so too. I am going to try it now… :crazy_face::crazy_face: