Unable to update - Supervisor not privileged

I’m running HA on an Intel NUC with Ubuntu in supervised mode. After updating to 0.118.2 I can no longer update HA, because it my supervisor is not running in privileged mode. How can I change that? So how can I change the supervisor docker container to privileged mode and also make it persistent so that it will also run privileged after a reboot? Any help would be greatly appreciated.

Quick edit: I just checked the state of the supervisor container and it says that it is privileged! But still HA keeps saying that it is not.

Quick edit 2: I could fix the problem by updating and rebooting the host system (Ubuntu).



I am having the same problem. Docker inspect reports that the supervisor is indeed privileged, but supervisor itself reports unhealthy because it is not privileged. Ubuntu 18.04.5 LTS with Docker version 19.03.14 and Supervisor version 2020.12.2.

Good to see your edit that an update and system reboot seemed to resolve the issue. I will try that also.

Edit: Update and reboot resolved the issue, thanks!


you should re run the supervised install script https://github.com/home-assistant/supervised-installer

Same issue here. Noticed eventually why I couldn’t upgrade an addon.
There should be a persistent notification for situations like these. Who checks supervisor logs when an addon update/installation gives trouble?

Anyway, I created an issue for this:

I wonder when using Ubuntu 18.04.05 will become problematic as well.
According to the architecture doc, the prerequisites are

  • Docker CE >= 19.03
  • Systemd >= 239
  • NetworkManager >= 1.14.6
  • AppArmor == 2.13.x (built into the kernel)
  • Debian Linux Debian 10 aka Buster (no derivatives)

Most of them are newer than what Ubuntu 18.04.05 offers…

Installed today Supervisor 2020.12.6 on Ubuntu 20.10 with Docker version 19.03.14, build 5eb3275 (Which was released earlier this wk). Since this update it tells me:

Your installtion is running in an unhealthy state.

The rerun of the installation script does help resolve it nor a reboot afterwards.
I checked as well in Portainer but the Superviser is already privileged.

Because of this HA Supervisor refuses to run any HA Core Updates or Supervised Apps like VCS.

Can you please have a look at this before many others get into the same problems.

There are 2 aspects.

  • The container.
  • The host access.

First is solved by https://www.home-assistant.io/more-info/unsupported/privileged
Second is something wrong on your host, usually host OS updates and reboot solves that.
If not you need to deep dive into your host OS to see what’s going on, or an alternative installation:

  • Home Assistant OS
  • Home Assistant Container

Host has no more updates. Its not only on my PI4 but also on my Proxmox VM running 20.04.’

@ludeeus @balloob
Everything worked fine and no issue’s until we did the update to Supervisor 2020.12.6 which caused this issue. Systems have been dist-upgraded etc to the latest versions also multiple reboots done. All wo resolving the issue.

Convenience script works fine if you have nothing installed but it will not do a docker rm and docker run unless I am missing something.

1 Like

please do not randomly tag, thanks.

How do you mean randomily tagging. I think this is serious enough to get Paulus involved in this conversation.

It was already mentioned on Github as well and then simply wo any real solution closed. Is a bit strange that when an update of the Supervisor comes we need to reinstall our instances.

This stops people from updating their instances. Meaning no more updates until this is resolved.

He’s not involved in the conversation, don’t tag him. Plain and simple. Ludeeus is here, you simply could reply to him without the tag. Thanks.

I am having the same issue. Also tried rebooting as mentioned but no luck here.

1 Like

Same issue here.

Update >> Ran an update on the host system, the update is now working. I should probably consider reinstalling the host system to the one that is officially supported.

Very good idea.

I’m kinda dreading it. As I understand it, I’ll need to format the drive on my nuc to remove ubuntu and instead install debian then restore the HA / HASSIO on that. Seems a big job, that’s why I’ve been putting it off.

You could get a new drive that way you keep your working version intact while you play around with other options. If you want to install HA OS on the NUC, there is an official image you can use.

If you use system for other things, you can try Proxmox. This method allows you to install the HA OS as a virtual machine and then also run other VMs like Ubuntu or Debian, etc, to run other software outside of the HA ecosystem. Keeps you fully supported, but is a little harder to set up initially.

You can also try a Debian 10 Supervised install. If you want to stay supported, you can not use the underlying OS for anything else, like Plex.

There are benefits and disadvantages to both methods.

1 Like

Thanks, that’s useful. I’m using the server just for HA, homebridge. I wouldn’t mind running some sort of NAS / disk sharing as well, though sambaNAS (home assistant addon) work quite well for this purpose.

I didn’t realise I could install HA OS directly on the NUC till now.

I’ll have to do some reading, but I would like to get on to it soon(ish).

1 Like

Installing HA OS on the NUC (as the only operating system) is really a waste of resources as the NUC is most likely idle most of the time and you can’t install anything else on there. Have a look at Proxmox and then install HA OS into a VM. There is a very good YouTube tutorial on this by JuanMTech. This way you can install other VMs alongside HA and use the NUC for other stuff (video surveillance, Plex, etc.).


Thanks. I like the VM idea. Installing on an unraid installation might also be worth thinking about.

Great suggestions however this does not resolve the problem at hand because I am running Debian 10 and still have this issue because of the Supervisor update.

I resolved the “unprivileged” error by modifying the docker run command of the supervisor as described here in the last comment:

Basically mounts the whole device tree now. And after restarting the service (not the machine) the unhealthy error is gone. I even had the courage to update HA to the latest point release .5 afterwards and all seems fine for now…

I guess this won’t be the last hack to keep things running…
Lets hope those supervisor features become optional soon…

1 Like