Unable to update - Supervisor not privileged

Hey all,

Just a quick note, the issue is currently being tracked on github Supervisor is not privileged #2351

1 Like

I’ve also had this problem. Rebooting the (Ubuntu 18.04.4) host solved the issue.

Rebooting Ubuntu 18.04.5 also solved it for me too … until two days later when it crashed and the ‘unhealthy’ indicator returned. I upgraded to Ubuntu 20.04.1 and that eliminated the indicator (no problem so far) and a related Warning message in the Log.

Restart the Supervisor, wait a minute or two, then refresh the Supervisor log. Check for messages complaining about Network Manager version 1.10 is not supported. It needs to be a minimum of 1.14 (except 1.10 is the latest official version for 18.04.5). In comparison, Network Manager in Ubuntu 20.04.1 is version 1.22.

Apparently the issue I have is that Supervisor is not compatible with latest version of Docker. See here

Those dependency versions should all be irrelevant for supervised installations. What useful thing does the supervisor do that depends on exactly having docker 19 and a certain minor version of network manager???

I have two installations that got borked by the last updates and I’m thinking about rolling back the supervisor to an earlier version and blocking further updates.

Has anyone tried something like this?

I’m having the same issue. Ubuntu 20.04.1 LTS, Docker 20.10.1, Supervisor 2020.12.7 (core 0.111.4). System reports supervisor is not running in priviliged mode. OS is fully updated and has been rebooted multiple times.

I’ve followed the instructions in https://www.home-assistant.io/more-info/unsupported/privileged, and re-ran the convenience script (more than once), but it did nothing to resolve the issue. I’m still getting the “installation is in an unhealthy state” in the Supervisor/System tab, and when clicking on it the only issue is “Supervisor is not privileged”.

Anyone have a solution that doesn’t involve running the install script again or rebuilding the entire system?

I wanted to try your solution, but I don’t appear to have a /sbin/hassio-supervisor Any idea where else it might be hiding?

Running the install script isn’t difficult. Worth doing, if not, take a snapshot anc backup all your yaml and take the opportunity to move to Debian 10.

sudo -i
curl -sL "https://raw.githubusercontent.com/Kanga-Who/home-assistant/master/supervised-installer.sh" | bash -s

Wasting time putting band-aids on an unsupported installation is only kicking the can down the road.

Please read my entire comment. I ran the install script. Twice. It did nothing. That’s why I’m looking for a solution that doesn’t involve running it again.

Sorry, you said ‘convenience’ script. I didn’t pick up that as the installation script on first read.


The page ludeeus posted calls it that, so I used the same nomenclature. I can see how it could be confusing.

You might spend a few hours and get frustrated trying to fix this issue.

If you have a spare SSD, backup your config, swap the SSD out and install Debian 10. It honestly takes under 1 hour, I’ve done it so many times now I can get it done in 20mins (it’s fast and easy to do)

Worth a try, if you face an issue, pop your current drive back in.

It’s even easier than that for me, since the Ubuntu machine itself is a VM on an ESXi box. But it’s still more of a PITA than I really want to do. I’ll do it, if I don’t find another solution, but I’d prefer not to.

1 Like

Check in /usr/sbin/hassio-superviser

It’s always good to know what the install script does and how HA supervised is working. The script above is one part.

My system has fallen back to unprivileged despite the /dev mount. Not sure what’s going on.

1 Like

I also was using a Home Assistant installation on a NUC running on Ubuntu server and docker. Setup way back with the provided script at that time. Running other dockerized services as well.
Finally gave in after last Supervisor update, which bricked my setup. Not wanting to deal with the being ‘not privileged’ and having an ‘unsupported installation’ anymore, it was time to make some changes.

Migrated all to a Proxmox setup with one VM running Home Assistant with the available QCOW2 image.
On the fresh Home Assistant VM, I just loaded my latest snapshot during first onboarding step to get that going again.

Setup a second VM I did a fresh Ubuntu Server 20.04.1 install with docker (compose) containers for all other services.

Having a separate SSD available to start fresh made the migration a lot easier and less time consuming.
Mounted the old SSD (using an USB to SATA convertor) to the Ubuntu VM and copied my ‘home\user\docker’ folder with all settings for my containers and docker-compose.yml file.
Next ran docker-compose to get my other services up and running again.

Took less total time than I already invested trying to get my old setup running again after the latest Supervisor update ruined it.
Time well spent, knowing that with the next update I would probably have to do that all over again anyway.

But then you are running one of the images with HassOS (or whatever it’s called now). I don’t want that. I want control over the underlying OS.

Fortunate are those with enough RAM for this feat :slight_smile:

Rebooting the Host machine, does seem to resolve the issue for me and I guess I will have to watch for the next time I want to do an update.

I have the same issue, and a reboot seems to always fix the issue. It tends to work for some time, then falls into a non-privileged state again. (maybe after a supervisor update?)

I am running a janky setup with proxmox which likes to mess with my DNS and interfaces though so who knows what else it is messing with

Running HA Supervised on an Ubuntu 20.04. I also have this problem for a while now. Since Supervisor updates itself automatically, with every new supervisor version this error comes up. My solution is, whenever i have this “Supervisor not Priviliged” written in Supervisor System page, i ssh into Ubuntu and:

sudo docker restart hassio_supervisor

And that solves the problem until the next automatic supervisor version update. As i see, whenever there is a new version, docker does not restart the container (that’s maybe it is a new container from a new image); so you have to do that yourself. I do not know how long this solution will last but we’ll see.

Although the administrators say “There is no support for unsupported systems like ubuntu supervised etc”, and close the issues on github without solution, i find them right in a way. They never guarantee that the system will work on an environment that they do not design it for.

However, on our defense, i also have other apps on this ubuntu system for other purposes. And the system works perfectly and i am planning to resist until the last moment not to use proxmox or hassos. That is not suitable for my situation, personally. And auto-updating of supervisor every time brings new surprises and problems together with it. Once my system is stable, i would like to keep the version intact and not update it unless i really need to because of a bug or a new item. So, for me, it is very normal to keep HA version 0.99 whatever if it is working stable. But unfortunately that is not the situation now. Of course i always have the option to work with HA core without supervisor; but i need config backup-restore and some addons desperately. If there was only a way to merge these two together… Anyway, i humbly and kindly request from the administrators to make supervisor updates optional. Thanks…