2022.7: A stunning performance

What do you see if you click on privileged?

Brings me to here:

“The Supervisor needs to have privileged access to the docker runtime on your host to be able to do everything it needs to do.”

Im running on:

System: Host: automationhub Kernel: 5.4.0-113-generic x86_64 bits: 64 compiler: gcc v: 7.5.0
Desktop: MATE 1.22.2 wm: marco dm: LightDM Distro: Linux Mint 19.3 Tricia
base: Ubuntu 18.04 bionic
Machine: Type: Desktop System: Intel Client Systems product: NUC7i3DNKE v: J57829-510
serial: Chassis: Intel Corporation type: 3 v: 2 serial:
Mobo: Intel model: NUC7i3DNB v: J57625-510 serial: UEFI [Legacy]: Intel
v: DNKBLi30.86A.0056.2018.1003.1513 date: 10/03/2018

I’ve done -apt update and upgrade many times over. There is nothing left to update on the host.


Hmm. So you need to run the container in privileged mode?

Not sure how you would do this given it’s a supervised installation. That should be automatic when you installed. Do you have the HA agent installed? Have you tried running the installation script/package again?

Also see this thread

Seems they also say re-run installation

Inevitably this will bring problems as supervised is only supported on debian 11.

True but supported is a moving target these days becoming increasingly narrow all the time. I stopped chasing it a long time ago.

Hi guys,

Reading through the thread @DavidFW1960 shared.

I did “sudo docker restart hassio_supervisor” on host terminal, went back to HA and attempted update which it did successfully.

I have NOT restarted host or HA and now have a Healthy supervisor and updated to the latest.


From the convo, I take it not to always expect this outcome, but for a reason (of which I do not know), simply restarting hassio_supervisor and then updating via HA GUI did the trick.

Thank you for your responses, support, and feedback. I learned some new things today.

Much appreciated.

2022.7.5 is out, but the the release note is missing. :frowning:

The release notes are there.

good morning everyone, since 2022.7 came out on my mini pc there is an exaggerated Consumption of RAM up to the mini pc block, while if I go back to allan2022.6.7 no! I can’t even read the logs, has anyone had the same problems?

It’s not explicitly mentioned in the release notes, but just in case –

Anyone here know if the merged PR

Add mariadb-connector-c to Dockerfile by bdraco · Pull Request #247 · home-assistant/docker (github.com)

has made it into 2022.7.5?

Completely agree. History was my quick glance at everything I wanted to see using a carefully curated list in my config file. I’m not even sure what the history component does anymore if I also have to pick everything on the page itself? Then also clutter it up with all the items I’ve picked at the top?

I’ve started building history graphs to show on different dashboards to replace this, but then I also have to build a way to show different time frames to get the same functionality that the history page had.

1 Like

I don’t think so, latest release is from 17 days ago and this PR has been merged 5 days ago

This would be a nice FR for history_graph cards; the ability to select date/time ranges.

Maybe take a look at my workaround.
I’m happy with it.

BTW: If anyone is able to template the start timestamp to the urls in the frontend


it will also be possible to open the sets with different time frames.

Agreed, please go here and vote if you would like to see this as well.

Also, this is a somewhat workable solution for now.

After updating to 7.x I’m experiencing over and over again that starting HA partly fails in the sense that some integrations do not load and several custom dashboards fail to load. This only happens when there’s a section in the configuration.yaml file that has lines with incorrect indentations. Still, the Check configuration command always produce a Configuration Valid! output. It seems as if this check is no longer capable of catching incorrect indentations? I belive it used to be able to do that in earlier versions.
Info: I run 2022.7.5 in a docker container.

1 Like

You can see the state of the code in any release on github. Open any piece of code, click the dropdown that says “dev”, then “tags”, then the version you want to look at.

Thanks @stevemann, I’ll be giving that a go this weekend.

I’ve only once had to do a restore, and that was after trying out a new zigbee integration (which unfortunately clobbered all of my DeConz entity assignments)

In regards to updating HassOS, I was not aware that I would be able to get back to a pre-upgrade state with a restore of a full snapshot, I guess I was thinking that the full snapshot only contained “my configuration”, not HomeAssistant itself

Cheers :slight_smile:

I got burned by that way back when…

Never realised that filenames needed to be unique in split config regardless of path

Created an issue:

1 Like