Unexpected high CPU use

Hi,

since 0.62.0 I have an unexpected high CPU use on my raspberry pi 3.
Normally I had about 6%, now its 50-60%.
I have temporary disabled most of the addons. But this have no effect.
Nothing in the logs. Does anyone recognized the same?

You can try docker stats to see which addon/container uses the cpu.

Thx for reply. Where do I have to add this?

Terminal?

Yes, in a terminal.
I’m running hassio on a Ubuntu server.
I think on RPi you could use the ssh or terminal addon.

Yes,
I have SSH access. But its very limited.
How is the exact command? „docker stats“ is not working.

Hmm, then the command is not avaiable on RPi.
Are you using the ssh or the terminal addon?
Maybe a simple top works?

Yes I‘m using the addon.
Top shows only a few processes.

Sorry, then i have to give up.

I had the same problem, but the culprit was MySQL. Also happened after the update to 0.62, but that could also be a coincidence.

I haven’t looked into it yet (will do in the weekend) but have temporarily disable MySQL and have the default recorder running for the moment.

Ok,
That can cause the problem. I‘m using MariaDB and already have reported a problem with the recorder.
I try to do the same.

I should have said I was running MariaDB, I confused the two as in ‘top’ the process was called MySQL.

I disabled the recorder. Now its lower, but still at 25-40 % :frowning:
I think I went back to 0.61.1…

I have had to remove my external NAS drive MySQL Database and go back local on my Pi with this release - the frontend would take 45-50 mins to load, if at all.

RPi 3, VirtualEnv install, 0.62.1

I see high cpu use with mysql onĺy when service ‘recorder.purge’ runs.
Then my mariadb docker contaner needs about 80 - 100% cpu for 10 minutes, even if there’s nothing to purge.

Maybe related:

Now I‘m on 0.62.1. The recorder bug is gone and I switched to MariaDB again.
CPU Load is 30-45 % …normally 5-6%

Is there any way to monitor the processes on the official hassio installation?

Found this in another topic.
Here the docker command should be available.

Thx,
I will try!

Because I cant find the issue I went back to 0.61.1 and CPU load was fine again.
Today I upgraded to 0.63.0 I hope this issues is fixed. But its worse than on 0.62.0.
CPU is about 75-80% constantly for a few hours now. And again (same on 0.62.0) the Recorder component is not working correct. I see no states or anything.
I think I have to go back to 0.61.1 an wait until all this is fixed…

I have detected hight CPU usage on my HA install (v0.62.1). Running on an orangepi, so it is not related to hardware. Tried to disable the latest devices added, disabled also the discovery component but in six hours the CPU usage grows apparently to 50% (with top it shows a lot of hass processes and more than a core is fully used) and makes the system very unresponsive (5-10 seconds delay between clicking a switch/light and the activation).

Did anyone find a solution upgrading to a newer version?