Universal IR remote not configured correctly in MQTT

MOES UFO-R11 doesn’t work as a remote
Zigbee2MQTT shows that the device exposes all required fields for the universal remote to work:

but in MQTT send IR code is missing

and in general its not being recognized as a remote thus the remote integration doesn’t work with it.

how can I configure MQTT to detect it as a remote and/or expose everything that Z2M exposes

1 Like

1 Like

Hi mate, I’m trying to configure this same device now. I’ve come across the same stumbling block as you - did you manage to find a solutions?

I got my working in a script

Follow up, I managed to get it working.

Here is how you do it via MQTT Publish. I then created a script calling service via MQTT Publish. In the relevant boxes, use the below


Payload    {"ir_code_to_send": "PASTE IR CODE HERE BETWEEN QUOTATION MARKS"}

With my names and IR code, here it how it should look.

Topic  zigbee2mqtt/irbox/set

Payload  {"ir_code_to_send": "BTUjfBEvAuAXAQGLBuANA0ABwBtAAeADC+AHAUAbwAFAC+ADAwd0ozUjoggvAg=="}

1 Like

I try to use smartir add-on with Mqtt settup won’t work.

I’m feel like I’ve messed up. I put the matching Topic & Payload into Mosquito Broker’s configuration but I got nothing.

Also does your workaround allow more than one remote/button signal?

1 Like

@jellytotz I did everything as you described, and in the Zigbee2MQTT logs the IR code was sent. But actually - nothing is happening with the devices (tested on three devices with 3 different IR remotes)…

Sending a code to the Homeassistant via Mosquito Broker,
The code has been sent:

But nothing is happening with the device actually :frowning:
What I’m missing here?

Just to confirm I got it working like described above.
But a few specific of my “learned IR commands” didn’t seem to work.
Maybe there was some interference while learning or something.
Need to test further.

Hello all, I seem to b having the same issues as you guys.

It shows up as supported in Z2M and is visible in Mosquito broker (see pics). And when I click ‘learn new IR code’ in Z2M, the latest one shows up there and in the mqtt logs.

I’ve created a script with topic & payload as per the instructions and a have button to call service and run the script, but in traces the script shows ‘script running_script: false’. I’ve also triggered the scene manually in the script editor with the same results.

I’ve tried learning several different commands from my TV remote control all with the same results.
I’ve also raised this in the Facebook group, but haven’t had any replies as yet:


SOLVED - kind of :roll_eyes:

I think I’ve got a faulty unit. I bought 2 so was able to run a test:

My problems above were with my first unit (bed 3 ir blaster). It’s discovered, interviewed, learns codes all no problem

Firstly I changed my naming system: originally I gave it the friendly name: bed 3 ir blaster, then when I referenced it in scripts I put underscores between the words. But, taking note of @jellytotz advice above, I deleted the device and re-paired and renamed it bed.3.ir.blaster

This made no difference! haha! BUT I decided to stick with this naming system just in case it was causing an error.

I’ve then gone through the process with a second unit and everything works just fine: I wrote this script and triggered it: working, added a button to a dashboard with call service Scripts: bed.1.ir.blaster BED 3 TV mute and it works :slight_smile:

So, next to test the first unit. In order to test if it was actually outputting an IR signal, I duplicated the working script, altering the device name obviously, and fired it. No luck. So next I put the known working unit in learn mode and triggered the test unit to send again. No luck, the known working unit is not picking up any IR signal from the other unit.

My conclusion is a faulty unit - it can receive but not send. I’ll contact customer support later and see what they say and report back.

Seeing as some folk here are winning and others are losing with exactly the same scripts, I reckon there might be a bad batch out there…

This is what I’ve got working:

Hope this is of some help to someone.


i bought the same item
you need to learn the code, put it on a note pad
then make an automation calling the MQTT service “zigbee2mqtt/FRIENDLY_NAME/set”

example i made a long press on a button to turn off my airconditioner

For those who have problems with the operation of this with sending commands from the remote.
I checked the operation of my remote control through the IR ESPHome service. I sent commands from this remote to the remote stitched in esphome.
And it was clear from the logs that the remote control sends commands in raw form and sometimes in the right encoding (so that the receiving device understands what is being sent to it).
The batteries were to blame. The ones I installed showed 64%. Replacing them with new ones. The remote control began to send commands stably in all encodings. I haven’t seen a single failure in 20 consecutive launches.
Maybe it will be useful to someone.

на русском

Для тех у кого проблемы с работой этого с отправкой команд с пульта.
Я работу своего пульта проверял через службу IR ESPHome. Посылал команды с этого пульта на пульт прошитый в esphome.
И по логам было видно, что пульт отправляет команды в сыром виде и иногда в нужной кодировке (чтобы принимающее устройство понимало, что на него шлют).
Виноваты оказались батарейки. Те которые я установил показывали 64%. Заменив их на новые. Пульт стал стабильно отправлять команды во всех кодировках. Ни одного сбоя за 20 запусков подряд я не увидел.
Может это кому то пригодится.

Hi all!
I am new to HA. I have the same type of ir controller and I tried to make the settings but I think I’m making a mistake somewhere.
I extracted the codes from the AC remote control for the on and off command
I didn’t understand clearly what to write in automation calling the MQTT service “zigbee2mqtt/FRIENDLY_NAME/set”

zigbee2mqtt/FRIENDLY_NAME/set config

"learn_ir_code": "OFF"
"learn_ir_code": "ON"