Update Gone Wrong - A Confession

Over on the new version thread, there’s been some talk about waiting to update because of all the problems some have reported. I was one of the hesitant ones. I use some of the things which were reportedly problematic, and I’ve been waiting for a rainy day when I can dedicate enough time to recover if need be.

Today I bit the bullet.

I ran through my preparations. Made all my backups and copies. Took screen shots of various states and configurations. Finally I pulled the trigger. Oops. Forgot to un-check the option to make a backup, which of course I had already done manually.

But that was the least of my mistakes…

After a few anxious minutes, HA seemed to come back up normally. The logs looked good. The dashboard looked good. I was able to control a few devices over WiFi and Zigbee. I was getting data from my GPIO pins. The logs showed the database update went smoothly (and in just a few seconds!) I settled in to start my usual test procedure, this time taking a few screen shots to do some before/after comparisons. And…

Suddenly, I lost the SAMBA share to HA. Then I lost the UI. Then SSH failed. I couldn’t even ping the host.

HA must have crashed! I remember others on this forum saying this happened to them, but not so quickly. Mine had only been running for five minutes!

OK, down to the utility closet where HA lives. The hardware looks OK. Gave it some time. Still no good. Did a cold reboot. All the right lights came on. Still no response to a ping. I went to dig out a spare monitor, keyboard and mouse, and cleared some room on my workbench to set it all up. Still no response to a ping.

I unhooked the HA hardware from the UPS, and pulled off the ribbon cable to the breakout GPIO board. Unlatched the case, gathered up the Zigbee controller on its USB cable and brought them to the bench. Connected everything and fired it back up. And…

No problem. HA came up just fine. But I still couldn’t ping it. I was sitting there staring blankly at my laptop when I spotted a little icon in the tray:

“Airplane Mode”

Yup. Somehow in my haste to take screen shots, I’d managed to hit the magic key sequence for airplane mode.

I’m sure I’ve done dumber things, but I’m not about to admit to them here!

I hope this gives everyone a good laugh at my expense. And maybe you’ll remember to look for something simple like this next time you’re ready to give up.

14 Likes

We have all done similar things or worse. Anyone who says otherwise is probably being fast and loose with the truth! And lying to yourself never does you any good.

1 Like

I once spent quite a while trying to find out why a headless machine was not getting a dhcp address, restarting my dhcp server, tearing hair out, hours wasted. Then I realised the ethernet cable was not plugged in.

6 Likes