Update Limitlessled/Milight Component V6 Bridge (iBox)

I mean I will purchase another new V6 model bridge.

Ohhh okay! I got it now. So it’s about the hardware thing only not firmware.

Hi here is my config to make it work with 2 different types of bridges (V5 and V6) if it can help.

By the way did someone managed to control the bridge led? It doesn’t wotk for me as mentioned in the documentation.

  platform: limitlessled
  bridges:
    - host: 192.168.1.70
      bridge_led: True
      version: 6
      port: 5987
      groups:
      - number: 1
        name: Side
        type: rgbww

    - host: 192.168.1.32
      version: 5
      port: 8899
      groups:
      - number: 1 
        name: Bedroom
        type: rgbw

With HASS 0.39 I’ve got my lights working. The only issue I have is that I am also using a remote. This works fine but HASS can’t get state change. So I was wondering if it would be useful to have an on and off button instead of toggle button. Is this possible?

Yes right it’s due to the limitless light hardware/firmware that doesn’t give status feedback. I saw somewhere you can customize this “toggle” button and change it with on and off but can’t remember where and it would not help you having feeback status…

Change self._bytes = bytes on line 43. It should fixes TypeError.

“/usr/local/lib/python3.5/dist-packages/limitlessled/group/commands/init.py”, line 43, in init self._bytes = bytearray(bytes)TypeError: an integer is required
[/quote]

1 Like

Having now moved all my bulbs to the V6 bridge I think I may have jumped the gun a bit. :frowning: I have merged all of my bulbs, RGBWW, RGBW and CCT (White) into five groups on the bridge (maximum, supported is sixteen). I’m now hitting an issue where it appears that Home Assistant does not support more than 4 groups of any bulb type.

I just wondered if anyone could clarify this?

That’s normal behavior, you can have 4 RGBWW groups + 4 rgbw groups + 4 dual white groups (+ Bridge led “group”) + I forgot how many rgb groups. This is due to how the v6 bridge works

LimitlessLED/MiLights have 9 of built-in modes(colorloop effects), each with 8 different speed rates. I’d love to be able to access those - they’re handy for notifications and take the load of the controller.

Hi
Looking at the code it seems that some modes are built in (EFFECT_COLORLOOP, EFFECT_WHITE):
https://github.com/home-assistant/home-assistant/blob/dev/homeassistant/components/light/limitlessled.py

But I agree it would be really nice to have access to them all and maybe even possible to activate them from the UI.

I was wondering if there is support for white lights on the V6 bridge? Works fine with the milight app (if you select the right remote). I see the legacy script (for <V6 bridges) has support for the white lights but seems there is no support for white lights on v6?

I’ve tried all remote styles and when i set the REMOTE_STYLE in v6.py for white lights to 0x01 there is at least some control…
0x01 sets the light to full brightness
0x02 dims the light (but not fully dimmed)
0x03 sets the light to warm white
0x04 sets it to cool white

So there is connection with the light, authentication with the i-box is working as it should , i am therefore very close to get it working, just need the right command to send! I want at least control to turn it off and on
Anyone knows how to get this working?

ediit: btw these lights are the 12W dual white Downlights for ceiling mounting

I’m pretty sure white bulbs do work on V6, well they were working for me at least.

platform: limitlessled
 bridges:
 - host: !secret milight_ibox
   version: 6
   port: !secret milight_port
# WHITE Gruops
   - number: 4
     name: hall
     type: white

I’ve since moved back to V4/V5 bridges as I found V6 just wasn’t there yet.

Not noticed anyone else with this problem, so I don’t know if its just my installation…

My limitlessled lights stop responding after 24-48hours after last HA restart.
Switches appear to active etc. and the UI will allow me to switch on/off etc, but the lights themselves don’t do anything.

Using:
v6 wifi bridge
2 x RGBW lamps
HA 0.40.0

When they stop responding to HA, they are still controllable from the MiLight Android app, so the bridge is still up.

Not being a dev, I’m not sure how to debug and move forward with this.

Several times a day, I see this in the log, but it could be related to anything.

17-03-20 23:19:38 ERROR (MainThread) [homeassistant.core] Timer got out of sync. Resetting 

and

   17-03-21 00:10:24 ERROR (MainThread) [homeassistant.core] Error doing job: 
   Fatal read error on socket transport Traceback (most recent call last): 
   File "/usr/lib/python3.4/asyncio/selector_events.py", line 582, in _read_ready 
   data = self._sock.recv(self.max_size) 
   OSError: [Errno 113] No route to host

@noodlemctwoodle I cannot get the life of me to get the white lights working with v6. What port number did you use in your case
@Bradovic did you manage to get yours going, I have the same setting white down lights and RGBW v6 bridge only triggers rgbw from HA

Hi All,

Thanks so much for the hard work putting this together - I have been using Domoticz + HA Bridge to gain control into my Google Home setup, but was looking forward to switching to HASS now it is more stable.

One small item, when I toggle the lights on/off, i noticed the follow:

  • Turn on: Light goes to a very dim setting (for a half a second), then goes to full brightness
  • Turn off: Light goes to a very dim setting (for a barely noticeable moment), then goes off

I was reading and the core-code says the transitions are set to 0, can someone let me know what I’ve got wrong?

Thanks!
My setup: 0.41 HASS, v6 iBridge, RGBWW bulbs.

No mate unfortunately i didn’t manage to get the white downlights to work yet :frowning:
Would love some help with this, will keep you updated if i manage to get it to work!

I also can’t get my old white leds to work with the v6 bridge, even tho I can control them through my ancient v2 bridge. I also don’t see the bridge led in home assistant. Controlling works through the ios app tho.

Marcus

fwiw, I tested the python library directly on the command line as well, and nothing, but this node library worked perfectly, so I’m pretty sure there’s a bug - https://github.com/mwittig/node-milight-promise

(tested with examples/example-dual-white-v6.js)

Just gonna leave this here: https://github.com/sidoh/esp8266_milight_hub

From the Readme:

  • Both the remote and the WiFi gateway are limited to four groups. This means if you want to control more than four groups of bulbs, you need another remote or another gateway. This project allows you to control 262,144 groups (4*2^16, the limit imposed by the protocol).
  • This project exposes a nice REST API to control your bulbs.
  • You can secure the ESP8266 with a username/password, which is more than you can say for the Milight gateway! (The 2.4 GHz protocol is still totally insecure, so this doesn’t accomplish much :).
  • Official hubs connect to remote servers to enable WAN access, and this behavior is not disableable.
2 Likes

It would be awesome if someone can wrap this with Philips Hue API. Instant support in loads of home automation platforms.