Update ZigBee firmware using deCONZ on Hass.io

I found that you can wait forever for an Ikea device to wake up and start the upgrade. My solution was to first queue the OTAR from Deconz and then remove the battery and put it back. Then usually within a minute or two the OTAR starts. And it can take 30-60 minutes and only one device at a time

Did you ever found an answer how to upload files into the deconz container running on an HA BLUE?


Got it!
You have to use “SSH & Web Terminal add-on” and not “Terminal & SSH”.
On the first one, the docker command is available and you can copy the files.

Trying an update of an philips bulb now.


Hi guys,

Conbee II Stick connected to my NUC Running Home Assistant OS, with deCONZ add-on installed.
OTA Enabled.

I have a few questions I didn’t fully understand reading through this, so maybe you can make it more clear for me:

What is the right approach here in order to check if there is any update - I mean the order of pressing the different buttons. Query, select Otau file and then Update or should I just click Query and wait for it to check whether a newer firmware is present or not?

Currently I have two Ikea Range Extenders (2.32 Build 22065) which I believe isn’t running the latest update and I do also believe my Ikea TRADFRI bulb E27 CWS 806lm (1.0 Build 136789) isn’t fully updated.

Finally I have my Ikea Trådfri Shortcut Button which says “No file” even after I pressed the Query.
If I look up the files, in the Otau folder I do indeed find a file that matches the Shortcut Button.

Right now it looks like my two Ikea Range Extenders froze(looks like it froze at 0:58 seconds):
One thing I see if that after I pressed “Query” it loaded the file automatically in the Otau file, but the file doesn’t match the vendor_image_version:

I am running the latest deCONZ, but will it automatically download any new updates from IKEA etc., or is this done manually by running that python script each time (have not added that though as it looks like files are being updated within the otau library).

1 Like

i know this is an old one, but could this not in some way be done from a dashboard? ie have one where all zigbee stuff is listed and if updated or not, if not then an update button

It might not be the answer you’re looking for, but a while ago I bit the bullet and moved away from Deconz for a number of reasons, one of them being the lack of (easy) firmware updates.

I purchased an inexpensive Sonoff Zigbee dongle, installed the Z2M add on and one-by-one started migrating my devices over to the new network until I had nothing left in Deconz, allowing me to remove the integration and add on.

It was a bit of a faff for the day (walking around the house, putting everything into pairing mode, but all of the weird Deconz-specific issues are gone and Zigbee2Mqtt has been brilliant - especially the ability to update firmware from within HA itself (update entities are exposed).

1 Like

i will keep it in mind… also depends on how often say ikea reelase an update and what i gain from it

i cant get Zigbee2MQTT to run

my adapter is on port ttyAMA0, i’m a cheapskate and will if at all possible reuse the raspbee board

data_path: /config/zigbee2mqtt
  enabled: true
  master: pty,raw,echo=0,link=/dev/ttyAMA0,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: "-d -d"
  log: false
  base_topic: zigbee2mqtt
  server: mqtt://localhost:1883
  user: homeassistant
  password: xxxxxxxx
  port: /dev/ttyAMA0
homeassistant: true
permit_join: true
frontend: true
zigbee_herdsman_debug: true
  network_key: GENERATE

does it look total bollocks or? i keep getting the bad gateway when i try to open the ui

a bit from the log

[10:37:30] INFO: Preparing to start...
[10:37:32] INFO: Socat enabled
[10:37:33] INFO: Starting socat
Socat startup parameters:
Options:     -d -d
Master:      pty,raw,echo=0,link=/dev/ttyAMA0,mode=777
Slave:       tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
[10:37:34] INFO: Starting socat process ...
2023/03/02 10:37:34 socat[53] N PTY is /dev/pts/0
2023/03/02 10:37:34 socat[53] E unlink("/dev/ttyAMA0"): Read-only file system
2023/03/02 10:37:34 socat[53] N exit(1)
[10:37:35] INFO: Zigbee Herdsman debug logging enabled
[10:37:40] INFO: Starting Zigbee2MQTT...
Zigbee2MQTT:debug 2023-03-02 10:37:50: Can't load state from file /config/zigbee2mqtt/state.json (doesn't exist)
Zigbee2MQTT:info  2023-03-02 10:37:50: Logging to console and directory: '/config/zigbee2mqtt/log/2023-03-02.10-37-50' filename: log.txt
Zigbee2MQTT:debug 2023-03-02 10:37:50: Removing old log directory '/config/zigbee2mqtt/log/2023-03-02.10-30-21'
Zigbee2MQTT:info  2023-03-02 10:37:50: Starting Zigbee2MQTT version 1.30.2 (commit #unknown)
Zigbee2MQTT:info  2023-03-02 10:37:50: Starting zigbee-herdsman (0.14.96)
Zigbee2MQTT:debug 2023-03-02 10:37:50: Using zigbee-herdsman with settings: '{"adapter":{"concurrent":null,"delay":null,"disableLED":false},"backupPath":"/config/zigbee2mqtt/coordinator_backup.json","databaseBackupPath":"/config/zigbee2mqtt/database.db.backup","databasePath":"/config/zigbee2mqtt/database.db","network":{"channelList":[11],"extendedPanID":[221,221,221,221,221,221,221,221],"networkKey":"HIDDEN","panID":6754},"serialPort":{"path":"/dev/ttyAMA0"}}'
2023-03-02T09:37:51.640Z zigbee-herdsman:adapter Failed to validate path: 'Error: spawn udevadm ENOENT'
2023-03-02T09:37:51.647Z zigbee-herdsman:controller:log Starting with options '{"network":{"networkKeyDistribute":false,"networkKey":[1,3,5,7,9,11,13,15,0,2,4,6,8,10,12,13],"panID":6754,"extendedPanID":[221,221,221,221,221,221,221,221],"channelList":[11]},"serialPort":{"path":"/dev/ttyAMA0"},"databasePath":"/config/zigbee2mqtt/database.db","databaseBackupPath":"/config/zigbee2mqtt/database.db.backup","backupPath":"/config/zigbee2mqtt/coordinator_backup.json","adapter":{"disableLED":false,"concurrent":null,"delay":null}}'
2023-03-02T09:37:51.650Z zigbee-herdsman:adapter:zStack:znp:log Opening SerialPort with {"path":"/dev/ttyAMA0","baudRate":115200,"rtscts":false,"autoOpen":false}
2023-03-02T09:37:51.678Z zigbee-herdsman:adapter:zStack:znp:log Serialport opened
2023-03-02T09:37:51.684Z zigbee-herdsman:adapter:zStack:znp:SREQ --> SYS - ping - {"capabilities":1}
2023-03-02T09:37:51.689Z zigbee-herdsman:adapter:zStack:unpi:writer --> frame [254,0,33,1,32]
2023-03-02T09:37:51.953Z zigbee-herdsman:adapter:zStack:znp:log Writing CC2530/CC2531 skip bootloader payload
2023-03-02T09:37:51.956Z zigbee-herdsman:adapter:zStack:unpi:writer --> buffer [239]
2023-03-02T09:37:52.961Z zigbee-herdsman:adapter:zStack:znp:SREQ --> SYS - ping - {"capabilities":1}
2023-03-02T09:37:52.966Z zigbee-herdsman:adapter:zStack:unpi:writer --> frame [254,0,33,1,32]
2023-03-02T09:37:53.219Z zigbee-herdsman:adapter:zStack:znp:log Skip bootloader for CC2652/CC1352
2023-03-02T09:37:53.685Z zigbee-herdsman:adapter:zStack:znp:SREQ --> SYS - ping - {"capabilities":1}
2023-03-02T09:37:53.687Z zigbee-herdsman:adapter:zStack:unpi:writer --> frame [254,0,33,1,32]
2023-03-02T09:37:59.692Z zigbee-herdsman:adapter:zStack:znp:SREQ --> SYS - ping - {"capabilities":1}
2023-03-02T09:37:59.694Z zigbee-herdsman:adapter:zStack:unpi:writer --> frame [254,0,33,1,32]
2023-03-02T09:38:05.702Z zigbee-herdsman:adapter:zStack:znp:SREQ --> SYS - ping - {"capabilities":1}
2023-03-02T09:38:05.706Z zigbee-herdsman:adapter:zStack:unpi:writer --> frame [254,0,33,1,32]
Zigbee2MQTT:error 2023-03-02 10:38:11: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2023-03-02 10:38:11: Failed to start zigbee
Zigbee2MQTT:error 2023-03-02 10:38:11: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
Zigbee2MQTT:error 2023-03-02 10:38:11: Exiting...
Zigbee2MQTT:error 2023-03-02 10:38:12: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
    at ZStackAdapter.start (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/zStackAdapter.ts:103:27)
    at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:132:29)
    at Zigbee.start (/app/lib/zigbee.ts:58:27)
    at Controller.start (/app/lib/controller.ts:101:27)
    at start (/app/index.js:107:5)

I’m afraid that’s beyond my capabilities to debug, but I’ve seen others report similar issues in the past. Worth searching other posts here.

got it to run… only pain in the eye is HA’s default color slider goes from crazy 2000 to 4K something

ikea goes from 250-454… any clue on where to change the default?

I did this as well. A sonoff stick now instead of deconz.

What a relief!!

It worked all out of the bozlx, devices updated 1 by 1 and it just works now :+1:

1 Like

Great news on getting it running.

Which model ikea bulbs are you having issues with?

not an issue with the bulb, but the color slider in HA

What are the options for those lamps in the z2m interface? Is the range accurate?

the range in HA is way off… it starts with 2000 and should be 250-454

the ones in z2m are ok

the ones in HA are not

Those are different scales. Z2M’s is mired whilst HA uses Kelvin.

I too have an Ikea lamp and I’ve just conducted a test where the limits of the scale in both HA and Z2M correspond to each other. (250 mired = 4000K and 454 mired = 2202K).

can i change the scale in HA?

prob hidden somewhere

Doubtful, it was only recently changed to Kelvin:

The changed was released late last year - 2022.11: A heck of a release! - Home Assistant

it “nice” of them to force it on people and not have it as an option :-/

Hi I’m using Home Assistant OS latest version and cannot seem to find the deconz data directory where to put the Otau files.

If I look into the addons directory I find it empty

I tried searching for it

find / -type d -name "addon_core_deconz"

nothing found

Yet the add-on is running