Update ZigBee firmware using deCONZ on Hass.io

I just found that it is easily possible to update the firmware of my IKEA tradfri bulbs that are connected to a Conbee2 by Dresden Electronics which is plugged into my Hass.io Raspi! The process is actually quite simple.

With a bit more effort you can also update OSRAM devices (= Ledvance / Smart+). See the discussion below for details (postings of @manup and @gerard33 - thanks guys!).

Unfortunately there is currently no way to update Philips Hue. You still need a Hue bridge to do that.
As @radar commented: deCONZ now seems to provide at least some firmware images for Hue devices too.

Here is how to do it for IKEA gadgets…

My setup:

  • Conbee2 adapter plugged into Raspi running Hass.io. I guess the RaspBee shield would work too.
  • Hass.io 0.103.4 and latest deCONZ add-on 5.0 installed and configured.
  • VNC connection set up for deCONZ. The setup instructions can be found in the installation instructions of the above add-on.

Steps to update:

  • Open the VNC connection to the deCONZ application. You will need a VNC viewer somewhere on your network to do that.
  • In the application activate the checkbox in the menu under: Plugins –> STD OTAU Plugin
  • This activates an additional tab “STD OTAU Plugin” in the left-side pane (the tabs are found at the BOTTOM of that pane!)
  • In that tab make sure that the sub-tab “OTAU Update” is selected.
  • There you will find a list of updatable ZigBee items. Just mark one of them and click the “Query” button. It may take some time until you see a reaction! Then the Progress column will start counting up until the update is complete.
  • Tipp: If you hover over the number in the Version column you will see a pop-up with the current version and build of that ZigBee item.

Happy updating! :smiley:

26 Likes

I really need to look into this.
One question though, How do you ensure the VNC part is set up?
(is this the part that shows the network map? As I’ve never been able to find that in my install so far)

Yes, this is exactly the application that shows the ZigBee mesh map. The VNC server is part of the Home Assistant deCONZ add-on. The setup is described right in the installation instructions of that add-on. All you need apart from that is a VNC viewer to contact the VNC server.

I have updated the original posting accordingly.

Ah! I added Deconz quite some time ago before it was integrated so never looked at the installation instructions since then!
Will have a dig around over the holidays. Thanks!

Do you have to download the firmware file from the Ikea website before you update?

No, not at all. deCONZ does it all for you!
You simply hit that “Query” button. Nothing else needed.

1 Like

First thanks a lot for sharing the detailed instruction! This is something I’ve been looking for for quite some time!

But, hmmm… I’m not sure how it works in real life… I followed your instructions to the point of pressing Query button and then nothing happens… I did wait for quite some time and no progress visible at all. Hovering mouse cursor over the Version field shows that update is available (version with higher number). Progress field shows No File message.
What is interesting to me is the Update button… while hovering the mouse over it I can see message Start update for selected node. File must be choosen first. No file is selected however in Otau file field. While clicking on file selection buton (…) I can see the list of files (seems somehow uploaded to Phoscon data folder), but naming convention for these is, well, unreadible… I’d not take the risk of selecting one of these for updating firmware. :slight_smile:
So the question is what exactly should we expect to happen in step of Update? How long it might take in real life to start seing update (I waited ~30 minutes). What is your experience with this? Perhaps I’m facing some connectivity issues…
Also I have multiple devices of the same type (~25 GU10 bulbs from Ikea), should I repeat the same operation for each device to get it updated or will phoscon handle it?

2 Likes

I have the same questions and I also see the ‘No file’ message, but I’m trying it with Philips Hue bulbs and Xiaomi Aqara hardware. (Just wanted to see if that’s going to work :slight_smile:)

Unfortunatly it would work only for a few brands, mainly Ikea.
Here is the available firmware in /root/otau

10005777-4.1-TRADFRI-control-outlet-2.0.022.ota.ota.signed
10005778-4.1-TRADFRI-onoff-shortcut-control-2.2.008.ota.ota.signed
10032198-2.1-TRADFRI-gateway-1.9.27.p.elf.sig.ota.signed
10035514-TRADFRI-bulb-ws-1.2.221.ota.ota.signed
10035515-TRADFRI-bulb-cws-1.3.009.ota.ota.signed
10035534-TRADFRI-bulb-ws-gu10-1.2.221.ota.ota.signed
10037585-5.1-TRADFRI-connected-blind-2.2.009.ota.ota.signed
10037603-3.1-TRADFRI-signal-repeater-2.2.005.ota.ota.signed
10038562-TRADFRI-sy5882-bulb-ws-2.0.022.ota.ota.signed
10039874-1.0-TRADFRI-motion-sensor-2-2.0.022.ota.ota.signed
10040611-3.2-TRADFRI-sy5882-unified-2.1.022.ota.ota.signed
10046695-1.1-TRADFRI-light-unified-w-2.1.022.ota.ota.signed
1014-0005-14010400.zigbee                     
1135-0000-2010009B-FLS-PP3_RGBW.zigbee        
1135-0000-2010009B-FLS-PP3_RGBW.zigbee.md5    
1135-0000-201000A0-FLS-PP3_RGBW.zigbee        
1135-0000-201000A0-FLS-PP3_RGBW.zigbee.md5    
1135-0006-20100021-Ribag.zigbee               
1135-0006-20100021-Ribag.zigbee.md5           
117C-0002-165801BC.zigbee                     
117C-1101-20022623.zigbee                     
117C-1102-22005631.zigbee                     
117C-1187-22009631.zigbee                     
117C-11C1-23014631.zigbee                     
117C-11C2-12248572.zigbee                     
117C-11C4-12214572.zigbee                     
117C-11C5-22008631.zigbee                     
117C-11C8-20022623.zigbee                     
117C-2101-12214572.zigbee                     
117C-2201-12221572.zigbee                     
117C-2202-12217572.zigbee                     
117C-2203-12221572.zigbee                     
117C-2801-13009572.zigbee                     
117C-4101-12245572.zigbee                     
117C-4103-21022631.zigbee                     
117C-4201-12217572.zigbee                     
117C-4202-12217572.zigbee                     
117C-4203-20022623.zigbee                     
117C-4204-20022623.zigbee                     
117C-4205-21022631.zigbee                     
14010400_0x0005.zigbee                        
14010400_0x0005.zigbee.md5                    
159495-TRADFRI-transformer-1.2.245.ota.ota.signed
159695-TRADFRI-bulb-ws-1000lm-1.2.217.ota.ota.signed
159696-TRADFRI-bulb-w-1000lm-1.2.214.ota.ota.signed
159697-TRADFRI-driver-hp-1.2.217.ota.ota.signed
159698-TRADFRI-driver-lp-1.2.217.ota.ota.signed
159699-5.1-TRADFRI-remote-control-2.3.014.ota.ota.signed
159700-TRADFRI-motion-sensor-1.2.214.ota.ota.signed
159701-TRADFRI-wireless-dimmer-1.2.248.ota.ota.signed
190579-ncp572b444.ebl.ota.ota.signed          
191100-4.1-TRADFRI-sy5882-driver-ws-2.0.022.ota.ota.signed

For OSRAM devices there is this a small guide at https://phoscon.de/en/support#ota-update-osram-devices.

Philips Hue devices are currently not supported as there are no firmware files available yet easily (on Github someone could extract the URL for one hue light but we couldn’t manage to get this working in a broad sense yet).

3 Likes

That’s great, thanks for sharing it !

I have used that guide to successfully upgrade my Osram devices a few weeks ago.

When using Hassio you can use the steps below to upload the OTAU files to the Deconz add-on, so you can easily select the file in step 5b of the instruction:

  1. Download the OTAU file as mentioned in step 4.
  2. Copy the file to your Hassio share folder.
  3. Use the SSH & Web Terminal add-on to SSH into Hassio.
  4. Run this command to copy the OTAU file to the Deconz addon

docker cp /share/ZLL_MK_0x01020510_CLA60_W_CLEAR.ota addon_core_deconz:/data/otau/

where ZLL_MK_0x01020510_CLA60_W_CLEAR.ota is an example of an OTAU filename.

1 Like

Thanks for the post! This was great, and worked great for my Trådfri devices.
Does anybody know if INNR-plugs are upgradable? I got the “No file…” on that one.

Exactly the same here. Everything just says no file. Query does nothing. Some of my Tradfri devices are definitely out of date and the correct files are in the folder.

1 Like

Strange. I can only repeat that for me it took also some time after clicking Query (several minutes). I had already given up and then for no obvious reason when I looked again I found that the update process had started.

Could it be that you have to restart your HA deCONZ add-on after activating the STD OTAU Plugin? The log of my add-on shows the following lines at a restart that indicate that some IKEA related code has been initialized:

[09:50:04] INFO: Running the deCONZ OTA updater...
[09:50:04] INFO: Running the IKEA OTA updater...
[09:50:04] INFO: deCONZ is set up and running!

@Jpsy, where do you get deCONZ log from? I see some similarily looking deCONZ entries in home-assistant.log, but no such info as you posted, only something about setting up different ZigBee components.
I restarted hassio few times in meantime, one thing I noticed is that after every restart I have to re-enable STD OTAU Plugin - it is not active anymore. I tried to find any option in preferences to have it done automaticaly, but found nothing. Perhaps this is the problem.

@Jpsy those lines appear in my log, but as with @mirekmal theres no OTAU plugin at launch - it needs to be readded. Do you by any chance have the ikea plugs at all? Can you confirm what firmware deconz (none vnc) shows? I see the following :

58

In the OTAU folder I see a file for 2.0.022 so it seems this is out of date, but perhaps deconz has in fact updated it and it shows as 1.4 anyway?

EDIT:

I see OTAU disabled in the bottom right of this window… does yours say enabled?

04

Thanks,

Dan

@Dan for me message changes from OTAU disabled to enabled when I click on Query button. It stays like that until next restart, then it needs to be re-enabled again.
Regarding ikea plug version - inconsistency of version representation is very annoing in Phoscon :frowning:

  • Phoscon add-on in hassio shows current version 2.0.022
  • Plugin shows in version column 0x20022623
  • After hovering the mouse over I can see that latest available version is 2.0 build 140835
  • in data folder I can see 2.0.022 being available (10005777-4.1-TRADFRI-control-outlet-2.0.022.ota.ota.signed)

Thanks. One more quick request if I may (your help is very much appreciated). Does the OTAU section in the node menu look this this for you? (This screenshot shows my conbee and one of my ikea plugs). OTAU looks greyed out in the plug menu and Im curious if you see the same.

38 )