Updater component not working, what am I doing wrong?

Currently running Hass as a docker image (v 0.97.2) on my Synology NAS. Still a n00b, so sorry if this is a stupid question. Couldn’t really find something recent about this on the forum.

Added this to configuration.yaml

updater:
  include_used_components: true

Since 0.98 is out I would have expected to see something, but I don’t (in Lovelace, nor old states)

Or do i have to add something to the lovelace ui config?

Thanks!!

Add an entities card with the binary_sensor.updater entity.

OK, I will try that. Maybe an idea to add that info here too https://www.home-assistant.io/components/updater/

I assumed it would be automatically added like many other integrations.

Sure go for it:

1 Like

Cool, that’s good to know. I will update it after I get it working!

1 Like

Keep in mind that the sensor only updates once a day. So if you restart HA it can show as “unknown” for a day.

For this reason I don’t show it in the front end and just trigger a notification when it’s state becomes ‘on’.

OK, but as you said, you first need to add the binary_sensor.updater entity before even showing up as unknown. Or should I already have a circle at the top stating unkown (which I haven’t) without adding the code?

Correct. Just thought I’d mention it in case you thought it wasn’t working when you saw ‘unknown’.

Updater doesn’t work as it should be, there is a new update since yesterday and it has not changed state. Seems to me that the problem is the web address against which he campares the version of HA, It still shows 0.98.1.

So I got everything setup in terms of sensors etc, so my lovelace is fully populated. So now I can start edit the lovelace config.

I still don’t understand how to get this to work. I have the updater in my configuration.yaml as top level entity, but no binary_sensor.updater shows up in the developer tools -> states. So I cannot make a card for it.

Or do I also have to add the sensor to configuration.yaml? Which makes the updater: top level entity pretty useless…

Not sure where I should ask this.
Homeassistant 0.100 has bean released for a few days by now, but https://updater.home-assistant.io (and thus the updater-component) still show 0.99.3 as the newest version.

If the release on that page isn’t updated, the updater component is rather useless.

2 Likes

Any news update the updater? Not working till now …

Regards, Steffen

Same here. I’m using 103.2 with hassio.

How do you trigger a notification?

  trigger:
    platform: state
    entity_id: binary_sensor.updater
    to: 'on'

I have rarely seen this work now. every update pushed to HA, after a few days even, its still not working. its always unavailable.

Having the exact same issue

Ok. I have been an idiot here. I didn’t seem to be up to date on HA changes so the sensor was updater.update or something like that and once updated it works fine. this sensor was add when this sensor was introduced way back so i never got to change it.

I don’t like the daily check, which rarely seems to actually update for me. You can call the service “homeassistant.update_entity” with “entity_id: binary_sensor.updater” to force a check whenever you want, like on an hourly timer. If you use Node-RED, the following flow will check every hour on the hour, and notify your mobile app when an update is available. It uses the Cron-Plus node which is better than the timer built into the inject node.

[{"id":"3a4f62b2.f3597e","type":"tab","label":"Updater","disabled":false,"info":""},{"id":"87b09d94.748c","type":"api-call-service","z":"3a4f62b2.f3597e","name":"Check for Updates","server":"b2b4933d.45d52","version":1,"debugenabled":false,"service_domain":"homeassistant","service":"update_entity","entityId":"binary_sensor.updater","data":"","dataType":"json","mergecontext":"","output_location":"","output_location_type":"none","mustacheAltTags":false,"x":370,"y":100,"wires":[[]]},{"id":"798be00e.3067f","type":"cronplus","z":"3a4f62b2.f3597e","name":"Every hour","outputField":"payload","timeZone":"","options":[{"topic":"every hour","payload":"on","type":"str","expression":"0 0 * * * * *"}],"x":130,"y":100,"wires":[["87b09d94.748c"]],"outputLabels":["every hour"]},{"id":"22521bfc.ad9b74","type":"trigger-state","z":"3a4f62b2.f3597e","name":"Update available","server":"b2b4933d.45d52","exposeToHomeAssistant":false,"haConfig":[{"property":"name","value":""},{"property":"icon","value":""}],"entityid":"binary_sensor.updater","entityidfiltertype":"exact","debugenabled":false,"constraints":[{"id":"sd752m9bl5r","targetType":"this_entity","targetValue":"","propertyType":"current_state","propertyValue":"new_state.state","comparatorType":"is_not","comparatorValueDatatype":"prevEntity","comparatorValue":"state"},{"id":"7kq7k28gjtr","targetType":"this_entity","targetValue":"","propertyType":"current_state","propertyValue":"new_state.state","comparatorType":"is","comparatorValueDatatype":"str","comparatorValue":"on"}],"constraintsmustmatch":"all","outputs":2,"customoutputs":[],"outputinitially":true,"state_type":"str","x":140,"y":200,"wires":[["cae9e776.a33278"],[]],"outputLabels":["true","false"]},{"id":"cae9e776.a33278","type":"api-call-service","z":"3a4f62b2.f3597e","name":"Notify mobile","server":"b2b4933d.45d52","version":1,"debugenabled":false,"service_domain":"notify","service":"mobile_app_william_s_s10","entityId":"","data":"{\"title\":\"Update Available\",\"message\":\"Home Assistant {{data.event.new_state.attributes.newest_version}} is available.\"}","dataType":"json","mergecontext":"","output_location":"","output_location_type":"none","mustacheAltTags":false,"x":350,"y":200,"wires":[[]]},{"id":"b2b4933d.45d52","type":"server","z":"","name":"Home Assistant","legacy":false,"addon":true,"rejectUnauthorizedCerts":true,"ha_boolean":"y|yes|true|on|home|open","connectionDelay":true,"cacheJson":true}]
1 Like

You can use the scrape sensor:
Scrape sensor

Running natively on Home Assistant and you can specify your scan interval, even change the scan interval depending of the time of day with an automation. Use it to notify your phone when a new update is released. :+1:

sensor:
  - platform: scrape
    resource: https://www.home-assistant.io
    name: Release
    scan_interval:
      hours: 1
    select: ".current-version h1"
    value_template: '{{ value.split(":")[1] }}'