Updating ESPHome?

I have a very plain, simple Home Assistant setup. Every other month, or so, I update the modules that HA indicates need updating, but have made no other changes. Everything has worked fine for years until just recently.

A week or so ago, HA assistant indicated that ESPHome should be updated. Fine. Once that was done, it indicated that the two devices that are controlled via ESPHome needed to be updated and this is consistent with previous updates. However, then I clicked on ‘Install’ from the Settings->Update->DeviceName screen, I was told “Failed to call service update/install. Error compiling DeviceName.yaml; Try again in ESPHome dashboard for more information.” But when I clicked on the ESP Home tag, to see the ESPHome dashboard, I was informed “Supervisor - Unable to fetch add-on info to start ingress”.

Note that I am still seeing messages to update ESPHome (currently running V 2024.6.3) and the two devices. What should I do? Note this is not a panicked ask since everything is still working as it should.

The yaml not compiling is most likely this:

The esphome addon not being reachable via the icon is something else, I would first try a HA restart or even host restart.

Edwin_D: Thank you. The icon is not the issue, I suspect my problem relates to the first thing you mentioned.

Took me a minute, but I found a .yaml file in the ESPHome directory and there was an OTA line in said file. Per the link you pointed me to, I update the file, but I was still unable to update!

I then did a restart, which (I assume) causes the YAML files to be reread. This time the updates worked - thanks!

Thank you @Edwin_D your suggested fix worked great for me. I too have had a flawless HA setup working for years with only one ESPHome device, this new error had been bugging me for a while but tonight was the first time I sat down to troubleshoot it. Thank you for helping me solve it quickly!

1 Like