Updating HA Core to 2024.7.0 and 7.1 Energy Dashboard is not working FIXED

Same here, stops at 4am, reboot fixes it

Same here, logging stop at 4:00 am and a restart of the HA server solve it…

You need to configure the recorder in your configuration.yaml.

   auto_purge: false

This disables the nightly 4am auto purge. Be sure to enable it again or configure otherwise by automation. More into on the recorder and purging: Recorder - Home Assistant

1 Like


This resulted in the stats coming back but the last few days are still missing.
Are they lost forever?

Also, this seems to break shelly gen 1 integratated devices for some reason :frowning:

Lost forever :-/

Did you report this to the dev of icloud3? The thing is I don’t want to miss icloud3 …

Can anyone else comment on the fix with 2024.7.2 ?

Applying 2024.7.2 appears to have fixed the problem. It’s a bullet item at the top of the list of fixes. Installed and manually ran a purge and repack and the task finished in a couple minutes and CPU returned to normal state.

Yes, I can confirm. I installed 2024.7.2 and then enabled auto purge again.

Hard to prevent, it is a major bobo. I’m surprised this is not seen in the beta branch before release.

Updated to 2024.7.2 last night, but unfortunately it didn’t help. The energy dashboard didn’t show any new data after ~04:15. Also some history graphs of ESPHOME sensors (and used in the energy dashboard) are not updated anymore.

I downgraded again to 2024.6.4…

Lost the energy dashboard after the update 2024.7.1 to 2024.7.2, going back to 2024.7.1 shows the dashboard again with all history except the last days.