Upgrade from 0.83 to 0.83.1 Problem - Can´t access anything

Thanks @1337hium, that fixed it for me!
(It’s strange though, that this doesn’t only throw some kind of “unknown platform” error but completely kills HA)


Same here on the owntracks fix. Maybe this needs to be fixed upstream ? Has anyone filed a bug ?

Some problem with “Unable to connect to Home Assistant” here. Automations and file access works though.

Same problem here! :disappointed_relieved::disappointed_relieved: And not solved with owntracks changes!!

I had the same problem, had to reinstall HASSOS on a new SD card and restore from an old backup. Up and running now, but afraid to try the 83.1 update again. BTW, I do not run owntracks.

Removing owntracks from config made it possible to run HA again. After removing onwtracks from configuration, i did an update to 0.83.1 without problems, so nothing to be afraid of :wink:

I had the same problem updated from 0.83 to 0.83.1. I don’t have owntracks. The error log from Hassio is:

18-11-30 15:07:56 INFO (MainThread) [hassio.homeassistant] Successful run Home Assistant 0.82.1
18-11-30 15:07:56 ERROR (MainThread) [aiohttp.server] Error handling request
Traceback (most recent call last):
File “/usr/local/lib/python3.7/site-packages/docker/api/client.py”, line 229, in _raise_for_status
File “/usr/local/lib/python3.7/site-packages/requests/models.py”, line 940, in raise_for_status
raise HTTPError(http_error_msg, response=self)
requests.exceptions.HTTPError: 500 Server Error: Internal Server Error for url: http+docker://localhost/v1.37/images/sha256:da975f1106e20776c9d55decd7ab30fafae1fc7d0e9b6b66bc97b0375b7192f1/json
During handling of the above exception, another exception occurred:
Traceback (most recent call last):
File “/usr/local/lib/python3.7/site-packages/aiohttp/web_protocol.py”, line 390, in start
resp = await self._request_handler(request)
File “/usr/local/lib/python3.7/site-packages/aiohttp/web_app.py”, line 366, in _handle
resp = await handler(request)
File “/usr/local/lib/python3.7/site-packages/aiohttp/web_middlewares.py”, line 106, in impl
return await handler(request)
File “/usr/local/lib/python3.7/site-packages/hassio/api/security.py”, line 137, in token_validation
return await handler(request)
File “/usr/local/lib/python3.7/site-packages/hassio/api/utils.py”, line 32, in wrap_api
answer = await method(api, *args, **kwargs)
File “/usr/local/lib/python3.7/site-packages/hassio/api/homeassistant.py”, line 116, in update
await asyncio.shield(self.sys_homeassistant.update(version))
File “/usr/local/lib/python3.7/site-packages/hassio/utils/init.py”, line 33, in wrap_api
return await method(api, *args, **kwargs)
File “/usr/local/lib/python3.7/site-packages/hassio/homeassistant.py”, line 277, in update
await _update(version)
File “/usr/local/lib/python3.7/site-packages/hassio/homeassistant.py”, line 268, in _update
if not await self.instance.update(to_version):
File “/usr/local/lib/python3.7/site-packages/hassio/utils/init.py”, line 33, in wrap_api
return await method(api, *args, **kwargs)
File “/usr/local/lib/python3.7/concurrent/futures/thread.py”, line 57, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/local/lib/python3.7/site-packages/hassio/docker/interface.py”, line 247, in _update
File “/usr/local/lib/python3.7/site-packages/hassio/docker/interface.py”, line 289, in _cleanup
for image in self.sys_docker.images.list(name=self.image):
File “/usr/local/lib/python3.7/site-packages/docker/models/images.py”, line 338, in list
return [self.get(r[“Id”]) for r in resp]
File “/usr/local/lib/python3.7/site-packages/docker/models/images.py”, line 338, in <listcomp>
return [self.get(r[“Id”]) for r in resp]
File “/usr/local/lib/python3.7/site-packages/docker/models/images.py”, line 295, in get
return self.prepare_model(self.client.api.inspect_image(name))
File “/usr/local/lib/python3.7/site-packages/docker/utils/decorators.py”, line 19, in wrapped
return f(self, resource_id, *args, **kwargs)
File “/usr/local/lib/python3.7/site-packages/docker/api/image.py”, line 245, in inspect_image
self._get(self._url(“/images/{0}/json”, image)), True
File “/usr/local/lib/python3.7/site-packages/docker/api/client.py”, line 235, in _result
File “/usr/local/lib/python3.7/site-packages/docker/api/client.py”, line 231, in _raise_for_status
raise create_api_error_from_http_exception(e)
File “/usr/local/lib/python3.7/site-packages/docker/errors.py”, line 31, in create_api_error_from_http_exception
raise cls(e, response=response, explanation=explanation)
docker.errors.APIError: 500 Server Error: Internal Server Error (“readlink /var/lib/docker/overlay2/l: invalid argument”)

Solved by downgrading first to 0.82 than upgrade back to 0.83.1

hassio ha update -o version=0.82


hassio ha update -o version=0.83.1

1 Like

I can’t get the frontend to load either. Tried to upgrade from 0.83 to 0.83.1 (although it said 0.82.1) and even though I’ve commented out owntracks from my config I still get this in my logs:

2018-11-30 18:43:56 ERROR (MainThread) [homeassistant.loader] Unable to find component owntracks
2018-11-30 18:43:56 ERROR (MainThread) [homeassistant.setup] Setup failed for owntracks: Component not found.

I also tried deleting my DB but still no joy.

Also in my log is:
2018-11-30 18:56:53 ERROR (MainThread) [homeassistant.setup] Error during setup of component hassio
Traceback (most recent call last):
File “/usr/local/lib/python3.6/site-packages/homeassistant/setup.py”, line 145, in _async_setup_component
hass, processed_config)
File “/usr/local/lib/python3.6/site-packages/homeassistant/components/hassio/init.py”, line 178, in async_setup
user = await hass.auth.async_get_user(data[‘hassio_user’])
File “/usr/local/lib/python3.6/site-packages/homeassistant/auth/init.py”, line 118, in async_get_user
return await self._store.async_get_user(user_id)
File “/usr/local/lib/python3.6/site-packages/homeassistant/auth/auth_store.py”, line 56, in async_get_user
await self._async_load()
File “/usr/local/lib/python3.6/site-packages/homeassistant/auth/auth_store.py”, line 247, in _async_load
KeyError: ‘name’

I confirm Owns track is causing the unreachable HA interface error after updating to 0.83.1.
To overcome this, you remove the owns track declaration from the configuration file, check the configuration-validate - next update normally.
I had to recover the snapshot in 0.82.1 to 5 times and learned this lesson.

Thanks @kiucheng, that worked!
hassio ha update -o version=0.82 resulted in an error but hassio ha update -o version=0.83.1 brought HASS.IO back to life.

No Owntracks to blame, must have been something else.

Had same problem after upgrade to .83.2. Removed Owntracks and am how able to login to Home Assistant.

Do all you guys just refuse to read the release notes before upgrading?

1 Like

I too am having these issues. All my automatons are work properly, but not able to access the front end. Do not and have never used Owntracks. Read the release notes, but do not see any changes that would break my front end.

What error do you see? Have you tried deleting settings in the browser - removing all site data and clearing cookies/cache.

Do you have frontend: latest in config yaml? I think you need that.

Same old story every release

Thanks for the suggestions! I fixed my problem by removing the docker images, re-install, then restore from a previous back-up. Not the best solution, but it worked for me.

Prior to my fix, I was seeing pretty much the same error as OP. “Error during setup of component hassio” and “Error handling request” with several files listed below. No longer have logs, so can’t be any more specific.

I did clear the site data, cookies, and cache in Chrome; however, the problem persisted. Frontend was also listed in config yaml.

No idea what the problem was, but glad I was able to resolve.

I click upgrade and it goes to 0.82.1 instead of 0.83.1

This is first time i move from hassbian to hassos at version
core-ssh:~# hassio ha info
“result”: “ok”,
“data”: {
“version”: “0.82.1”,
“last_version”: “0.83.1”,

I have a similar error in that Hass.io see’s there is a update for 0.83.1 when I try to process a update it downloads the update but then loads back into 0.82.1 that I currently have installed.

I am having the same issue

Fixed it for me too, Should be in the release notes.