Upgraded ikea switch, now no binding to group so automation issues

HI all,
I thought it was a good idea to upgrade almost all my ikea switches (IKEA E1743 control via MQTT | Zigbee2MQTT). I knew this firmware doens’t bind to group anymore but now to bulb but that was no issue but unfortunatly it does.
I have all my switches bound to the corresponding bulb but now my automations won’t work based on the CLICK/ACTION of my button.

How can i solve this issue ?

I want to be able to controll my lights, even when the coordinator is down. that worked before the upgrade…

thanks in advance.

Did you try binding them again?

You mean binding to a group, well not really because as Koekk mentioned itself


The binding functionallity of this remote varies per firmware version:

  • below 2.3.75: suppports binding to groups only. It can only be bound to 1 group at a time. By default this remote is bound to the default bind group which you first have to unbind it from. This can be done by sending to zigbee2mqtt/bridge/request/device/unbind payload {"from": "DEVICE_FRIENDLY_NAME", "to": "default_bind_group"}. Wake up the device right before sending the commands by pressing a button on it.
  • 2.3.075 and greater: supports binding to devices only

After the upgrade I removed the group (was not working anymore) added the lightbulbs and now in my zigbee2mqtt logs I don’t see the action anymore, even with having an bind to the coordinator.

Are you proposing to completly remove them and bind them again to my network ?

Yes, its fixed.
The problem was as I said that the coordinator is not seeing the on/off action but that is because that checbox was not selected.
I had re-paired one of the other switches and then I saw that also that checkbox was enabled.
I checked on/off to another switch and now my coordinator is seeing my on/off action!..

Glad this worked.