USB3.0 Radio Frequency Interference

In case someone else runs into the same problem, I just wanted to report my recent experience:

I was setting up a second Home Assistant instance (for my cabin) on an RPi4 with the data partition on a USB3.0 SSD (the RPi4 booting from the SD card, but with the data partion on the SSD).

This worked well and is not the issue in this post.

Later I found that I had lost control of all zigbee devices on my home’s HA instance. My home’s HA instance is running on a NUC and zigbee uses the deconz integration and a ConbeeII stick connected via a USB extension cable.

After a couple of hours of despair, I found that the problem was that I had left my second HA instance (the one on the RPi4 with the USB3.0 SSD) on my desk close to the ConbeeII stick. USB3.0 is known (it wasn’t to me, but it is now) to create radio interference for 2.4 GHz devices.

Moving the RPi4 with the USB3.0 a meter or so away from the ConbeeII stick solved the problem and I regained control of my zigbee network.

As this was quite a surprise to me and since I could not find anything about this here at the forum, I thought I would mention this in case someone else experiences something similar.


I had same issue with my Zwave stick. I have a 2meter long USB3 cable with a extra layer around to protect from interference. My Zwave network is working blasting fast for almost a year now.

Everywhere you read to put your Zwave or ZIgbee stick far away from your RPi

1 Like

I had the same issues with my first setup. I thought using an external ssd would help with stability but little did I know this would be the source of all my woes in getting started with HA. I think there needs to be more prominent information available when setting up a HA server using usb3.

Issues I found:

  1. Usb3 ssd when in a low power/low speed mode doesn’t cause too much interference. Though can be unstable if not enough current is supplied the ssd. In my case I had a 3amp psu which was enough to run the ssd but only in a low power mode. This caused intermittent drop out issues.

  2. Usb3 when in high speed mode generates lots of noise around the 2.5ghz frequency which crosses into the 2.4ghz band causing issues with zigbee and WiFi when operating in 2.4ghz bands. Once I resolved my ssd power issues it caused almost all my radio to start intermittently fail.

As a lot of setups will be near the router and have the devices connected directly to the computer often raspberry pi, they will exacibate potentially both these issues and face lots of stability issues.

In my case using a powered hub, moving the pi and ssd as far away from any radio solved these issues.

Had I used an sd card I likely wouldn’t have had any of these issues.

FYI, tried to cover the mentioned issue + more in this documentation update PR for the ZHA integration: