Valetudo Map Card Installation Instructions

Tried to install Valetudo Map Card. Installed via HACS as suggested.

According to the instructions the card should be registered right away - it was not.
Also acc. to the instructions the path for manual registering should be

/community_plugin/lovelace-valetudo-map-card/valetudo-map-card.js

which also didn’t work for me.

I had to register the card by adding the path

/local/community/lovelace-valetudo-map-card/valetudo-map-card.js

to lovelace’s resources.

Hopefully this will save some time for the next poor soul trying to get this to work!

Side note: don’t forget to add the vacuum_entity property if you want buttons to show up.

Hi !
I have also problems installing this package and couldn’t solve it so far.

I’ve followed the installation instructions of hacs and the lovelace plugin several times with no success.

Always the same behavior: the card isn’t registered and attempts to add it manually fails obviously (but without any noticeable error message).

image

I’ve searched the location of the JavaScript file on my system and found it relatively to the root folder of my HA installation at

./www/community/lovelace-valetudo-map-card/valetudo-map-card.js

According to your post I tried both paths

  • /local/community/lovelace-valetudo-map-card/valetudo-map-card.js
  • /local/www/community/lovelace-valetudo-map-card/valetudo-map-card.js

but without success.

I’m using:

  • Home Assistant 2021.8.8 running on a Raspberry PI 4 in Docker
  • HACS 1.15.1
  • Lovelace Valetudo Map Card v2021-08-12

Any hints that might solve the problem ?
(Maybe to enable logger for debug messages to see if the JavaScript file was found and loaded ?)…

Thanks,
Michael.

Hi and welcome to the forum!

No need to tinker with anything (anymore?), in the meantime I removed any manual changes I made and just installed it using HACS.

Please bear in mind that there will be no new card type visible in Lovelace, you have to configure it manually!

My current config looks as follows:

type: custom:valetudo-map-card
vacuum_entity: vacuum.robot
entity: camera.map
title: null

If you did that already try

  • deleting your browser’s cache
  • using a different browser
  • using your browser’s private mode

Hi, and many thanks for your feedback.

According to your information I was finally able to fix it !!!

  1. I had to add a new card explicitly to the dashboard.
    The above shown card was added automatically once the robot was detected the first time.
    But I had to adjust the lovelace config slightly (due to different valetudo firmware ?):
  type: custom:valetudo-map-card
  vacuum_entity: vacuum.valetudo_robot
  entity: camera.map_data
  title: Rockrobo Map
  1. And I still had to add the JavaScript manually - there was no automatic detection:

Glad to hear that!
The IDs may differ, since you can set those manually when setting up the vacuum in HA.

#2 is weird, but as long as everything works now ¯_(ツ)_/¯

Yeah, I’m happy now :smiley:

The map is showed but also a “not loaded” warning/error under hacs/frontend:

(had to split the message into parts because as new user I’m only allowed to upload one image)

Tried to remove the entry from config/lovelace/resources but than the card isn’t available:

Adding the resources back:

strange … :thinking:

Sorry to dig this up but I have the same problem. Installed HACS and the valetudo map, latest versions of course. HA is current.
The .js ended up in /config/www/community/lovelace-valetudo-map-card/.
There is no /local/… path on my system. Do I have to create it? (that would be no problem)

Thanks.