Home Assistant Community

Valetudo - Xiaomi Vacuum Dustcloud alternative, Live Maps

#29

I’ve tried the new firmware v3416 and v3514 and when i compile them with the command

sudo ./dustcloud/devices/xiaomi.vacuum/firmwarebuilder/imagebuilder.sh -f sebgen1firmwarev3416.pkg -k id_rsa.pub

It throws an error that “…/dc/image” doesn’t exist midway through the process. This doesn’t happen when i do it for firmware v3254. Despite this I still try to flash it to my Mi Robot however it doesn’t work. MiRobot rejects it.

Is anyone else here using a rooted firmware on their Gen 1 Mi Robot that higher than v3254?

0 Likes

#30

you need to download latest pkg and do the whole rooting process again either from here:


or by doing this: https://github.com/dgiese/dustcloud/wiki/VacuumRobots-disableUpdates and then start the firmware update from your app, then copy firmware from temp folder (look it up in google) and rooting that one, reenabling the crypto and start the firmware upgrade with mirobo.

1 Like

#31

All links are broken. Trying to look for a way on rooting the device

0 Likes

#32

Which links?

The original two I posted on the first post both work ok for me.

0 Likes

#33

I receive this

Forbidden

You don’t have permission to access /public/xiaomi.vacuum.gen1/original/encrypted/ on this server.

0 Likes

#34

I guess you are trying to download the firmware?

Have a look at this in the Wiki

0 Likes

#35

This is turning out a bit mpre difficult then expected :smiley:

I am following this for rooting

but I don’t know how to do this …
Create custom image with imagebuilder.sh

0 Likes

#36

I succesfully made the vacuum work with HASS (not the map), I also was succesful in using the FLOLEVAC android app.

But I can make it work one (HASS) OR the other (app) not both. My goal is to make both work, hope that rooting serves this purpose

0 Likes

#37

It tells you what to type in further down under “Instructions on Linux”

sudo ./dustcloud/devices/xiaomi.vacuum/firmwarebuilder/imagebuilder.sh -f v11_001228.pkg -k id_rsa.pub

If you are using Windows either use a Virtual Machine or a Raspberry PI

1 Like

#38

Oh right :slight_smile:
I am stuck at this command. Going here

https://dustcloud.seemoo.de/public/xiaomi.vacuum.gen1/original/encrypted/

its again

# Forbidden

You don't have permission to access /public/xiaomi.vacuum.gen1/original/encrypted/ on this server.

you have access to it? Maybe geo blocking of some sort??

0 Likes

#39

I linked to the Wiki before where it explains how to download direct from Xiaomi. Have you tried that?

0 Likes

#40

I made progresses but now a big roadblock. 3 hours of google searches brought no solution

when I try to do this

sudo apt-get install python3 python3-pip python3-venv python3-dev

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package python3-venv is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'python3-venv' has no installation candidate
0 Likes

#41

Try with out the virtual environment parts (python3-venv)

  1. Install the required packages: sudo apt-get install python3 python3-pip python3-dev

  2. Install wheel so the other packages can be installed successfully: pip install wheel

  3. Install python-miio for communicating with the vacuum: pip install python-miio

  4. Now press the wifi button on your vacuum and join the wifi created by it (‘roborock-vacuum-s5_XXXXXXXX’ or similar).

  5. Use the flasher script to upload the new firmware: python dustcloud/devices/xiaomi.vacuum/firmwarebuilder/flasher.py -f output/v11_001228.pkg

  6. The update takes several minutes. After the upload is complete, the robot explains that it is now going to install an upgrade and restarts when it is complete. Once the robot has successfully restarted, you can connect to it via SSH.

0 Likes

#43

Thanks a lot. I finally managed after 2 evenings to root the vacuum.

I can now ssh to it… but only from the raspberry that has the key (ssh key, I think) which is NOT the host that runs HASS.

The vacuum can be controlled by the Mi Home app, but not from HASS, maybe because of this ssh key thing?

0 Likes

#44

Which is the version that can save old maps?

1 Like

#45

I think for gen2 aka roborock s50 it should be v1518

0 Likes

#46

I have gen 1, you know for those?

0 Likes

#47

I’m not quite sure, but i dont think that gen1 has this feature. I think its gen2 only for now.

0 Likes

#48

Now I can enter my rooted Vacuum from the same raspberry pi with ssh keys (user root, password mypassword).

If I try to enter from any other machine (ubuntu where HASS is) I can’t entrer, permission denied, even if user and password are correct.

Need top understand all this ssh keys think. Man sometimes linux is difficult, for me lol

0 Likes

#49

Ok thank you

0 Likes