Home Assistant Community

Valetudo - Xiaomi Vacuum Dustcloud alternative, Live Maps

#83

Yes correct, I put username root and nothing in password. It does later ask for the password but not asks to convert

#84

Can confirm S50 firmware 1780 with a patched rrlogd has persist map. No more 500 errors when in charge mode.

1 Like
#85

Putty needs the private key, id_rsa, not id_rsa.pub . The id_rsa.pub should have been patched into your firmware file when you rooted the robot.The openSSH server on the robot verifies a challenge signed with id_rsa using id_rsa.pub. Hope this helps.

1 Like
#86

The guys over at Valetudo have released quite a big update, with better Map View, Carpet mode etc.

I have just reflashed Rosie to the newer firmware 1792, just remember firmwares above 1518 need the rrlogd patching on the Gen2.

#87

?? version 0.2 beta was released 19 days ago :frowning:

#88

It’s a heads up for people who might not track the GitHub. No one has posted on this thread in 2 months.

1 Like
#89

ahh :wink: got it

#90

Hi thanks for bringing this up.

I rooted now long ago, and I forgot which user password I used (lol) … I can access with SSH the vacuum, but login … any idea on what my options are?

#91

If you just want to update and you can still log in through SSH follow:

Otherwise just create new SSH Keys and re-perform the firmware build / flash.
You just need to know your IP address of the Vacuum and your access token.
I had to perform this last night as I had lost my SSH key.

As per

#92

Will do as a last resort.

Default User should be root correct? Is there any default password in installation?

#93

root is correct. Your password is what ever you setup when creating your SSH Key.

Luckily to reupload new firmware you don’t need that information. You create a new Key while doing the firmware and then you upload it with the IP address and access token.

#94

How did you get on @Klagio?

#95

For those who don’t keep an eye on the Valetudo GitHub there have been a couple of releases over the past couple of days adding MQTT support.

2 Likes
#96

I just rooted and flashed Valetudo, it’s great so far, but I cannot get the map sensor to work, it show up in Home assistant but gives me an error:

Error getting new camera image: Cannot connect to host 192.168.0.103unknown:80 ssl:None [Name does not resolve]

I just copied your sensor.yaml en configuration.yaml and changed the name in both files.
any ideas?

Xiaomi / RoboRock s50 more sensor information
#97

@n03xp3rt4tt4ll have you uploaded one of the newer packages with MQTT support as they deal with the Map in a different manner.

I have not upgraded to 0.3.0 yet my self as I have been too busy. But check out https://github.com/Hypfer/Valetudo/wiki/Home-Assistant-Integration it might help.

#98

So i updated to the newest version to use MQTT but how can I implement the map now?
Is it still the same way to create a sensor and a camera or is it easier now?

#99

Hi 0rn0lf,
Did you figure it out?
I would like to know that too.
I have all the mqtt controls in HA, but no map.
I’ve tried the sensor and camera image but without success.

#100

How do you get the controls to HA with MQTT?

Thanks

#101

Valetudo has mqtt auto discovery. Just adapt valetudo.conf to Our mqtt broker and it’ll be discoverd by hass

#102

I installed the Mosquitto broker AddOn with this config:

{
  "logins": [{"username": "local-user", "password": "mypw"}],
  "anonymous": false,
  "quiet_logs": true,
  "customize": {
    "active": false,
    "folder": "mosquitto"
  },
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem"
}

Then I adapt the config.json file on the robot like this:

{
  "spots": [],
  "areas": [],
  "mqtt": {
    "enabled": false,
    "identifier": "rockrobo",
    "topicPrefix": "valetudo",
    "autoconfPrefix": "homeassistant",
    "broker_url": "mqtt://local-user:[email protected]",
    "mapSettings": {
      "drawPath": true,
      "drawCharger": true,
      "drawRobot": true,
      "border": 2,
      "scale": 4
    }
  },
  "dummycloud": {
    "spoofedIP": "203.0.113.1",
    "bindIP": "127.0.0.1"
  },
  "map_upload_host": "http://127.0.0.1"
}

But the vaccum entity doesn’t appear in HA. Is there something that I’ve missed?

Thank you