Version 1.0.2 Released

iOS 1.0.2 is now available as an update in the App Store. If you aren’t seeing it just wait a few hours, it’ll eventually show up.

Thanks for all the great feedback thus far, please keep it coming! Feel free to leave a review on the App Store with your thoughts about the app so far too :).

New features and improvements:

  • Enable zone tracking by default (no more track_ios required!)
  • Allow enable/disable of location-related notifications (check the Location Settings screen)
  • Rename push token to push ID and remove from identify payload to cut down confusion
  • Prepend base URL if attachment URL begins with /api/ (No need to prepend your base URL to notification attachments)
  • Whenever we update location let’s identify too so battery gets updated (battery stats should update much more frequently)

Bug fixes:

  • Remove some force unwraps which may have been causing crashing bugs around notification and location setup
  • Don’t force unwrap base URL in connect step (was also possibly causing crashes around notification/location)
  • Quote the password in the userscript (Should fix auto login problems)
  • Make app version number a string instead of an int since semver can’t be coerced to an int like 1.0 could (This is the long term version of the fix implemented in 0.42.4)

Great work! I think it is finnaly ready for the wife’s phone.
Where would the best place be for feature requests?

Thank you again!

Autologin works now, cool But when I click enable location tracking the app locks up.

Interesting, I saw the update and installed it. But do not see any new options.

Settings->Location Settings->Notifications at the top. Looks like this.

Ok, so I installed the upgrade and clocked open but didn’t see anything new. Then saw the update still showing in app store so installed it again and that time it worked.

I know for sure it was installed the first time as the button changed from upgrade to open.

Will add a version string in the app. Had a couple requests to do so anyway.

Small bug: when I enter my device id the keyboard covers the field where I am entering text

Also, ‘Enable Location Tracking’ is still freezing the app

1 Like

Hey Robby, great work. Question is it possible to make the Icons in the app the same color as hass icons, would looking better.

Yes that solution works :slight_smile:

So many thanks for this! I was using the web app which worked pretty nicely, but the addition of location services and push notifications are great!

1 Like

Next version, 1.0.4

Thanks! Keep up the great work.

The last time i visited about a month ago i did not see an app published in app store and all of sudden i got email with home assistant update and was surprised by the app thats in app store. I am glad and i am going to install it now. I do have one question.

When the app was not there back then i had to setup OwnTracks for location and it all worked fine, the reason i choose OwnTracks is because of privacy policy that it does not track or store or share my device locations. Now that i see with the latest update on app store app that it handles location, whats the privacy policy on this app, does it track and store our usage and location?


I just installed it, logged in, enabled notification, it works fine. Then clicked on “Enable location tracking” and the app freezes! and it freezes my phone lock screen. was able to get back after few clicks on power off and home button though.

UPDATE: I thought the version in the app store fixes the issue, but i still have to delete the app and install it back for location and notification to get enabled.

Thank you guys, I love this HA and this app.
Keep up the great work.

Location doesn’t go to our servers. The only thing that is required to go through our servers is notifications. The servers do log notifications right now while I am still working out some issues but I am the only one with access to those logs, and they don’t contain any personally identifiable information other than your push ID.

This is a known issue without a fix yet. Tried to track it down, so far nothing :frowning:

Locking this topic as 1.0.3 is now available!