VLAN-Setup, with devices with different IP addresses within same LAN

Hi All,

Very happy to join the HA community. Just gotten my HA Green and adopt it with no issues. Integration with IOT devices within the same network was a breeze. However when it comes to IOT devices outside the IP addy i have issues. The only exception is Ring Doorbell, somehow HA managed to discover and i managed to configure and adopt it. This Ring Doorbell is on the same IP addy with my other IOT devices like TP Link stuffs, however i could not manage to integrate them.

My Router has been configured with the main IP to access all Vlans and other IPs.

Can anyone point me in the right direction please thank you.

Something else is going on there clearly. You cannot have 2 subnets running on the same LAN. You have some VLAN shenanigans going there somewhere for some reason.
VLANS like that are

in HA because of weirdness with connections, and I would not not be able to help you with this.
You will likely need to sort out the VLAN problems yourself or move everything to a flat single subnet LAN.

Are you saying HA can only do a single network albeit all IOT devices and the HA must be on the same network? Then i must be looking at the wrong solution then. Main LAN and Vlans within the same network serves specific purposes. I can ping all Vlans from my main LAN so am confuse why the HA could not detect those devices.

How to configure HA to use two networks for integrations - Configuration - Home Assistant Community (home-assistant.io)

Can those who went through give some clarity?

I’m saying it’s possible to do, but is advanced due to the fact that no 2 VLAN networks are the same. This makes you the expert and you will have to do the brunt of the troubleshooting. We have a couple of folks that might be able to figure this out but generally VLANs are troubleshot by looking at the router, the IP’s, the firewall, and piecing it together. VERY hard to do in a chat forum. That is why unsupported by official HA. People that are successful at it know how to fix it when needed.

Your specific question, why does it see this and not that, the answer is likely firewall rules or bridging problems, but that doesn’t really help you, sorry.

1 Like

HA and your other IP Devices communicate via HTTP(s) , PING Don’t

Your RING DoorBell, is most likely a Cloud-depended Device ( Device>Cloud>HA - HA>Cloud>Device )

1 Like

Yes you are right the Ring is cloud based and needed me to log in hence was more straight forward.

Why can’t your IOT stuff use the same network?

2 Reason, My more important stuffs on one IP address and IOT stuffs on another. There are quite alot of items herein easier management.

I am not sure if its firewall rules or bridging issues as i have configured all of them sufficiently i guess, whilst i am connected on my phone/ipad on the main network i can also access other devices from other network controlled by their apps which have been setup using a different network. If i configure in my firewall to drop them ie. cannot talk to each other then the access is denied so yes i think i have my firewall part taken care.

Please avoid cross posts if possible. It makes it easier for folks to understand the whole conversation and the solution if the issue if it’s resolved…

“controlled by their apps” , if you mean the device/brand-apps on your phone, then yes indeed, they either work/talk “locally” or through the cloud, and depending upon whether your phone is connected to a wifi/ip-network or connected to phone-net(3G-5G)

So the reason you “Apps” work is again most likely due to the fact

Sound familiar as your DoorBell ?

" to drop them " what does that actually means ? , i’ve never seen a feature described like this in I.E a Router/FireWall

If it’s what i think it is(you mean) , then yeah Right !, obviously

btw, you still haven’t specified which Router you run,nor showed any “settings” but only described "

Main IP ? , other IP’s ?
How does the iot-VLAN Communicate With the other(Main-Lan / VLANs) and visaversa ?

If I understand correctly from your other post, your HA Green only has one interface and its on network (you call it “main”), but your router has 2 interfaces with one interface on (main) and the other interface on From this post it looks like the router has a third interface on

In this setup, the general problem is that “Discovery” uses link-local multicast which by definition is not routable, so the router is not forwarding multicasts originating from IOT devices on to (and vice-versa). Having said that, some routers have “Multicast-Forwarders” which actually will forward these multicasts. Routers that have this capability call it by different names, such as proxy forwarder, Avahi, etc. If your router has this kind of capability, then it will help a lot, but it is not necessarily a guarantee that it will work. Some have success with this, others don’t, so in general it is not a “best practice”.

1 Like

Not how. Why?

See how complicated this all gets. This is why VLANs are officially

Not that they can’t be made to work, it’s that you have to have intimate knowledge of your VLAN to make it work.
I suggest not glossing over

It is by far the most likely point of failure. Something cannot talk to something. Maybe ipv6, maybe some protocol is blocked, who knows.

Not to mention involvements of Routes/Proxy/DNS/Allow-List(HA), it’s a long “check-list”

I am using a mikrotik router, and to “drop” them in my firewall meant any access from one network to another is denied. So if i put it to work they cannot talk to each other, and by default all Vlans and Lan can talk to one another. Its not by cloud, even when i disable my phone ie. airplane mode and only on my wifi to my network it will connect and all other Vlans gets accessed.

Mikrotik bridging is simple. When you lump all the desired ports, aggregation ports, Lan, Vlan under a bridge, it meant they are one cluster one network, very simple and they will route to each other.

why? i just like to keep them separate

Interesting, i guess that you are used to reading Manuals, and are familiar with that Brands various HW-Routers and it’s capabilities , And howto configure their SW

Apparently their “Default Behavior” doesn’t seems to work, cording to your claims
Have you updated the Router-OS to latest stable-version ?
( As im sure you have Configured HA to “accept” your VLAN :wink: