VM install, unsure on a few things

:wave:Hello, I’m following the Set up Hass.io on top of a virtual machine guide, however I’m not clear on the initial preparation. :question:

I’m unsure if hass.io is its own OS?

I have setup my server Proxmox with a VM.
The VM can only be created by installing an OS.iso, in this case CentOS.
Perhaps I don’t need to create the VM with the CentOS.iso, if there’s a hassos_intel-nuc-3.8.iso file? The hassos_intel-nuc-3.8.img file won’t be allowed?
In the guide, As a virtual appliance, I don’t see any iso, just:

I’m multi platform, so happy to use Debian, Ubuntu, CentOS or Fedora 27 (as per Hass guide).
However, I then need to figure out how to install Debian 9 onto Fedora 27…new to these 2 systems. Huge amount of reading in the Debian 9 guide.

Currently researching other hass.io vm install guides, unless someone has a suggestion.

Install HassOS in a VM using Whiskers one line script from https://github.com/whiskerz007/proxmox_hassos_install

wget -qO - https://raw.githubusercontent.com/whiskerz007/proxmox_hassos_install/master/install.sh | bash -s local-lvm
1 Like

Thank you, however my Proxmox hypervisor has no Internet.
I download from another computer, then ssh the hass.iso file across.
Which hass.iso file do I need to download please?

I downloaded Intel-Nuc and VMDK, but these are wrong as the unzipped file is a .img file. The VM hypervisor needs a .iso file to install the HassOS.

look in the script, download the file locally and run script locally. Why don’t you have internet for the hypervisor? That is not going to end well.

Yes, I read the install.sh script, but it downloads the latest version of all images.
I haven’t found an iso file yet.

I’ve ordered a new modem, so just running this computer of my mobile hotspot, whilst I have some time off and time for a new project…Hass!

When I was playing around with this I did find another tutorial for Proxmox and then a Debian VM and a generic Linux install of Hassio instead of using HassOS - that is my preferred way although I also made another VM using the above script.

To be honest I’m not overly sold on Proxmox anyway… for a start chrome doesn’t play nicely with the shell command (I have to use Firefox to initialise the image)

1 Like

I will research the generic Linux install.
Proxmox is bare metal light resources and free.
I did have your issue too, but it’s fine on Proxmox 4.4-1/eb2d6f1e.

The Proxmox community could be friendlier…I receive the StackOverflow type responses to silly (I research, but am learning) questions.

Why are you using an old version (very old version) of Proxmox?

It might be the way you ask questions- there is a great pinned thread at the top of the forum about how to ask a question. You will then get more useful responses. This community is as friendly or friendlier than most in my experience.

1 Like

Just haven’t upgraded for a while.
Yes, the Hass community looks great from what I’ve read and seen.

Eiger, I’ve read this thread and David’s responses seem fine to me, he responds very promptly and gives you good, informative advice answering your questions. This whole thread (so far) has been conducted over a mere 6 hours. His point about the ‘sticky’ at the top is a common issue and I see that you have not read the forum guidelines.
So is your comment based on your experience on another thread ?
I ask because I’m interested in the “newbie experience” ? (I know you’re not but it’s parallel)

What do you mean by that? I am using proxmox 5 (not yet 6!) and I am only using chrome to interact with it…
And I agree, I prefer the “install on generic linux script” over HassOS. I like to keep control of the underlying OS!!

I just updated the post, to clearly note the Proxmox community.

Understood, thanks

When I try and open a console/shell through the proms:8006 web interface in chrome I get an error. I almost totally abandoned Proxmox at that point till I found I could open shell/console in Firefox. You have to be able to use the console so that the ISO you select gets installed. Once the image is installed I can use normal ssh etc to access a shell… just not through the shell in chrome.

I am using Proxmox 6 latest. (And chrome latest as well)

Sorry to highjack the original thread… but I don’t have a problem at all when I start “Console” form the web interface on my proxmox box from Chrome or firefox. Both works.

Remember to enter https://xxx.xxx.x.xxx:8006.
Just xxx.xxx.x.xxx:8006 fails.

I’ve been using Proxmox for 10 years. This has NEVER been a problem for me at all. Were you trying to use SPICE or just the normal NOVNC console?

Tried all consoles none work. I saw on the Proxmox forum an issue with Eset which I use and I applied the suggested remedy but it still doesn’t work. Also won’t work in chrome on my Mac either.

Yes I know that and it’s not the problem.

I’ll fire it up and show some screenshots later today.

this one right clicking proxmox and selecting shell

Do you have any extensions that could be blocking JavaScript or something?

There has to be some kind of error in your browser console or something

yeah. I definitely have javascript enabled. I have tried ip_address:8006 and also proxmox.fritz.box:8006 (both https). Chrome complains about the site being ‘unsafe’ and I have to go into advanced mode to even open it. I have downloaded self-signed certificates as well but no difference. My feeling was that it’s some kind of https http mismatch on frames (similar to a http iframe when you use https in HA which won’t work either). The proxmox forum points to an error caused by eset but I made that change and it doesn’t work.
Anyway it works in Firefox and I only need to use it to install the image in a new VM as after that I can just use normal ssh. I’m stumped. There seem to be a few people who have the same issue.