VM shows high CPU, but HA shows low

I have home assistant running in virtual box on a windows host.
I noticed today that the power draw on that pc is higher than usual, and then I noticed that when looking in task manager, the VM host is consistently using 35-30% CPU but when looking in HA, its showing 2%…

I’m assuming its an addon then ? How might I go about finding out what causing this ?

So, I turned off all my addons and still no difference. Constant 35-40% CPU when viewed from the host.

Top also shows nothing:-

So it seems that restarting the VM wasn’t enough, even rebooting the host did nothing. This seems to be because the restart or a host reboot saves the current memory state of the VM.

I’ve forced a machine shutdown on the VM and everything is back to normal.

1 Like

How did you force the shutdown more exactly? I’ve tried everything, even killing it from the task manager, and still have the same problem. The host uses a lot of CPU, while HA is idling.

In my case, I’m running home assistant in VirtualBox on a windows host, soyou have to use the shutdown command from virtualbox menu, that causes the actual HAOS to shutdown rather than just going to sleep.

Thank you for your response! Unfortunately I have a different problem then, because this does not help :frowning: