Volvo on Call HA integration stopped working

The Volvo on call integration worked fine in January, but stopped working in the beginning of february. Tried it on several HA installation with same result.

Logger: volvooncall.volvooncall
Source: /usr/local/lib/python3.8/site-packages/volvooncall/
First occurred: 12:35:41 (4 occurrences)
Last logged: 12:38:42

Failure when communcating with the server: 401, message='Unauthorized', url=URL('')```

Logger: homeassistant.setup
Source: components/volvooncall/
First occurred: 12:35:41 (1 occurrences)
Last logged: 12:35:41

Error during setup of component volvooncall
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/”, line 213, in _async_setup_component
result = await task
File “/usr/src/homeassistant/homeassistant/components/volvooncall/”, line 182, in async_setup
return await update(utcnow())
File “/usr/src/homeassistant/homeassistant/components/volvooncall/”, line 167, in update
if not await connection.update(journal=True):
File “/usr/local/lib/python3.8/site-packages/volvooncall/”, line 105, in update
user = await self.get(“customeraccounts”)
File “/usr/local/lib/python3.8/site-packages/volvooncall/”, line 91, in get
return await self._request(METH_GET, self._make_url(url, rel))
File “/usr/local/lib/python3.8/site-packages/volvooncall/”, line 76, in _request
File “/usr/local/lib/python3.8/site-packages/aiohttp/”, line 1000, in raise_for_status
raise ClientResponseError(
aiohttp.client_exceptions.ClientResponseError: 401, message=‘Unauthorized’, url=URL(‘’)

Anyone experiencing the same ?

I think rememeber having read recently that volvo changed their authentication method, but I may be wrong.

Maybe it has something to do with this ?

Maybe, do you have any way to test the API that HA uses and see if it works outside of HA?
If you can’t get it to work,I’d open an issue on GitHub.

Exactly the same issue here

Its working for me.

What location are you in? I’m based in the UK.

I´m in Sweden

When did you originally set it up? Mines been working since June of last year until the last month. I’m contemplating removal and reinstallation of the integration.

For about 2 years I think.

Do you use Volvo oncall app?

I have it working now. I hashed out the details in my config and restarted. I then reset my password in the OnCall app - even though it was working.

I re-enabled in HA and restarted. All fine.

I think the authorisation was out of date or some hiccup but this flushed through the issue. All sorted now, thanks.

Is your Volvo on call integration still working for you? I can’t get it to install…

Yes it is still working well. What bit is not installing?

Thanks for responding @DeepfatDad. It doesn’t seem like anything is installing. I am adding my volveoncall username, password, and region (I’ve tried with and without region) to my configuration.yaml file, and then restarted HA, and then nothing happens. The integration does not appear in my integration list and no new entities appear. Strangely, I don’t see an errors in my log either, it just seems to be ignoring the new config entry for volvooncall….

My entry in configuration.yaml is in this format (a few added XXX for security):

username: [email protected]
password: !secret volvo_password

Strange you are not even getting errors in the log. I imagine you’ve updated to the latest version etc.?

Might be also trying deliberately wrong credentials to see if that gives it a kick?

  username: [email protected]
  password: !secret volvo_password
     XXXregXXX: 'XXXPolestarXXX'

Now with correct formatiing!

Thanks again for the @DeepfatDad. I have indeed updated to latest version, and the vehicle is only a few weeks old (2021 XC40 recharge).

I don’t have the !secret in my setup, as that essential or is that just part of how you labeled your password placeholder?

I also don’t have the name: part. Is the XXXregXXX supposed to be my VIN? And the XXXPolestarXXX whatever I call it?

I’ve also tried changing my on-call password, as I saw that mentioned online as a solution, but it did not seem to help.


I have my passwords located in a separate file - hence the !secret reference.

The name part replaces the registration the car was registered with by Volvo with a friendly name. I have also put the car on private plates so the old reg is no longer valid but the thoughts of trying to explain that and get it changed without breaking anything has meant I just rename it!

Really daft question - I take it the Volvo app on your phone is working perfectly?



That’s not a dumb question at all. The app is working perfectly, but it might be worth mentioning that I did end up with the newly redesigned version of the app when I got the new car (which I’m not happy about and was not my choice). For example, I’ve attached a screenshot of the version of the app I have.