WallPanel for Android Redux

As far as I know, the way to exit full-screen is the same for any Android device. You can use the available navigation keys or you can pull down on the top of the screen to get the software keys. You hit the back button to return to the settings. So you just need to activate the onscreen navigation.

happy to see you took over, much appreciated… switched to your version and love it :slight_smile:

but is there some kind of logging from the app? i have a strange connection issue… after some hours it just doesn’t refresh the dashboard anymore. switches etc. are still working but i don’t get any feeback pushed back to wallpanel, motion wakelock also stops working. Otherwise my setup works pretty well so I wouldn’t suspect ha to cause the issue. appdaemon also doesn’t show anything usefull in the logs.

It could be a lot of things, but it sounds like your device is sleeping and killing the application or the connection. Do you have DayDream setup so that your device doesn’t turn off? Do you have your power cord connected? Do you have an option in your settings for WiFi sleep?

Sure it’s hard to debug. Weird that it happens after several hours… it’s a N7 (2013) connected to a ps. With a minimalistic custom 7.1.2 rom. Wifi doesn’t sleep, it’s set to always. I might try an automation to wake the thing up every now and then via mqtt or something.

Well the application works the same after one our or seven hours, so it has to be the device. I had one person report the same issue but the device was low on battery, so it started to shut down applications to save battery. So check the battery level after it runs for some time. I have an N7 (2012) running Android 5.0.1 that stays on constantly. Is the application crashing or something after 7 hours? Do you just have to wake your device by touching the screen or do you have to hit the power button? Are you using Daydream?

No Daydream, Display is configured to shut off after 2min. Battery is full and gets constantly charged. Application doesn’t crash, I have to wake the screen with the power butten and have to do revert to the menu and reload the dash to get a current view. It just dosn’t refresh the view anymore. only the clock widget is running… looks like it looses the connection to ha. I might try a different rom maybe, not much to set up there, so no loss.

Well without some type of feature to keep the screen on, then eventually your device will shut down background running tasks, which appears to be what is happening. The clock feature? Isn’t that a Daydream feature? You can call to wake the screen via MQTT from HA periodically, but I believe the solution would be to run Daydream without any lock screen. If you have to wake the screen with a power button, your device is going into deep sleep and will kill WiFi and background processes. So that’s the problem, use Daydream if you can to prevent the device from sleeping.

I meant the clock on my dashboard is the only element that refreshes properly. But isn’t daydream defeating the purpose of a screen of and motion wake? Maybe just waking the device with tasker now and then will be sufficient.

No, because you can only force the device to keep the screen on all the time, but without daydream active your screen will “burn” the image. There is an option to keep the screen on forever, much like you would if you were watching a Netflix movie. You would use the motion or face detection feature to automatically wake the screen from day dream mode. But you have to have one or the other, either screen always on, or use daydream which prevents the device from sleeping. You can wake the device periodically if you wish, but it seems like your making it harder than it has to be.

To explain better, you can’t wake an android device from sleep unless you set some type of periodic alarm, but you can keep the device from sleeping, which then works with motion detection to wake the “screen”. If your device sleeps, you no longer will be able to use the camera to wake the device. So your suggestion to periodically wake the device may work, unless the device goes to sleep, then the background tasks will stop and you can no longer wake it. My suggestion is to just keep the device from sleeping using the daydream feature in conjunction with motion detection which wakes the screen.

1 Like

Thanks mister thanksmister for explaining. I’ll will give it a shot in that direction. :slight_smile:

Great, best of luck sir.

I’ve noticed the same issue as mason on my fire7 tablet. I just haven’t looked in to it much. What is the daydream option? Is it a wallpanel option?

Fire tablets are running custom roms, so I am not sure you have this feature. Do you have any built-in screen saver feature on the device?

I’ll have to look when I get home.

I do have the option on to prevent screen sleep in wallpanel. I also have the camera turned on and screen dim after 30 seconds. I also have motion detection set to wake the screen. When the screen dims I can barely see the screen but camera motion does brighten the screen. But after the device was sitting idle for a long time the panel’s devices aren’t always insync with HA.

I’ll have to look for screen saver options and possibly wifi sleep settings. Other than that your app does seem to keep the tablet from needing to use the power button to wake it.

This is an amazing project, on top of that this is just about plug-and-play, very easy to configure.

I do have a question involving the payload template, i’ve been trying to feed the tts command a parameter, but so far i am unable to. The example underneath is doing exactly what i want if i put it in the template tab, but in my script it does nothing. Any idea as to what i’m doing wrong? Thank you

  • service: mqtt.publish
    topic: “wallpanel/mywallpanel/command”
    payload_template: >-
    “{‘speak’: '” ~ message_param ~ “’ }”

You can check the logs in the application to see what was received. I suspect its something to do with quotes or formatting for the published MQTT message. Otherwise try to sniff the outgoing MQTT from Home Assistant to see what the message looks like. Its not an application issue, its more likely an issue with the way you format the template.

There is no error in the log, it seems the script is called just fine.

If i replace “~ test~” with any string it works fine, but using a parameter i don’t get a TTS message

Have you tried just testing using what’s outlined in the documentation?

{"topic":"wallpanel/mywallpanel/command", "payload":"{'speak':'Hello!'}"}

That works for me on a fresh install with MQTT setup.

yeah, that works fine, I just can’t get it to accept a parameter