WallPanel for Android Redux

I recently volunteered to take over and revamp the WallPanel project (formerly HomeDash) from @quadportnick. WallPanel is an Android application for Web Based Dashboards and Home Automation Platforms.

I have completed the first pre-release of the WallPanel Android application. You can find it here at the WallPanel Project Page and also on Google Play.

I have added TTS support and did some improvements to the face and motion detection. It may have bugs since I am the only one testing it, but its a start. You may recall I am also the developer of the MQTT Alarm Control Panel, an Android (and RPi 3) project for Home Assistant’s MQTT Manual Alarm Control or other MQTT platforms. I am hoping to combine some of the features of both projects in future updates.

Features

  • Web Based Dashboards and Home Automation Platforms support.
  • Camera support for streaming video, motion detection, face detection, and QR Code reading.
  • Google Text-to-Speech support to speak notification messages using MQTT or HTTP.
  • MQTT or HTTP commands to remotely control device and application (url, brightness, wake, etc.).
  • Sensor data reporting for the device (temperature, light, pressure, battery).
  • Wake device on motion or face detection.
  • Continuously runs in the background (using ongoing notification).

Community Page: https://community.thanksmister.com/c/wall-panel-app/

28 Likes

I just released an update due to a crash with notifications on Android O devices. I will monitor the issue to see if it persists. The new version is v0.8.1-beta.1 (v.0.8.1.1) and will be rolling out on Google Play and available for side-loading from the project page.

1 Like

Happy to test this @thanksmister and will report back with my findings.

Doesn’t seem to be sending any sensor data via MQTT for me (battery, motion etc). Same settings at original Wallapanel. Has anything changed in the MQTT setting for home assistant?

I will take a look, thanks!

1 Like

Running 0.73.1 home assistant, nothing changed there as far as I’m aware.

I see that MQTT connection is failing, so its nothing different with HASS, its something with the MQTT connection established within the application. For now I will continue to investigate the cause of the problem and issue a patch as soon as I have one. Thanks!

1 Like

Glad I could help, and thanks for taking on the project.

I’m glad that the project is alive and someone has taken it over! It would appear that app force closes on start on Android 4.4.x.

Sorry, I had the wrong IP address of the MQTT broker. I am publishing pressure for example to
“wallpanel/mywallpanel/pressure” with a payload of “1690299”, so I seem to be missing “/sensor/” as part of the call which would account for the missing MQTT message in HASS. I will add that as part of the MQTT call as its outlined in the documentation.

1 Like

Motion for example is being published correctly, are you sure that the motion isn’t being received by your mqtt broker? I initially thought that the payload was wrong, but realized that MQTT sends the payload as bytes instead of text. So it appears that motion/face/qrcode should still be correct because they include the “sensor” portion of the topic even though sensors seems to be broken for the moment.

wallpanel/mywallpanel/sensor/motion

1 Like

I am picking up sensor data with the addition of “sensor/” to the topic, but I am not picking up motion using the binary_sensor for HASS. Still investigating why this one is not coming through. Here is what I have in my configuration.yaml file:

binary_sensor:
  - platform: mqtt
    state_topic: "wallpanel/mywallpanel/sensor/motion"
    name: "Motion"
    payload_on: '{"value":true}'
    payload_off: '{"value":false}'
    device_class: motion
1 Like

ok, it seems to have taken a restart or two to get the motion sensor to appear, but it works:

binary_sensor.wallpanel_motion_detected	off	friendly_name: WallPanel Motion Detected
device_class: motion

I will publish a fix (maybe tomorrow) for the sensor topic publishing issue but I have all the sensors coming into the MQTT HASS broker now.

1 Like

I just released an update with fix for publishing sensor data. The new version is v0.8.1-beta.2 (v.0.8.1.2) and will be rolling out on Google Play and available for side-loading from the project page.

1 Like

Great to see this continuing.

Can’t seem to get it to load on Android 6.0, the settings page comes up, but when I click dashboard on the top, it just goes to a white screen.

Also when you click Sensor settings, the title of the loaded page says Face Detection settings at the top.

That seems to have fixed the issues I was having with the MQTT sensors, all working again now.

Also implemented the camera into HA but getting the following error (it’s not WallPanel related) and it’s then making HA unresponsive for a good 10 seconds.

Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/aiohttp/web_protocol.py", line 398, in start
    await resp.prepare(request)
  File "/usr/local/lib/python3.6/site-packages/aiohttp/web_response.py", line 300, in prepare
    return await self._start(request)
  File "/usr/local/lib/python3.6/site-packages/aiohttp/web_response.py", line 605, in _start
    return await super()._start(request)
  File "/usr/local/lib/python3.6/site-packages/aiohttp/web_response.py", line 367, in _start
    await writer.write_headers(status_line, headers)
  File "/usr/local/lib/python3.6/site-packages/aiohttp/http_writer.py", line 100, in write_headers
    self._write(buf)
  File "/usr/local/lib/python3.6/site-packages/aiohttp/http_writer.py", line 57, in _write
    raise ConnectionResetError('Cannot write to closing transport')
ConnectionResetError: Cannot write to closing transport

That’s just a typo on the sensor settings page title. Try changing the default browser on the main settings page under “Specify Browser Engine”. If you have changed the default browser URL be sure its valid. I’ve tested it on Android 6.0.1 (Samsun S5) and I didn’t have to make any changes to get the website to appear. Try going to https://google.com to test it.

I can get the the stream in a web browser directly, have you tried in the browser, just enter the URL something like this:

http://192.168.86.26:2971/camera/stream

I am also able to see the stream in HASS with the following in my configuration.yaml file but I had to reboot HASS after updating the config and then I could see the stream. The stream only works if you are in the Dashboard mode.

camera:
  - platform: mjpeg
    mjpeg_url: http://192.168.1.1:2971/camera/stream
    name: WallPanel Camera

That is a strange error from HASS, not sure how to assist on this issue. I am running the latest HASS update (0.73.1) and not having streaming camera issues. I know its streaming over http and it looks like its having some issues reading the stream, that’s about it.