WallPanel for Android Redux

Well then, my guess is that its your formatting on the payload_template you are using. Here is an example I am using with the sun from another project.

{ "payload_template": "{'sun':'{{states('sun.sun') }}'}", "topic": "voicepanel/command"}

But TTS is working on your device and it works when you send out a regular payload, so its something with your payload_template that is not correct. The application can’t process the MQTT message unless it receives the proper format.

Where are you getting this from? How is this getting set into the payload_template?

The parameter comes from my speech engine project, I’ve been using it for quite a while already.

My plan is to run this in combination with wallpanel for a talking magic mirror project.

you’re right that it’s probably a templating problem, though in the Hassio Templating view it gives the correct output

I would install MQTT on some machine and watch the MQTT traffic of your HASS install to see what is being published exactly, maybe that will give you some direction.

I’be found the problem, it’s the use of apostrophes in the string I’m feeding into it.

{"topic":"wallpanel/mywallpanel/command", "payload_template":"{'speak': 'its {{ states('sun.sun') }}' }"}

The example above works great, it gives a tts output, it fails though when I add the apostrophe to “it’s”.

I did some searching on JSON string formatting and i found that normally the function JSON.stringify() can be used, but this function is not recognised. Do you know a workaround of this problem?

Can you just escape them by using a \ in front of the quotes. The other option is to say “it is”.

Single quotes can’t be escaped, the alternative is to not use them, but surely there has to be a way to just work with them? Especially the English grammar is full of single quotes

Maybe a question for the Home Assistant developers on how to format the payload with single quotes. I had a heck of a time using JSON as a the payloads due to quotes as well.

You are confusing quotes with apostrophes. It’s contains an apostrophe.

Just leave the apostrophes out of the text. I doubt that TTS pays much attention to them anyway.

Yeah, not intentionally, a single quote is the same as an apostrophes. But yeah, my suggestion was to use “It is” rather than “it’s” but just using its is probably the same to TTS.

What is the command for changing the screen brightness? I can see the sensor setup, en mention of the ability to adjust brightness, but its not mentioned in the command list.

I updated the documentation, it was missing. It would be "{“brightness”: 1}. The value should be between 1-255. https://github.com/thanksmister/wallpanel-android/blob/master/README.md#commands

1 Like

Would anyone be interested in a custom component like Fully Kiosk has?

I just stumbled upon this. I have tried it and I like it. However, I wish it has option to lock down the device in kiosk mode so that other users cannot exit the app and change the settings like how Fully Kiosk Browser is. Anyway, thanks for this app.

is there a way to configure mqtt to connect over tls using the ca-cert (mosq-ca.crt in my case)? for example, mqtt.fx has a tab when configuring connection for this…

I think to allow MQTT to use a certificate a new feature would have to be added to upload the certificate to use for the application. I use the Paho MQTT library and it has the feature, but I think it needs to have the certificate to allow this.

Here is the Paho library documentation: https://www.eclipse.org/paho/clients/android/

You can add a feature request to the Github project page https://github.com/thanksmister/android-mqtt-alarm-panel/issues. Here is the

I was using this Wallpanel since v.5x I think, and I like the thing.
Updated it to few months ago and noticed it loses connection, every now and again when it wakes up I see Connection lost, reconnecting…
It is especially annoying as I use it to disarm my alarm and on few occasions it took too long for the panel to reconnect and it triggered the alarm :expressionless:
Downgraded it to, the apparent issue is it shows Network unavailable if I turn on Start on boot option and restart the device.
However, if I then click Back and Dashboard (or relaunch the app), everything works fine.

It would be great to sort out that frequent disconnection issue as I don’t really like using older versions.

The issue isn’t that is disconnecting too often, its that its showing the alert for the disconnected network. At some point your network is getting disconnected. Probably your device is turning off the WiFi when it goes into sleep mode or there is an extra setting on your device to keep the WiFi connection active.

Well, I set my tablet to keep WiFi on during sleep and disabled any battery optimisation from the start as it is plugged in 24/7/365.