Wallpanel wont show my custom cards

I updated from 0.86 to 0.92 yesterday and now my wallpanel on my lenovo tablet wont show any custom cards.
I get the red banner where it says “custom element doesnt exist”

Opera on my PC and chrome on my phone are working fine.
This is my lovelace:

### https://github.com/custom-cards/tracker-card
  - url: /local/custom-lovelace/tracker-card/tracker-card.js?track=true
    type: module

### https://github.com/maykar/compact-custom-header/
  - url: /local/custom-lovelace/compact-custom-header/compact-custom-header.js?v=0.0.1
    type: module

### https://github.com/custom-cards/surveillance-card
  - url: /local/custom-lovelace/surveillance-card-master/surveillance-card.js?v=0
    type: module
1 Like

I am bumping this up hoping someone can help me with this:

I am trying to figure out if this is wallpanel or HA related.

My tablet is not showing any custom cards, but when I installed wallpanel on my phone, it worked fine.

I tried deleting data and cache and reinstalled the app, but still the same on the tablet.
Any ideas?

Is your tablet up to date? Custom cards often don’t work if you are using an old version of webview - I had a similar problem with my Fire 7 tablets, and my lenovo tab out of the box. Updated the system and chrome on the tablet and it is now all working fine.

Hmm… Webview huh? OK… My tablet is a lenovo tbx103f and I have a custom rom on it (the original rom was way too slow/heavy for anything). I have lineage os and the last update was more than a year ago. Google play shows no updates (so, I guess webview is updated?).

What version of android is the custom ROM based on? More info toward the bottom of this post:

You might want to try either a newer ROM, or the legacy version of wallpanel.

It is based on 7.1.2

I am searching through the whole internet, but I cant find a solution. Thank you for your suggestions anyway…!

It looks like I found the problem. It was the webview settings from the developers options. I just switched it to “google webview” and it did the trick.

I had a similar problem on my fire tablet where it would only show half of my custom cards but then show the red screen for the other ones. Some investigation found that anything with “type: module” showed up as a red error card. Anything with “type: js” worked fine. Changing the “module” to “js” actually got them working.

I think I remember trying that and it didnt work. Might help others though.

I figured out what is wrong.
I had to go to the developer options on my device and then at WEBVIEW implementation. I just chose Android System Webview, and now it is OK.

I figured out how to update webview on my Fire 10 (7th Gen/2017) today to get my custom cards working:

  1. Root device (see XDA forums for how)
  2. Install Google Play Services and Play Store
  3. Uninstall the Amazon Webview:
    pm uninstall --user 0 com.amazon.webview
    pm uninstall --user 0 com.amazon.webview.metrics.service
    pm uninstall --user 0 com.amazon.webview.chromium
  1. Install ‘Android System WebView’ from the PlayStore.
  2. Restart and voila!

I managed to uninstall the amazon webview after rooting, but Installing the Android WebView did not work. It was installed, but the home screen kept blinking and wall panel app said “there is no webview installed”. Do you have any tips?


I also have an ancient Lenovo with custom rom and I was having the same issue.

Going to the Developer tools (or programmer or something from Android) I changed the WEBVIEW to CHROME (stable) and now I can get all the cards.

Hope this helps