WARNING! Do not update websocket to 0.61.1 with Add-on version: 16.0.2

After updating node-red-contrib-home-assistant-websocket in manage pallette:


Flows stopped due to missing node types.


[warn] [node-red-contrib-home-assistant-websocket] Node module cannot be loaded on this version. Requires: >=3.1.1

Add-on version: 16.0.2

Reverting backup solved it.

Be carefull!


OK so this may not actually help anyone but I have just pulled this together from the relevant GitHub release notes (11 December 2023).

Apologies to all concerned if it is incorrect.

What it shows, if I am right, is that a lot of people have been doing a lot of work over the past year. However, there are breaking changes (yellow highlights) and inter-dependencies (red lines).

The Node-RED companion integration (NRC) depends on a given HA version, and also on a given HA Websocket Node version. Hence v3.0+ needs HA 2023.7+ and HAWN 0.57.0+

The Websocket Nodes (HAWN) depend on a given HA version, and on a given Node-RED version. Hence HAWN 0.57.0 needs NR v3+ and HA2023.3+.

The Node-RED addon (NRA) comes with a base version of Node-RED, and a base version of the HA Websocket Nodes. Hence from v14.5.0 onwards this is based on Node-RED V3.1. and NRA v14.5.0 matches with HAWN 0.56.1 (and therefore will not support Companion v3.0.0+ without upgrade)

I am not aware of a back-dependency status between HA Websocket Nodes on the Companion, but I assume that HAWN v0.57.0+ work only/best with NRC v3+


Got the same problem here, had to upload my backup.

0.62.0 came out this morning, still doesn’t fix the issue… When node-red is restarted, the home-assistant add-on is no longer installed in node-red… I need to re-install it, and then works until I restart Nodered again.


FYI, for those having issues, here;s what I did to revert back (Home-Assistant supervised):
1- stop Node-red addon
2- on your home-assistant OS:

cd /usr/share/hassio/addon_configs/a0d7b954_nodered
sudo vi package.json

3- in the package.json file, locate the node-red-contrib-home-assistant-websocket
4- change the version to “~0.59.0”
5- save and exit
6- start Node-red addon.

That worked for me.


0.62,1 is out anyone dared to try it?

Just gave a try updating the node-red component to 0.62.1. Same Issue.
The component states it require Nodered 3.1.1, but the supervised add-on is only at 3.1.0… → GitHub - zachowj/node-red-contrib-home-assistant-websocket: Node-RED integration with Home Assistant
In prequisites:

* [Node.js](https://nodejs.org/) v14.0.0+
* [Node-RED](https://nodered.org/) v3.1.1+
* [Home Assistant](https://home-assistant.io/) v2023.12+

But in Supervised Node-red:

Welcome to Node-RED
14 Dec 16:38:03 - [info] Node-RED version: v3.1.0
14 Dec 16:38:03 - [info] Node.js  version: v18.18.2
14 Dec 16:38:03 - [info] Linux 5.15.0-91-generic x64 LE

I’m wondering at this point if it’s even tested against the Supervised Node-Red Addon version.

1 Like

Checking the github addon-node-red account, I can see that Node-RED v3.1.3 has been merged just this past week, as has WebSocket nodes v0.62.1


In the following issue report frenck explains that the problem is addressed and the next release of the addon is stuck awaiting a QMEU bug. The solution is to NOT manually update.


The Node-RED addon will be updated in due course. Manually updating just the WebSocket nodes beyond the version currently shipped within Node-RED addon is, in this case, not a good idea.


Good to know, thanks!

Did the same with nano 0.59.0 and restart of nodered was succesfull…so thanks

1 Like

Now is 0.62,2 out.

Sorry if my English is not quite right, it 's not my native language

Is there a fix that can be installed now or is there a workaround?
If there is a fix, is it only beta?

Hi, this worked for me, many thanks!!

1 Like

As @Biscuit mentionned earlier, the merge is stuck at the moment, so until we get a new version of the Node-red addon, we have to keep 0.59 in place.

Thanks for sharing this, it worked for me to get my HA stable again… and just in time. We’ve had some nasty weather today where the power has flickered nearly a dozen times.

1 Like

@gleepwurp I don’t understand your steps 2 and 3. Could you elaborate?

Sure! What type of Home-Assistant installation are you using? It might differ if you’re not using the supervised installation.


Supervised on a virtual machine

Cool! Ok, for step 2, you need to log in to your Home-Assistant’s underlying OS.
When logged in, you cna navigate to where the nodered addon configs reside (usually) → cd /usr/share/hassio/addon_configs/a0d7b954_nodered

once in that directory, you can edit the package.json file. I used vi, but you can use nano of any other text editor you have availalable.

Step #3, while editing package.json in your text editor, locate the line that mentions node-red-contrib-home-assistant-websocket module, and the version currently installed. Change that version number to ~0.59.0, save and exit.

now restart your nodered addon and you should be good.

Hope this helps clarify!



Sorry, I have hassio on RP4, but I can’t go to the folder you indicated.
I connect with putty, but under /usr/share I can’t find the hassio folder.