Waterkotte Heatpump Integration

Hello!
I build an integration for the Waterkotte Heatpump.
You can get currently around ~65 Metrics from it change the different heating modes and setup Holiday mode.
I might add the ability to set different temperature settings in the future if required.

You can get it from here and install via Hacs: https://github.com/pattisonmichael/waterkotte-integration

2 Likes

Wow, you’re amazing! Thank you a lot for this great contribution. I will try it out this evening and will let you know of the results.

Hi Michael,
as promised i’ve tried to install your integration through HACS. Installation was without any problems, but adding it through integration and + afterwards, the integration assistant always seem to be stuck for me with the following screen:
“Please wait, the configurationassistant for Waterkotte Heatpump will be started” with a loading circle

I’ve restarted Homeassistant several times but to no avail.
Do you got any idea, what might be wrong here?
Edit: My fault, i’ve restarted HA again and this time it worked. Thanks a lot!
How is your experience with the connection to the waterkotte itself? Very often i get unavailable status but after some time some values again. I get the feeling that the Waterkotte WebUI is not very stable and responsive and might be the culprit here.
Thanks in advance

Glad you got it work. Unfortunately quite often, usually after the heat pump changes function (start, stop,etc), it will not respond with data. I tried to hide it as much as possible by caching the data. Although the status (heating, water, cooling) should be always accurate.

That makes sense. Thank you for the explanation. Btw. i’ve seen that some of the entities show “bar” as a unit, like holiday times, the COP-Values for heating and cooling, as well as the state service. Can i somehow change the unit, it uses here?

Ya looks like if missed some :slight_smile: I just pushed v0.0.6 that should fix them. Let me know if you find some more!

Unfortunately, after installing the integration and restarting HA, I can’t log in. Error: Username/Password is wrong. I have Watercotte EasyCon Home 2.4.1
waterkotte_error

Can you log in with those credentials on the web interface? If yes it should work. Maybe wait a bit, it’s possible the login failed because the session was already occupied.

yes i can login with user:waterkotte pass:waterkotte . Perhaps there are different versions of the heat pump driver, and my version of the driver does not work. That’s why I gave the EasyCon version

Where did you find that Version? I’m not familiar with that string.
I think it should work for all heat pumps that have the build in web interface.
Can you try username / password “wtkadmin”?

Thanks a lot for the great support. It’s working perfectly now.
Did you find an energy usage counter (kwH) or anything on the web ui by any chance, which one could use/parse for the energy meter components/statistics in Home Assistant? I’m not sure if the web ui provides any values, one could use (or maybe calculate based on the COP-values).

I don’t think I have noticed any kwH, usually its just a percentage of 100%.
You can install the Waterkotte Mobile app and have a look in there, it exposes a few more metrics.
If you find anything there that is missing here right now let me know and I can add it.

unfortunately wtkadmin user/pass login doesn’t work

Interesting, this looks completely different than what I have seen so far.
I assume you opened this in a web browser, right?
Could you follow the instructions in the link below to generate a HAR file and send it to me?
I would like to see if the login changed.

Create a HAR file

Michael, can I send the HAR file directly to you (e.g. via email)? I would not like to post the HAR file on the forum.

I think you can just DM it to me. Drag & Drop the file into the message.
Although there should nothing secret be in that file, but I understand :slight_smile:

Thank you, that was helpful! Unfortunately it’s a completely different API than what I use… I have no plan to implement this as I can’t even test it myself. Sorry for that. :slightly_frowning_face:

1 Like

Having actually slept over it, let me try something.
Unfortunately there was no content in the HAR file.
Could you get me the content of the following files?

http://192.168.0.193/http/easycon/cfg.wtk
http://192.168.0.193/http/easycon/js/dictionary.js

and one of the many requests to

/config/xml.cgi

If the data structure is similar, maybe it’s not to difficult to add.

Of course, I will get all the files available in the driver for you. I will send in the evening