Wear OS - "Could not connect"

I’ve installed the app on my Wear OS watch (Ticwatch Pro 3 GPS).

The instance is detected. However, when trying to connect, I get the message “Could not connect”.

I looked around and some people suggested trying via Wifi but that didn’t work either. I believe it’s some sort of bug.

a few users have issues logging into the app…can you try logging in with the phone to see if that works?

Make sure you are running the latest beta version of the app too.

I have the same issue. Can’t connect. Beta, no beta. I am running a public certificate, android 11 on moto z4 has no issues. Ticwatch Pro 3 can’t connect. Been trying to get this to work for months, every release I hope something has changed.

I am using 2 factor, it prompts for all my inputs then just goes back to the Login Wear OS Device screen on the phone. Watch app shows the instance but says Could not Connect.

The whole “make sure you are running the latest beta” thing seems like too much complexity, it doesn’t download right away when you switch. If we had any real control over which version we were running at any time via Google Play it would make sense but we can’t. You shouldn’t advertise this in the release if it requires the beta to work.

EDIT: sorry I am on android 10 not 11

Try turning off Bluetooth on the watch and connect, does it work?

Bluetooth is on the phone sees the watch… Do you think it is related to 2 factor, there seems to be a pattern in the reports of people not working that they are using 2 factor.

Just tried to uninstall the app on watch. Phone app detected it was missing but if I click the Install App on Wear Device I get an error “Play Store Request Failed Wear Device May Not Support Play Store” The android watch version is android 9, maybe that’s a clue?

I meant to turn off Bluetooth so you can connect using WiFi

Can you check Companion App logs to see what the failure there was?

Thanks bluetooth off does work if I input my internal address on the watch itself. External is going through HAProxy w/ SSL offload so there appears to be an issue on my end there.

If I re-enable bluetooth the phone app can manage the watch but the watch can’t communicate with HA again, can’t load entities, etc.

so this is a known issue only impacting some users but not all, if you refer to this thread you can see several different workarounds and fixes users have discovered

I have read through that several times. Nothing has worked for me with bluetooth on yet.

At least I have a working case now so I can take some network captures and compare working to not working. I will update that thread if I find any more work arounds.

Thank you for your help.

Turns out that this was a result of not sending the full certificate chain on my HAProxy setup. Let’s Encrypt recent changed their intermediate certificate and I guess the Ticwatch Pro doesn’t have that new cert in its cert store as valid. By sending the full cert chain the watch was able to accept the certificate.

can you please mention this in the issue, maybe it will help the next person :slight_smile:

Hi Guys, I have my TicWatch E3 connected to HA using WearOs, working fine, but I wanted to make some notify on the watch and I got this error message:

image

But the app on watch does not have so much configs, is there a way?

notifications do not work on Wear OS at the moment

1 Like

ok got it, should be a nice implementation btw, to see some notifications with sensor data on mobile would be awesome!

thanks for the fast reply!

Can you please tell me how did you resolve this? Thanks a lot!

I use pfsense to serve my HAProxy and the pfsense ACME plugin to pull the cert. The acme plugin was already building the full chain cert I just needed to edit the acme code to put that in pfsense’s certificate store.

The full chain cert is putting the endpoint, internmediate and root certs all in one text file.

I had this problem with Galaxy Watch4 and it was caused by the firewall app on my phone (AfWall) blocking Galaxy Wearable app’s access to LAN.

I’m having a similar issue with a Ticwatch pro S

Model : WF12096
Android 9 / June 1rst 2020 security update
Wear os version : 2.37

Companion app is working fine on phone, when I try to connect to HA instance from the watch I get the sad emoji saying something went wrong, I tried with both Bluetooth on and off.

Any ideas?

TicWatch Pro 3 Ultra GPS user here.

WearOS companion app doesn’t load saying “Error loading entities”.

Bummer :confused: