WearOS Activity State Sensor not working


after upgrading my galaxy watch 4 to wearos 4, the activity state sensor no longer works. Normally it shows the status Excercise when I do a workout. I use this to then start automation.

Unfortunately, reinstalling the companion app did not help. Does anyone else have this problem?

Many greetings


what app are you using? it might be that the app being used is not triggering the sensor to update. The app that starts the exercise activity needs to use Health Services and unfortunately not all of them do.

I use the “standard” Samsung Health App for my workouts and this worked very well before the upgrade to wearos4.

thats strange, not much we can do though if the app does not update the health services API. You can try checking logcat but its not as easy on a watch as you need to connect to a debugger to look at the logs. Even then not a guarantee we can correct it.

I’m having a similar problem, although I think it’s more generalized. Since updating my Galaxy Watch 4 Classic to WearOS 4, my home assistant server doesn’t seem to be getting any sensor updates from my watch unless I open the app. I tried disabling any battery optimization options that could have changed but it doesn’t seem to have helped so far.

the only place to set that on a samsung watch is using the samsung companion app on the phone

Yeah, I disabled it from the companion app, plus I also disabled an option marked “Pause app activity if unused” on the watch itself just in case, no dice. It had been working flawlessly for about a year before this.

I also have an issue after the update. I have my temp sensors showing in one watch face and they dont always update. Before, when I woke up the watch(tilting my wrist) the sensor values was updated in like a second. Now sometimes I need to logout and login again to get the new sensor values.

is everyone here on Wear OS 4? If so we had a few users report random and odd issues that only got resolved after factory resetting the watch (yes that extreme). None of the users had tried to clear data in the HA Wear OS app to see if that also helped correct the issue.

I’m on
galaxy watch 4
Wear OS 4
One UI-version 5.0 Watch

I reinstalled my HA app yesterday. Looks like it behaves better now but I will see during the day.
I also have a weird bug after upgrading to WOS 4 (not related to HA).
When I get a notification and I turn my wrist to wake up the screen, the screen is black. I guess a factory reset solves that. But for now I have enabled the setting for waking up the screen automatically when I get a notification. Then my screen is not black…

Hi all
The my current status is:
galaxy watch 4
Wear OS 4
One UI-version 5.0 Watch

I can also confirm that after the update of the galaxy watch 4 to the latest version and after a factory reset the activity state is no longer registering any exercise.
It still tracks sleep time well but any other activity/exercise is not longer being tracked.

Just tested on my Pixel Watch taht received Wear OS 4 yesterday and starting a fitbit exercise updates teh state as expected, sleep state also still work. We had another user confirm that not all apps support health services exercises which the sensor uses. Can you try another app like runtastic or something similar to see if that will trigger it?

Hi, I’m using the latest versions for my phone and watch, but the steps and calorie sensors on the watch are not resetting at midnight, so my steps and calories count is accumulating every day. This all worked before the latest watch updates.
I have a Samsung Watch 4.

Sadly only Pixel watches and Fitbit watches can use fitbit app. I also made a test using Google Fit and Adidas Runtastic on the Galaxy Watch 4 but still no exercise registered in the Activity State sensor.

the app does not control that reset, Health Services does. Try rebooting your watch to see if it gets corrected?

we had a user on ticwatch experience the same issue and after trying one of hte recommended apps in teh play store exercises were starting. The app depends on Health Services to give us updates and its up to apps that do exercises to notify health services that it had started.

Restart didn’t work unfortunately.

ok thats strange, do you have access to logcat? If you are not familiar with it then might be difficult but looking at our logs may at least show that its accumulating and not resetting at midnight. Also if not already try checking for Health Services update in the play store for the watch too as that is the API we are using.

I just updated health services on the watch and restarted, no luck, unless I need to wait until next midnight. I don’t have access to logs at the moment.

Correct it only resets at midnight so the first update after midnight should show the reset. Our logs will also indicate what data we have received

Just an update…
After I reinstalled the wear OS HA app, I’m getting the updates for my complications on the watch face as before I updated to wear OS 4. So that seems to have solved my issue.