Web Browser wont connect to Home assistant with android devices

I have been using home assistant for a few years to display my tasmota wifi based sensors and wifi wemos sensors for Mitsubishi air cons. Have not been able to resolve the following so looking for some help.
The current situation.

I can use any of the browsers to connect to my homeassistant lovelace display using my desktop (win 11 ethernet connection) and an old ios iphone by wifi, no problems.

My android devices (lenovo tablet and g14 phone) via wifi wont connect using browsers, just sit there loading and eventually give up with a time out cant connect error. It seems the ip address is rejected by the server (pings ok)
(odd thing as they have connected previously).
I dont have any external web access enabled.
I connect using ip (the .local method has not worked for me)
I use home assistant on docker on a ubuntu server cat6 cabled to a switch and internet modem.

Any assistance greatly appreciated as I have read a lot but not been able to solve the problem :melting_face:

You mean that no browser (Chrome, Firefox, Edge, Brave) works from Android?

What makes you think that? Anything in the HA logs?

What happens if you telnet into the HA port from an Android device?

Did you reset/replace/reconfigure your router lately and maybe activated some segregation on your WiFI network?

thanks for the reply. didnt think to try telnet. Same result “failed to connect 192. xxx connection timed out”
Yes I meant cant connect using any internet browser. Browsers are fine for everything else.

Hi Wally, nothing changed of late that I am aware of. Router sees the server pc ok with its fixed ip address.

Some routers just have a feature to segment/segregate the WiFi network, so the WiFi connections can not see or connect to devices on the wired network.
Some ISPs even have this feature enabled as default, so if you have reset your router, then it might suddenly have become active.

thanks wally. The other wifi devices on the network are seen but not the android wifi devices wont connect using an internet browser.

Ok, then is the android running some VPN connections or have other DNS servers configured or maybe even have DNS-over-HTTPS enabled?

By the way, to telnet you should specify the HA port:

telnet 8123

If you get a blank prompt, it’s successful; meaning that at least TCP connection was established with the HA web server.

just comes back with “connecting to port 8123, please wait” then hangs

No VPN, disabled it previously just in case. I havent specified any DNS servers, so assume its using the dns server by default in the router. Ive no experience with dns. Doesnt the dns service resolve a web name to an ip address? I am using a web browser to connect to HA with the ip add of the server so does it still use a dns request? (i’m a dns dummy)

If you use the IP address, then DNS is unimportant.
What IP address and subnet mask does you Android device show?
It is usually displayed somewhere under the network tabs in the settings apps.

I guessed that was the case thks for confirming it.
Ive had a bit of an unexplained win :expressionless:
I tried adding a group on the router to include all devices. It screwed the wfi devices, couldnt see any on the router when logged in. So I set it back to the default of no grouping the rebooted the router.
In rebooting the router back to normal and now I can acces HA using the ip address. So I think rebooting the router fixed it!
I tried telneting from the phone and it comes back with "bad status line ‘invalid http method’ ?? So its sees the server as it reports python server error,

While we are on a roll, I’ve never been able to access ha by using home assistant.local in a web browser. So do I have a problem with DNS on the Debian server?

Thanks for any input

Long ago I moved away from using the .local domain for anything because Android tends to be finicky about it. Sometimes by design it will refuse to connect if it thinks that it’s not being used strictly for mDNS.

.local is a domain handled only by mDNS.
If you have used .local as domain in your normal DNS, then you are in for trouble.

mDNS is not using a dedicated central server, but select their own server on the devices that use mDNS on the local network.
It can be a bit of a mess to figure out where it goes wrong and like odwide I have just given up on mDNS and use either IP address or a DNS address from my router, which pair its DHCP entries into a DNS service.

Ok thanks for clarifying that. More to digest :grinning:

Thanks for that very useful info. It’s never worked for me but didn’t and don’t know enough to solve why

Its time for me to allow access of HA from external to the router (ie not on my local network) I will use a vpn. If someone would point me to a good description of the best way to do it I would appreciate it. (currently HA on docker on debian server)

how to set up your vpn might depend on what systems you have… e.g. i have a synology nas and i run openvpn on it. how to set that up is specific to synology. some network systems like ubiquiti also have vpn support.

however barring something like that, you might check out tailscale if it’s just for home use. they have a free personal tier for 3 users.