Weishaupt integration

Hi There,
Anyone using wemportal.com, and weishaupt?
Thank you

B/rgs Mads

hey mads,

long time ago but just to let you know: I created a weishaupt wemportal.com solution for homeassistant. check it here or here.

If you want to know, how you can integrate it into Home Assistant just let me know and I will share the way how I did it.

Currently I am reading out all values from the first site of wemportal.com and displaying them in Home Assistant lovelace dashboard.
Another thing is that I enable or disable the water heating with gas depending on the solar energy.


hi dirk,

i would like to integrate your solution in my Home Assistant but i sadly don’t know how.
I tried as “python_scripts” but this doesn’t allow “import” so i get everytime an import error if i run the script.
I only need the status script so if you could tell me how i integrate your solution this would be very nice.

Best greetings

  1. put them in “scripts” not “python_scripts”

  2. use a sensor in configuration.yaml

  - platform: command_line
    name: heating
      - "aussentemperatur_aktuell"
      - "aussentemperatur_minimum"
      - "aussentemperatur_maximum"
      - "warmwassertemperatur_aktuell"
      - "vorlauftemperatur_aktuell_hzk1"
      - "istleistung_aktuell_we0"
      - "kesseltemperatur_aktuell_we0"
      - "anlagendruck_vpt_aktuell_we0"
      - "weichentemperatur_aktuell"
    value_template: "dummy"
    command: 'python3 /home/homeassistant/.homeassistant/scripts/wem_status.py'
    scan_interval: 600
    command_timeout: 60
1 Like

Thanks for the fast reply. Can you tell me why i get a error:
[homeassistant.components.command_line.sensor] Command failed: python3 /home/homeassistant/.homeassistant/scripts/wem_status.pt

Why is the file ending with pt and not py

And also ensure that the fits the location of your installation…

I dont realy know why its end with “.pt” in die errormessage. In the scripts folder its ends with “.py”
i changed the location to ‘/config/scripts/wem_status.py’ because i tried to start the script via ssh but it doenst work too. “-bash: python3: command not found”
I dont get it, its look like python3 is noch installed but i took the standard Image from: Home Assistant Site and this must contain python3?!

Ps.: Sorry for that maybe dumb questions but im new to Homeassistant and dont have so much programming-skills :see_no_evil:

maybe your python3 is linked as python. just try to execute the command with python instead of python3

yeah i tried it already but it doesnt work…
I read about my problem in a few topics but there was never a “real” solution. I gonna install Home Assistant by my own on a fresh installed rasbian. Hopefully it will work after ths step. :thinking:

Anyway thanks for your support!

Nailed it! After 2 hours of configure the Raspbian system i finally did! Thanks a lot for your work Dirk!

Hi dirk! (its me again ;D)

i have one last question. Do you have a nice card-config? I added it on a site with a sensor card but there is just the “dummy” and with a click on it, the single attributes will shown.

Do you have something nicer solution?
Best regards

This command line sensor has several attributes were the concrete data is stored. You need to add a new sensor for every attribute that you want to directly show within your user interface.

Add this to configuration.yaml and duplicate the sensors content for every attribute that you want to use within ui.

- platform: template
        friendly_name: "Heizung - Außentemperatur Aktuell"
        value_template: "{{ states.sensor.heating.attributes.aussentemperatur_aktuell }}"
        unit_of_measurement: '°C'
        device_class: 'temperature'

Happy to hear that it works in general.

Best, dirk

1 Like

Nice Thank you!
I need to check the params because some values are in the wrong variable but i will check this tommorow.

@dm82m Your github repository seems to be deleted. Do you have a version of wem_status.py for me, please?

hey @dechris,

I went away from using my own solution and switched to a version based on Chromium and Selenium by Neiser on Github.

My reworked, ready to use solution for HomeAssistant can be found here: https://github.com/dm82m/wemportal-scripts

Feel free to use it. It consumes more memory but is way more stable compared to my old solution.


1 Like

I think your solution (install of additional packages) is not compatible with the home assistant standard appliance (hassos). Does somebody know how to get the requirements in my machine?

You need to install the chromium-driver and also the Python selenium package

I installed the chrome browser via web terminal add-on

apk --update add chromium-chromedriver
1 Like

does it work then with this installation? python package install should not be a problem at all…

I got it work in the Terminal, but it does not work as a sensor.

Protokolldetails ( ERROR )
Logger: homeassistant.components.command_line.sensor
Source: components/command_line/sensor.py:101
Integration: command_line (documentation, issues)
First occurred: 6:55:27 (1 occurrences)
Last logged: 6:55:27

Command failed: python3 /home/homeassistant/.homeassistant/scripts/ExportFachmannInfos.py

@Ph4t0n: How did you fix the problem with the Command?

I guess its system specific. I would suggest to check the user that runs HomeAssistant on your system and then switch to that user on the system and run the command as that user. You should then be able to see a more detailed error log.

Another idea: go to “developer tools” -> “logs” -> “show full log” and check what kind of errors are shown there.

I tried to get more information with the logger and the debug level. But no additional information.

2020-05-14 06:46:34 DEBUG (SyncWorker_1) [homeassistant.components.command_line.sensor] Running command: python /config/scripts/ExportFachmannInfos.py
2020-05-14 06:46:34 ERROR (SyncWorker_1) [homeassistant.components.command_line.sensor] Command failed: python /config/scripts/ExportFachmannInfos.py
2020-05-14 06:46:34 WARNING (SyncWorker_1) [homeassistant.components.command_line.sensor] Empty reply found when expecting JSON data

I tried different combinations with python vs python3 and another path.

Do you have any plans to make an implementation as a seperate component for home assistant? I think my scenario (HassOS) is the default one for home assistant and is used by the most people.