Wemo discovery very flaky

I’m running the latest version of HA (0.87.1) and are still seeing very intermittent wemo discovery for about the last four updates.

Here is my log file.

2019-02-13 10:03:44 WARNING (Recorder) [homeassistant.components.recorder.migration] Database is about to upgrade. Schema version: None
2019-02-13 10:03:49 WARNING (MainThread) [homeassistant.components.device_tracker] Duplicate device IDs detected jorgie
2019-02-13 10:04:10 ERROR (SyncWorker_12) [homeassistant.components.wemo] Unable to get description url for WeMo at:
2019-02-13 10:04:27 ERROR (SyncWorker_12) [homeassistant.components.wemo] Unable to get description url for WeMo at:

Anyone else having wemo issues??

Mine didn’t even show up at all under auto discovery. I had to add them to the config manually:

#Add Wemo Devices
  discovery: true

The “discovery: true” makes no difference to my setup. I have DHCP reservations for the devices themselves.

Even now, one only intermittently makes an appearance. Probably firmware, but the Wemo control and configuration software is simply so bad I can’t get it to acknowledge that there’s an update available. I had been using “Wemo Automation Manger” which is a 3rd party Android app until I migrated to Home Assistant; I abandoned the official Wemo software very quickly. I only use them because the light switch is tidy looking and I’ve been able to pick a bunch of them up cheap second hand.

I too am using static ip…

discovery: false
- #Garage Door Lights
- #Bookcase
- #Front Door Light

If I change to discovery: true it’s even more flaky.


I forgot to mention that I can always see all three wemo devices with the wemo app even though HA can’t see them sometimes…

One of mine has the same issue and I’m sorry, but I’ve still not found a solution. I don’t know why it would not talk to HA in particular, as I don’t know enough about the protocols. Does the WEMO app suggest firmware updates for all or any of your devices?

All of my Wemo’s are running the latest firmware.
The discovery is random… Sometimes all of the Wemo’s switches show up as “entity not available” then after multiple reboots I get random switches online and eventually all of them.

I have this same issue it seem to work from time to time and then “Unable to get description url for WeMo”. I have set it up as static too but it seem to flake out at times. Only issue is it detects switches and my coffer machine but not the Crockpot. Very odd.

I got rid of all my wemo switches and am now using Leviton switches with no issues.

1 Like

Why does wemo break every other update? Everytime I think it is fixed I upgrade to broken wemo integration. This is the kind of stuff that made me give up on OpenHAB.

Actually my Leviton switches stopped working after 0.95.4 update!

I am doing a fresh install on pi3, and now none of my 4 wemo switches are detected… how do we fix this?

Manually configure them. I find they are mostly auto-discovered. Also check if they are showing as an integration and add that if they are.

Yes, I realize I can manually configure them.

auto discovery used to work, but now stopped working for me, still wondering why.

I found discovery flakey a long time ago and did a manual config but in a recent version of HA they added an integration so I removed my manual config and use that. It does occasionally come up as unavailable when I restart HA but a restart normally fixes that.

This has been an ongoing problem. I don’t know enough about the discovery logic, but I would love to have a back door where I can simply enter the ip address of the device and it’s name. I will often restart Hass.io but the random dropping of the same or different Wemo device keeps me from doing so. My front lights are on a shelly 1 switch and I can use a browser to get to the device but HA won’t recognize it without a restart - where I risk losing a different one.

Is it possible to edit the entity database or some such thing? How about a “Discovery-Add” button on the Developers Tools page where the discovery runs and only adds new devices found? Is this possible?

I see the entry in the “core.entity_registry” file yet it is not in the states list in developer tools. Why not “Unavailable” there if it’s in the registry and let me change it to “Available” or ready or off, etc. to get it back?

You CAN manually configure them! Check the docs.

1 Like

My wemo switches were the start of my home automation journey, but I had to abandon them earlier this year. They started not being able to rejoin my wifi network after my router was offline for a bit, unless I manually reset them every time. I couldn’t handle it, and replaced them with tasmota-based switches.

Funny I had the exact same experience… But I think in the end I kinda identified it as either I didn’t have enough IP addresses allocated to DHCP or it didn’t like the mac address reservations I was using or it didn’t like my network… I did get some Xiaomi and Sonoffs as well but that one WiFi Wemo switch (my first smart device) has worked flawlessly ever since… Maybe there was a firmware update or something like that… dunno… but it’s working fine now anyway and has been for 2 years.

That wasn’t it. I had reserved addresses for them so I could manually specify their IPs in HA. Anyway, they’re long gone now – and good riddance!

Hi David.
I have static ip addresses for all my wemo switches including a shelly or two.So my config file has them manually configured. What I was hoping to do was add it back in when Hass.io is running. Like I said, it’s in the core.entity_registry and I can talk to the device using a browser sowing it’s working.
The only problem is that the last time I booted the Raspi, it didn’t find one of them (pick one). If I reboot, it’s a grap shoot which one will fall off as unavailable. Since they work, and they’re in the registry, why not simply tell HA to use it anyway…

Is this what you mean by Manually configure them?