WEMOS D1 ESP-WROOM-02 Board type

Hello all, When I look up the board I get d1_wroom_02. But get ESPhome Error: Unknown board ID ‘d1_wroom_02’. Board D1 works but the pins are incorrect, was able to match a few GPIO’s but not all. Tried esp_wroom_02 also.
Anyone had any luck with these?

Thatt’s why i never use “customized” pin markings (like D1 etc…), only and exclusively “GPIOx”. One of bigger stupidities is “special” markings of gpio ports on various boards… nobody know why… only to confuse people…
Find pinout for this board, then use GPIOx and it won’t matter which board you have defined. That’s how i do and it works every time. Say, GPIO4 is GPIO4 on ALL boards, GPIO0 is GPIO0 and must be pulled up on all boards for succesfull boot, while D1, D2… is…well, you don’t know until you look datasheet for specific board.

I have never even seen a D1 esp-wroom board and its an esp8266, that was a surprise. Theres so many boards out there these days. I find it keeps things simple if you stick to the same 3 or 4 boards. A couple di-mini sized and a couple 30 or 38 pin dev boards. It also gives you the benefit of being able to stock esp hats/shields or extra gpio breakout boards to quickly put something together. An esp8266 is plenty capable of most things youd ever want to make.

I have maybe 20-30 devices around the house using the Wemos D1 Mini.

esp8266:
  board: d1_mini

Works every time.

Its my first choice board unless i need lota of gpios. I am starting to think i might be better off spending 20$ a piece for the new s2 and s3 boards though. All that extra horsepower and Ram for run of the mill gpio sensors. The performance increase must be huge!

WROOM2

This is the board, I tried d1_mini and it errors out. Had no luck finding the data sheet online. Used the ESP-WROOM-02 Pinout to follow and get a few matched but D5-D8 are under the chip.

What IS that board? Do you have a schematic?

OK, I found the board as an “18650 charger”.
It should be easy to manually flash ESPHome to it. What is the chip near the Micro USB connector? If it’s a UART then it should be easy to flash ESPHome to it.

The question is about the board name. Board name are found here. PlatformIO Registry

Just like the docs for esphome link to. Searching the platformio site leads here WeMos D1 ESP-WROOM-02 — PlatformIO latest documentation

The one thing I have experienced in the past is that the esphome version of platformio might be behind the latest, which may be a reason for esphome claiming it is an unknown board.

From the OP, I read that he was using “d1_wroom_02” for the board name. The PlatformIO link says to use “d1_mini”, which I suggested.

Here is a better photo of the board. The chip near the USB connector is a CP2102 UART, so it should be programmable from ESPHome or manually.

It looks like a neat board if you need a battery-eating ESP. I ordered one from AliExpress, as well as an ESP32 version. Just for experimenting.

Show your YAML file and what errors do you get?

Found the pinout ESP-WROOM-02 WiFi 18650 Battery Charger Board, Using esp_wroom_02 board and mapping the esp-wroom-02 function to the Pin name seem to be working.
Is this the best way to deal it?

binary_sensor:
  - platform: gpio
    pin: 0 #D3
    name: "rx"

switch:
  - platform: gpio
    pin: 2 #D5
    name: "laser"

Pinouts

Following table lists how pins on ESP-WROOM-02 + 18650 module are connected with ESP-WROOM-02 surface mount module.

Pin No Pin Name ESP-WROOM-02 Pin ESP-WROOM-02 FUNCTION
1 A0 16 TOUT / A0
2 D1 14 IO5 / I2C-SCL
3 D2 10 IO4/I2C-SDA
4 D3 8 IO0
5 D4 7 IO2 / UART1_TXD
6 D5 3 IO14 / HSPI_CLK
7 D6 4 IO12 / HSPI_MISO
8 D7 5 IO13 / HSPI_MOSI / UART_CTS
9 D8 6 IO15 / HSPI_CS / UART_RTS
10 RX 11 UART0_RXD / IO3
11 TX 12 UART0_TXD / IO1
12 3V3 1
13 5V N/A
14 GND 9

It does not say d1_mini for that board. It says d1_wroom_02

You’re right- I read it wrong.

follow because i have a govee wifi temperature sensor