What is the current statues with Hassio on ssd boot on a PI4 as i'm lost!

I need to set up a new instance of home assistant as my old one is all over the place so thought while i’m doing it i might has well SSD it. but i’m confused as to what or how it’s happening.

i have done the eeprom upgrade and i can see the drive in a normal raspian build etc. but when i try too boot off the drive i just get nothing, a few green light flashes and then it stops. this is with either the hassio image or the raspian image in the SSD which is a crucial BX500 ssd and a ugreen ssd to usb3 adaptor.

so in basics am i missing something completely, can you boot straight from SSD in hass and if so whats the route to take etc etc. there is just so much conflicting info out there i’m getting more list by the minute!!

I just got my pi4 booted and working without an SD card. Followed this here: https://www.tomshardware.com/how-to/boot-raspberry-pi-4-usb
Appears its out of beta and released in stable within the past 30 days or so

Where am I wrong?
I followed the instructions of this link https://tynick.com/blog/05-22-2020/raspberry-pi-4-boot-from-usb/, however on the net there are others but almost all the same, as mentioned I followed all the instructions without errors found, result if I insert an SD with the Raspian flash image it starts regularly (so the boot update procedure worked), if I flash the hassio image on the SSD it does not it starts, I don’t understand I just have to flash the HA or do I have to do other maneuvers to start home assistant from ssd?

1 Like

@gojonny: The Raspberry PI OS will boot without problems on SSD as you have found out.
When you say that the Hassio image does not work, I believe you mean HassOS?
HassOS use u-boot as bootloader.
U-boot does not yet support SSD (USB) boot on RPI4, and therefore HassOS can not boot from SSD until the u-boot developers have implemented that.

1 Like

Use raspberry pi os and do a supervised install.

1 Like

If you need a stable distro then I recommend you to try ubuntu 20.04 which is running 64bit and also bootable from USB SSD Drive. Then simply run supervised HASSIO and you are done.

my guide can be read [here](I add booting from USB for ubuntu 20.04 without microSD for those who need it and add Desktopify into it as a bonus. You can read my guide from here

And you can used my curl -sL https://raw.githubusercontent.com/krdesigns-com/supervised-installer/master/installer.sh | bash -s to install it

For the beta version of Hassio (5.1) there is now USB boot. Currently I’m running on a USB stick with great succes (https://github.com/home-assistant/operating-system/releases/tag/5.1)

Of cause as it is BETA there are likely some issues, eventhough I have not found the yet.

1 Like

cheers for letting me know about that, i’ll try and have a look over the weekend and see what i can do

dunno if i’m doing something wrong but i usewd bel etcha tpo put this image on the SSD


plugged it into the pi i get a couple of lines of text in white of the pie really quickly, starts to load the ssd, then stops and a black screen?!?!

Which brand and model of SSD adapter are you using? Not all of them work. As a test have you verified that the RPi4 can boot from an SD card in the USB 3.0 port? When the SSD is plugged in and the RPI4 is booted up are you able to ping the IP of the RPi4 from a PC or laptop?

You’re using the 64bit file correct?

I think he is not using 64 bit because that is named hassos_rpi4-64-5.1.img.gz

Right, That’s why I asked.

So here’s the link to the 64 bit version of 5.1 https://github.com/home-assistant/operating-system/releases/download/5.1/hassos_rpi4-64-5.1.img.gz

1 Like

no i wasn’t i was using the 32bit version. does it need to the be the 64bit one then? i’ll try that tongiht… and if so winner.

that is why i love this forum… it usually points out my stupidity

Agree the 64bit version is working rather stable. During the weekend I got most of my old setup up and running.

1 Like

i’ll try the sd card boot trick and also the 64bit version tonight see what happens.

i;m using a crucial 128gb ssd and the 2 different adaptors i tried are

As far as I have researched and tried myself the 64 bit is currently the only one that will work. I have yet to read anyone having success with the 32 bit. I think you’ll be golden! I myself just got help from a user as to why I was having issues with radio interference. This is what the forum is about!

1 Like

What do you think the future update process will be for you? Do you think you will have to do a fresh install when the SSD boot is officially supported?

Thank you . Perfect timing . I got this to work with the 64 bit version with samsung ssd and RPi-4 . The 32 Bit version didn’t work . So far everything looks great with the exception of my zha ( that is likely a unrelated issue )

1 Like