What is the current statues with Hassio on ssd boot on a PI4 as i'm lost!

I think he is not using 64 bit because that is named hassos_rpi4-64-5.1.img.gz

Right, That’s why I asked.

So here’s the link to the 64 bit version of 5.1 https://github.com/home-assistant/operating-system/releases/download/5.1/hassos_rpi4-64-5.1.img.gz

1 Like

no i wasn’t i was using the 32bit version. does it need to the be the 64bit one then? i’ll try that tongiht… and if so winner.

that is why i love this forum… it usually points out my stupidity

Agree the 64bit version is working rather stable. During the weekend I got most of my old setup up and running.

1 Like

i’ll try the sd card boot trick and also the 64bit version tonight see what happens.

i;m using a crucial 128gb ssd and the 2 different adaptors i tried are

As far as I have researched and tried myself the 64 bit is currently the only one that will work. I have yet to read anyone having success with the 32 bit. I think you’ll be golden! I myself just got help from a user as to why I was having issues with radio interference. This is what the forum is about!

1 Like

What do you think the future update process will be for you? Do you think you will have to do a fresh install when the SSD boot is officially supported?

Thank you . Perfect timing . I got this to work with the 64 bit version with samsung ssd and RPi-4 . The 32 Bit version didn’t work . So far everything looks great with the exception of my zha ( that is likely a unrelated issue )

1 Like

Thank you. I spent too much time trying to boot from SSD. The 64bit version with WD green 120GB and Geekworm X862 board.

1 Like

Were you able to get it to work? The Orico adapter is supposed to work is listed at https://jamesachambers.com/raspberry-pi-4-usb-boot-config-guide-for-ssd-flash-drives/ I tried a dark Orico case and it didn’t work. I have no idea if the UGreen adapter will work.

all sorted and working!!!

pi4 4gb

64bit image


1 Like

I read on an other thread in this forum of a user upgrading from 5.0 to 5.1, so I hope it will work to upgrade my current installation.

Just noticed that the 32 and 64 bit version is now in 5.2. Anyone tried it?

Edit: 64 bit version online and I’m now running it on a 8gb USB2 stick. Stable for 20 minutes and counting…


Are you running any zigbee devices on your system? I can’t see to pair any, using conbee2, tried zigbee2mqtt & deconz phoscon both.

Used the 5.4 64bit img

I did not used zigbee at the moment, but usb should work… unsure…

Managed to get my conbee2 to work. Surprisingly easy and frustrating, connected it to a USB hub then to the Rpi. SSD boots fine from USB3 port.


which manual have you used?
Have you installed Hassio Superviced in this way/

Thanks a lot!

Does anyone have any install instruction on how to install HASSIO onto an SSD on a RPi4 please?

Cheers - Works a treat!