What is up with my Hassio file directory?

Hi, loving home-assistant, although lynx and this Pi system is new to me.
The main problem I’m having, when following trouble shooting guides ect, my directory seems to be different from everyone else.
For Example: I’m directed to folder, config/custom_components a lot, but I did’t have this folder. I created it myself. But now of course the files i’m looking for within are not there.

Anybody know what I could be doing wrong?
Thanks in advance…

If you’re being directed to the custom_components directory then one can only presume you are following some instructions for a custom component, the installation instructions of which would have told you what to put in the directory (and to create it first if it wasn’t already there).

1 Like

This is one issue, i’m trying to sort…

So, I think your saying, I need to create custom_components folder myself?
So, the parameters for my Tuya thermostat, are held where?

You have the safe source of your Tuya code into home assistant (do not download it from internet), tuya is part of the package in home assistant 0.92.2… Mine is located in the following directory (HA is running in a virtual environment on raspberry pi with Python 3.7.2 installed):

I just copied all the files from the previous directory to <config_dir>/custom_components/tuya/

and then, make “homeassistant” as owner of these files (command chown) and modified the climate.py program…

Restart HA and then you should have a message in “home-assistant.log” saying that you are using a custom components for tuya, example of the message:
2019-05-11 16:13:22 WARNING (MainThread) [homeassistant.loader] You are using a custom integration for tuya which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you do experience issues with Home Assistant.

That’s it !

Then why is my srv directory empty?
Thanks for helping…

Tuya is an integrated component now, no custom component required. If there is a fault make a bug report.

Maybe i’m trying to hard…
lol, Can’t find bug reporting anywhere…
agh, my head hurts…

This fault seems to be long standing… googling **tuya thermostat hassio**, seems lots of people have this issue, and have done so for a long time?

The official documentation includes details of finding bugs.

And yes, lots of people may have had problems, but that doesn’t mean it’s relevant to your setup - particularly if they’re using the old custom component and you’re not. Lots of people think that Hass.io is Home Assistant too, rather than a way of installing Home Assistant :wink:

1 Like

Think this maybe far to complicated for me…:sob:

If anyone knows of a fix for HA reporting TUYA thermostat temp, at double what is should be…
Please please, let me know. My head is done looking at this.
Desperate to fix this one!
Thanks again…

Please take a moment to read the stick post. That guides you through how to get help.

For instance, that’s the first time you’ve mentioned at all what the problem might be:

Is it really double? Is it just reporting in F rather than C?

There’s more, obviously, and that guide will help you help us help you :wink:

It’s exactly double. What im reading it’s because tuya use a step of 0.5, as where HA use a step of 1.
It’s so frustrating, is it really so difficult to divide a number by 2?
My understanding was open source means anyone with knowledge could fix this, like a community thing.

I’ve tried to read the sticky post above, maybe my brain has already taking in too much.
Not sure where to go from here? Just know I need to divide the HA output by 2, really is as simple as that.
If only eh?

I really need help with this, im feeling frustrated…
If only eh?

You’re confusing a lot of things here.

Yes, it is open source. Yes, you can contribute a fix if you like. If anyone else has had this same issue, found the fix and not submitted it, why?

You’ve kind of jumped in the deep end without really reading a lot of the documentation explaining custom components and how they work.

1 Like

I see lots of people with this issue, and lots of different fixes. I cant copy them, because I cant even find the directory’s I need.:sleepy:

here is same as my problem, Smart Life (tuya) show wrong temperature

be great, if somebody could take a look…

Because you haven’t read the documentation to UNDERSTAND the structure.

custom_components is a directory YOU create. If you want a custom component IN that directory, YOU have to put it there. The system doesn’t know what you deem a custom component unless YOU specify.

but how can I modify what is not there to begin with?

Same here, i’ve “solved” by modify the climate tuya py in custom components

I’m curious how you can link to that thread, quote that exact line and not continue reading that same post. He actually tells you the full steps.

Full steps:

  1. in homeassistant custom_components folder create a folder named climate
  2. then homeassistant custom_components/climate folder:
    wget https://raw.githubusercontent.com/home-assistant/home-assistant/master/homeassistant/components/climate/tuya.py
  3. edit the custom_component as described above

So based on this detailed guide, you create a custom_components folder, then inside that you create a climate folder, then you need to copy the tuya.py file from that link into that folder (wget is a command line option to grab that file, but you can manually browse to it, copy the contents and create the file manually.

tried that, I just get 404 file not found.

then I read this:

You have the safe source of your Tuya code into home assistant (do not download it from internet),

Looks to me like you need to create a tuya folder in custom_components, then copy climate.py to it and edit climate.py to do what you need.

But, from where to I get climate.py?

click on the link @flamingm0e provided, it has the files there

1 Like

Did you look at the link I sent?

:smiley: Awesome, thanks. I will take a look when I get back from school run.:star_struck: